always on the red button when switching on

hi again, first problem for ages and ages, and its only a minor one! every time i switch the box on in the morning its always on the red button channel, whereas it was set up to be on 1, any ideas?
 

Trev

The Dumb One
Use the startup package (or boot or whatever it is called) to set your startup LCN 1 or whatever you want.
 
Last edited:
OP
B

bixieupnorth

Member
power on channel thing is set to 1 and favourite 1, but it always reverts to channlel 200 and TV, how do i change this then, part from removing disable ota?
 

MikeSh

Well-Known Member
power on was superseded by boot settings (or the like, not certain of exact names). Whichever, it may have been disabled for some reason in which case running fix flash pkgs (or the like) may sort it out.
 

Black Hole

May contain traces of nut
boot-settings (or power-on-channel, whichever) can only take effect at boot time. If your box is not booting (because it isn't off, even if you think it is), boot-settings can't take effect. See Things Every... (click) section 18.

Sort out whether the unit is properly going into standby, and clear any crash remnants by going to WebIF >> Diagnostics and selecting fix-flash-packages in the Select Diagnostic box.

The disable-ota package is less necessary now, but still desirable (see Preventing External Events from Disturbing the CF - click), and a daily scheduled reminder (actually a pair of them) is necessary to prevent the EPG becoming stale while you are on holiday. disable-ota has a setting under WebIF >> Settings to select whether you want it to set up a reminder or not - my bet is that it is set to "yes". Set it to "no" and manually delete the 0420 reminder from your schedule, or (preferred) edit the 0420 reminder to whatever service you want at the start of the day and set up another daily reminder for 0400-0420 on a different service (eg 200) - this is the strategy required to prevent the EPG going stale and your unit failing to record anything after a week.

PS: I'm quite happy to have my units defaulting to 200 - no chance of audio blasting out at turn-on.
 

Brian

Administrator
Staff member
The disable-ota package is less necessary now, but still desirable (see Preventing External Events from Disturbing the CF - click), and a daily scheduled reminder (actually a pair of them) is necessary to prevent the EPG becoming stale while you are on holiday. disable-ota has a setting under WebIF >> Settings to select whether you want it to set up a reminder or not - my bet is that it is set to "yes". Set it to "no" and manually delete the 0420 reminder from your schedule, or (preferred) edit the 0420 reminder to whatever service you want at the start of the day and set up another daily reminder for 0400-0420 on a different service (eg 200) - this is the strategy required to prevent the EPG going stale and your unit failing to record anything after a week.
I have never found it necessary to set daily scheduled reminders to prevent the EPG from becoming stale while on holiday, as long as you have a number of scheduled recordings taking place during your absence.
 
OP
B

bixieupnorth

Member
same result this morning despite adding the boot settings, did this before i saw black hole's detailed reply tho, what have i done wrong??

just ran the fixflashpackages thing

i guess its a simple solution to leave it on 200, but its the favourites not being set that peeves me every day, again not a biggie tho!
cheers
 
Last edited:

Black Hole

May contain traces of nut
I have never found it necessary to set daily scheduled reminders to prevent the EPG from becoming stale while on holiday, as long as you have a number of scheduled recordings taking place during your absence.
That's OK as long as the unit is power cycling. If it's left on, the EPG goes stale.
 

Black Hole

May contain traces of nut
same result this morning despite adding the boot settings, did this before i saw black hole's detailed reply tho, what have i done wrong??

just ran the fixflashpackages thing

i guess its a simple solution to leave it on 200, but its the favourites not being set that peeves me every day, again not a biggie tho!
cheers
1. Have you set up the boot-settings package in WebIF >> Settings? What channel did you set there?

2. Have you located the 0420 OTA reminder entry in Guide >> Schedule (yellow) >> (select entry) >> OK and edited the reservation to your preferred service (bearing in mind that if the TV happens to be on at the time it will produce audio)?

If you've done 2 (if applicable), I have no idea why it would still be coming on at 200 first thing. It certainly shouldn't come on at 200 subsequently in the day.

As mentioned above, boot-settings only takes effect at boot time. My units never sleep, so it would be no use to me!
 
OP
B

bixieupnorth

Member
hi, sorry for the delay, long day at work!

yes i set up within boot-settings, channel 1 and favourites 1

i haven't attempted 2 yet tho, this is actually on the unit itself?
 

Black Hole

May contain traces of nut
Yes. But that doesn't answer whether the unit is actually booting (and if it is, why boot-settings isn't working).
 
OP
B

bixieupnorth

Member
i've no idea? i just find it odd that it only recently started to change the channel to 200, maybe 7-10 days ago at the most? i havent updated anything for ages. is disable-ota still necessary? is there nothing that can override these things to keep my favourites? what is a boot anyway. i switch it off at night, and it comes on again when disable-ota activates at 0400 or so
sorry for being a numbskull!
 

Trev

The Dumb One
That's if you can wade through everything when you don't really know what you are looking for.:frantic:
You explain Delinquent thingy, what the consequences etc. are, fine. But the question is: How can you tell whether the box has fully booting on wake up? Is there a log or something that will confirm or deny a full boot?

'We' have suggested that his box might not be fully booting, (post#15) but not told him how he can tell if it is or isn't.
Pointing someone with limited knowledge, such as myself' to the Things Every sect 18 is not a constructive way of helping someone unless the fine detail required is in things every and in this case, it isn't.
I don't know how to find if my box is fully booting or not and section 18 doesn't tell me how.

For instance the redring log on my box has the following entries
Code:
727 [RR] Fri Jul 7 04:40:04 2017: Standby ring dim detected.
726 [RR] Fri Jul 7 04:40:03 2017: Changing to dim blue.
725 [RR] Fri Jul 7 04:40:03 2017: Ring trying to go amber.
724 [RR] Fri Jul 7 04:40:02 2017: Standby ring dim detected.
723 [RR] Fri Jul 7 04:40:02 2017: Standby ring dim detected.
722 [RR] Fri Jul 7 04:20:02 2017: Ring going blue, full boot.
Does row 722 confirm a boot, or what will it say if the box is delinquent. This does suppose the OP has redring installed. There are also no entries for the boot that has just happened when I started my box.

A few of the bootlog entries are below from when I just switched it on
Code:
11 Micom Timestamp: 1499468936 - Fri Jul 7 23:08:56 2017
10 Starting humaxtv...
9 Starting webshell server...
8 Starting bootstrapd init.html
7 Cust FW 3.12
6 Fri Jul 7 23:08:51 UTC 2017
5 Boot: 2
4 TZ: BST
3 Micom Timestamp: 1499468931 - Fri Jul 7 23:08:51 2017
Does (say) row 5 or 8 confirm a boot? What entries will you get in the delinquent state?
The activity log looks promising
Code:
624 07/07/2017 23:09:25 - System booted (Remote control handset).
623 07/07/2017 04:17:42 - System booted (Scheduled event).
622 06/07/2017 04:17:34 - System booted (Scheduled event).
But is it definitive? What entries will you get in the delinquent state, if any?
 

Black Hole

May contain traces of nut
I think it is clear in 18 - if the disk doesn't stop spinning and the network lights don't go out within a minute of thinking you've put the unit into standby, then it's in the delinquent half-awake state. If it doesn't achieve standby, then it can't boot (it is already running when you start it up again). So much, so straightforward.
 
Top