Auto-unprotect not starting

ebbwboy

New Member
Auto-unprotect no longer runs on my HDR. It shows as installed but does not remove the flag.

It will work briefly when I force reinstall it but that does not survive a powercycle.

It hasn't been working since it automatically upgraded to 1.03.12 and I had to reinstall the CFW

Now uing the latest firmware 1.03.12 / 2.22 & all packages upto date

Any ideas, as I can't get to the bottom of it?
 

xyz321

Well-Known Member
From a telnet window try the following to see if the daemon is running:
Code:
ps uax
Also have a look in modinit.log, it may give some clues.
 

prpr

Well-Known Member
Are there lines in /var/log/modinit.log that look like this:
Code:
    Fri Feb 28 10:50:34 UTC 2014 - /mod/etc/init.d/S99auto-unprotect
 

4ndy

Forum Supporter
By coincidence I checked my modinit.log yesterday and rechecked today. Comparing it To the file on HDR2 it seems to end abruptly at the RS process. This be also be what OP has experienced.

This HDR is on 1.02.32 / 2.19 while HDR2 is running 1.03.06. Both are running webif 1.0.10-1

Code:
 >>> Contents of /var/log/modinit.log 6.46 KiB
=== Tue Mar  4 17:53:21 GMT 2014 - modinit - ===========================
=== Tue Mar  4 17:53:21 GMT 2014 - diag ===========================
Filesystem                Size      Used Available Use% Mounted on
/dev/root                17.2M     17.2M         0 100% /
tmpfs                    61.0M     36.0K     61.0M   0% /tmp
tmpfs                    61.0M         0     61.0M   0% /media
/dev/mtdblock1            2.0M    640.0K      1.4M  31% /var/lib/humaxtv
/dev/mtdblock2            2.0M      1.3M    716.0K  65% /var/lib/humaxtv_backup
/dev/mtdblock2            2.0M      1.3M    716.0K  65% /usr/browser/config-ocontroller-si-rootfs.txt
/dev/sdd1                 1.8T    687.6G      1.0T  40% /media/drive1
/dev/sdc1                 1.8T      1.5T    213.9G  88% /media/drive2
/dev/sdb1                 1.7T      1.0T    589.4G  64% /media/drive3
/dev/sda1                 1.7T      1.3T    273.2G  83% /media/drive4
/dev/sde1              1011.4M     41.4M    918.7M   4% /mnt/hd1
/dev/sde2               906.1G    651.2G    208.8G  76% /mnt/hd2
/dev/sde3                 9.8G      1.3G      8.1G  14% /mnt/hd3

eth0      Link encap:Ethernet  HWaddr DC:D3:21:65:B3:B7  
          inet addr:192.168.1.200  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:42 errors:0 dropped:0 overruns:0 frame:0
          TX packets:36 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:35219 (34.3 KiB)  TX bytes:4025 (3.9 KiB)
          Interrupt:16 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


  PID USER       VSZ STAT COMMAND
    1 root      1244 S    init
    2 root         0 SW   [migration/0]
    3 root         0 SWN  [ksoftirqd/0]
    4 root         0 SW   [migration/1]
    5 root         0 SWN  [ksoftirqd/1]
    6 root         0 SW<  [events/0]
    7 root         0 SW<  [events/1]
    8 root         0 SW<  [khelper]
    9 root         0 SW<  [kthread]
   10 root         0 SW<  [kblockd/0]
   11 root         0 SW<  [kblockd/1]
   12 root         0 SW<  [khubd]
   13 root         0 SW<  [kseriod]
   14 root         0 SW   [pdflush]
   15 root         0 SW   [pdflush]
   16 root         0 DW<  [kswapd0]
   17 root         0 SW<  [aio/0]
   18 root         0 SW<  [aio/1]
   19 root         0 SW<  [ata/0]
   20 root         0 SW<  [ata/1]
   21 root         0 SW<  [ata_aux]
   22 root         0 SW<  [scsi_eh_0]
   23 root         0 SW<  [scsi_eh_1]
   24 root         0 SW   [mtdblockd]
   25 root         0 SW<  [scsi_eh_2]
   26 root         0 SW<  [usb-storage]
   28 root         0 SW<  [scsi_eh_3]
   29 root         0 SW<  [usb-storage]
   31 root         0 SW<  [scsi_eh_4]
   32 root         0 SW<  [usb-storage]
   34 root         0 SW<  [scsi_eh_5]
   35 root         0 SW<  [usb-storage]
   37 root         0 SW<  [kpsmoused]
   38 root      1240 S    {rcS} /bin/sh /etc/init.d/rcS
   83 root         0 SWN  [jffs2_gcd_mtd1]
   84 root         0 SWN  [jffs2_gcd_mtd2]
  138 nobody     932 S    /usr/bin/dnsmasq
  144 root       812 S N  /sbin/utelnetd -l /bin/tmenu -p 23 -d -B
  192 root      1244 S    {S90settop} /bin/sh /etc/init.d/S90settop start
  254 root      363m S    /usr/bin/humaxtv
  293 root      1260 S <  {run-and-gun} /bin/sh /etc/mdev/run-and-gun
  408 root         0 SW<  [kjournald]
  458 root      1260 S <  {run-and-gun} /bin/sh /etc/mdev/run-and-gun
  475 root         0 SW<  [kjournald]
  506 root      1260 R <  {run-and-gun} /bin/sh /etc/mdev/run-and-gun
  552 root         0 SW<  [kjournald]
  624 root      1260 S <  {run-and-gun} /bin/sh /etc/mdev/run-and-gun
  657 root         0 SW<  [kjournald]
  752 root      1260 S <  {run-and-gun} /bin/sh /etc/mdev/run-and-gun
  777 root      1260 S <  {run-and-gun} /bin/sh /etc/mdev/run-and-gun
  783 root         0 SW<  [kjournald]
  785 root      1260 S <  {run-and-gun} /bin/sh /etc/mdev/run-and-gun
 1291 root         0 SW<  [kjournald]
 1307 root         0 SW<  [kjournald]
 1327 root      1228 S <  sleep 1
 1343 root         0 Z <  [echo]
 1352 root      1228 S <  sleep 1
 1361 root      1260 R <  {run-and-gun} /bin/sh /etc/mdev/run-and-gun
 1372 root      1252 S <  {modinit} /bin/sh /sbin/modinit
 1384 root      1260 R <  {run-and-gun} /bin/sh /etc/mdev/run-and-gun
 1385 root      1236 R <  ps -w
 1386 root      1260 R <  {run-and-gun} /bin/sh /etc/mdev/run-and-gun

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
default         192.168.1.254   0.0.0.0         UG    0      0        0 eth0

=== Tue Mar  4 17:53:21 GMT 2014 - reset all ===========================
=== Tue Mar  4 17:53:21 GMT 2014 - rma ===========================
=== Tue Mar  4 17:53:21 GMT 2014 - ugprade bootmod ===========================
=== Tue Mar  4 17:53:21 GMT 2014 - setup directories ===========================
=== Tue Mar  4 17:53:22 GMT 2014 - create modenv ===========================
=== Tue Mar  4 17:53:22 GMT 2014 - create rcS ===========================
=== Tue Mar  4 17:53:22 GMT 2014 - migrate bootmod ===========================
=== Tue Mar  4 17:53:22 GMT 2014 - setup hostname ===========================
=== Tue Mar  4 17:53:22 GMT 2014 - setup hosts ===========================
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
default         192.168.1.254   0.0.0.0         UG    0      0        0 eth0
    Interface: [eth0]
    IP: [192.168.1.200]
=== Tue Mar  4 17:53:22 GMT 2014 - run init ===========================
killall: bootstrapd: no process killed
Loaded FUSE module into kernel.
Loading config file /mod/etc/mongoose.conf
128+0 records in
128+0 records out
134217728 bytes (128.0MB) copied, 4.528037 seconds, 28.3MB/s
Setting up swapspace version 1, size = 134213632 bytes
UUID=95951f68-912e-4391-9cab-be70a65b16b8
Enabled swap file.
Anacron 2.3 started on 2014-03-04
Normal exit (0 jobs run)
rs: starting recmon...
=== Tue Mar  4 17:53:30 GMT 2014 - complete ===========================
rs: offering EPG...
No EPG data to send.
Error: near line 1: database is locked
Error: near line 1: database is locked


Sent from my iPad using Tapatalk
 
OP
E

ebbwboy

New Member
modinit.log shows:

/mod/sbin/auto-unprotectd: can't load library 'libinotifytools.so.0'


ps uax command shows:

Show list of processes

w Wide output
l Long output
T Show threads
but doesn't do anything when I select any of themthem.
Sorry, I'm a newbie with this.
 

af123

Administrator
Staff member
Can you run the reset-rcS diagnostic, then restart the box and see if it looks any better?
 

af123

Administrator
Staff member
@xyz321 - I think it's a library path problem with the rcS script. Same issue someone else had with a different package recently. The reset-rcS diagnostic just removes /mod/etc/init.d/rcS if it exists so the default one can be used instead.
 

4ndy

Forum Supporter
Sorry, my last post got saved before I had finished (several times). By the time I finished editing it, the conversation has moved on.

It looks like mine may be a different issue, but with a common cause.


Sent from my iPad using Tapatalk
 
OP
E

ebbwboy

New Member
This appears to have worked, log looks OK and has removed the flag on a recording after reboot.

I'll keep an eye on it but very happy at mo. Cheers af123 and everyone for your help.
 

4ndy

Forum Supporter
Thinking it might solve my issue, I ran the reset-rcS diagnostic and rebooted.

The modinit.log still seems to end prematurely.

Code:
>>> Contents of /var/log/modinit.log 6.17 KiB
=== Tue Mar  4 22:36:37 GMT 2014 - modinit - ===========================
=== Tue Mar  4 22:36:37 GMT 2014 - diag ===========================
Filesystem                Size      Used Available Use% Mounted on
/dev/root                17.2M     17.2M         0 100% /
tmpfs                    61.0M     36.0K     61.0M   0% /tmp
tmpfs                    61.0M         0     61.0M   0% /media
/dev/mtdblock1            2.0M    656.0K      1.4M  32% /var/lib/humaxtv
/dev/mtdblock2            2.0M      1.3M    692.0K  66% /var/lib/humaxtv_backup
/dev/mtdblock2            2.0M      1.3M    692.0K  66% /usr/browser/config-ocontroller-si-rootfs.txt
/dev/sda1                 1.7T      1.0T    589.4G  64% /media/drive1
/dev/sdb1                 1.7T      1.3T    270.3G  83% /media/drive2
/dev/sde1              1011.4M     41.4M    918.7M   4% /mnt/hd1
/dev/sde2               906.1G    663.8G    196.3G  77% /mnt/hd2
/dev/sde3                 9.8G      1.3G      8.1G  14% /mnt/hd3

eth0      Link encap:Ethernet  HWaddr DC:D3:21:65:B3:B7  
          inet addr:192.168.1.200  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:62 errors:0 dropped:0 overruns:0 frame:0
          TX packets:53 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:38230 (37.3 KiB)  TX bytes:6849 (6.6 KiB)
          Interrupt:16 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


  PID USER       VSZ STAT COMMAND
    1 root      1244 S    init
    2 root         0 SW   [migration/0]
    3 root         0 RWN  [ksoftirqd/0]
    4 root         0 SW   [migration/1]
    5 root         0 SWN  [ksoftirqd/1]
    6 root         0 SW<  [events/0]
    7 root         0 SW<  [events/1]
    8 root         0 SW<  [khelper]
    9 root         0 SW<  [kthread]
   10 root         0 SW<  [kblockd/0]
   11 root         0 SW<  [kblockd/1]
   12 root         0 SW<  [khubd]
   13 root         0 SW<  [kseriod]
   15 root         0 DW   [pdflush]
   16 root         0 DW<  [kswapd0]
   17 root         0 SW<  [aio/0]
   18 root         0 SW<  [aio/1]
   19 root         0 SW<  [ata/0]
   20 root         0 SW<  [ata/1]
   21 root         0 SW<  [ata_aux]
   22 root         0 SW<  [scsi_eh_0]
   23 root         0 SW<  [scsi_eh_1]
   24 root         0 SW   [mtdblockd]
   25 root         0 SW<  [scsi_eh_2]
   26 root         0 SW<  [usb-storage]
   28 root         0 SW<  [scsi_eh_3]
   29 root         0 SW<  [usb-storage]
   31 root         0 SW<  [scsi_eh_4]
   32 root         0 SW<  [usb-storage]
   34 root         0 SW<  [scsi_eh_5]
   35 root         0 SW<  [usb-storage]
   37 root         0 SW<  [kpsmoused]
   38 root      1240 S    {rcS} /bin/sh /etc/init.d/rcS
   83 root         0 SWN  [jffs2_gcd_mtd1]
   84 root         0 SWN  [jffs2_gcd_mtd2]
  138 nobody     932 S    /usr/bin/dnsmasq
  144 root       812 S N  /sbin/utelnetd -l /bin/tmenu -p 23 -d -B
  192 root      1244 S    {S90settop} /bin/sh /etc/init.d/S90settop start
  254 root      360m S    /usr/bin/humaxtv
  280 root      1260 S <  {run-and-gun} /bin/sh /etc/mdev/run-and-gun
  327 root      1260 S <  {run-and-gun} /bin/sh /etc/mdev/run-and-gun
  373 root      1260 S <  {run-and-gun} /bin/sh /etc/mdev/run-and-gun
  550 root      1260 S <  {run-and-gun} /bin/sh /etc/mdev/run-and-gun
  647 root         0 SW<  [kjournald]
  744 root         0 SW<  [kjournald]
  896 root      1260 S <  {run-and-gun} /bin/sh /etc/mdev/run-and-gun
  958 root      1260 S <  {run-and-gun} /bin/sh /etc/mdev/run-and-gun
  985 root      1260 S <  {run-and-gun} /bin/sh /etc/mdev/run-and-gun
 1045 root         0 SW<  [kjournald]
 1155 root         0 SW   [pdflush]
 1382 root         0 SW<  [kjournald]
 1404 root         0 SW<  [kjournald]
 1441 root      1228 S <  sleep 1
 1453 root      1252 S <  {modinit} /bin/sh /sbin/modinit
 1482 root      1228 S <  sleep 1
 1495 root      1228 S <  sleep 1
 1503 root      1228 S <  sleep 1
 1505 root      1228 S <  sleep 1
 1509 root      1236 R <  ps -w
 1510 root      1260 R <  {run-and-gun} /bin/sh /etc/mdev/run-and-gun

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
default         192.168.1.254   0.0.0.0         UG    0      0        0 eth0

=== Tue Mar  4 22:36:38 GMT 2014 - reset all ===========================
=== Tue Mar  4 22:36:38 GMT 2014 - rma ===========================
=== Tue Mar  4 22:36:38 GMT 2014 - ugprade bootmod ===========================
=== Tue Mar  4 22:36:38 GMT 2014 - setup directories ===========================
=== Tue Mar  4 22:36:39 GMT 2014 - create modenv ===========================
=== Tue Mar  4 22:36:39 GMT 2014 - create rcS ===========================
+ Creating /mod/etc/init.d/rcS
=== Tue Mar  4 22:36:40 GMT 2014 - migrate bootmod ===========================
=== Tue Mar  4 22:36:40 GMT 2014 - setup hostname ===========================
=== Tue Mar  4 22:36:40 GMT 2014 - setup hosts ===========================
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
default         192.168.1.254   0.0.0.0         UG    0      0        0 eth0
    Interface: [eth0]
    IP: [192.168.1.200]
=== Tue Mar  4 22:36:40 GMT 2014 - run init ===========================
killall: bootstrapd: no process killed
Loaded FUSE module into kernel.
Loading config file /mod/etc/mongoose.conf
128+0 records in
128+0 records out
134217728 bytes (128.0MB) copied, 5.691778 seconds, 22.5MB/s
Setting up swapspace version 1, size = 134213632 bytes
UUID=36cf2b1f-530d-4118-82e0-94981cd49efc
Enabled swap file.
Anacron 2.3 started on 2014-03-04
Normal exit (0 jobs run)
rs: starting recmon...
=== Tue Mar  4 22:36:51 GMT 2014 - complete ===========================
rs: offering EPG...
No EPG data to send.
Error: near line 1: database is locked




Sent from my iPad using Tapatalk
 

af123

Administrator
Staff member
You're on an old custom firmware so the diagnostic won't do much for you. That log looks ok to me though.
 

4ndy

Forum Supporter
Thais af123. I will update the CF tomorrow. I didn't think there was much changed recently.


Sent from my iPad using Tapatalk
 

xyz321

Well-Known Member
@xyz321 - I think it's a library path problem with the rcS script. Same issue someone else had with a different package recently. The reset-rcS diagnostic just removes /mod/etc/init.d/rcS if it exists so the default one can be used instead.
Sorry double crossed posting :eek: Your solution crossed with mine at which point I realised yours was much more plausible so I deleted mine. Your post then crossed with the deletion.
 
OP
E

ebbwboy

New Member
This appears to have worked, log looks OK and has removed the flag on a recording after reboot.

I'll keep an eye on it but very happy at mo. Cheers af123 and everyone for your help.


Yep this is now back to working a treat, Thanks af123 for your advice and all your good work on the CFW
 
Top