BootHDRmode failing


New Member
Decided to try BootHDR for the first time on my HD-Fox T2 and am having problems booting into HDR mode.

I initally installed the BootHDR package via the WebIF and it took a long time downloading all the necessary stuff. I was accessing the WebIF on my iPhone and I changed tabs in Safari during the install. When I returned to check the progress the page reloaded and I'm not 100% sure if it installed correctly. It says it is installed and I have even tried removing and reinstalling via telnet although it appears to just reuse the existing HDRfs directory for the reinstall.

Anyway, when I try to run bootHDRmode in telnet, I get this:

leaning up temp files...
Hdfoxt2# bootHDRmode
mount: mounting /dev/sda1 on /mnt/hd1/ failed: Device or resource busy
mount: mounting /dev/sda1 on /mnt/hd2/ failed: Device or resource busy
mount: mounting /dev/sda1 on /mnt/hd3/ failed: Device or resource busy
mount: mounting /dev/sda1 on /mnt/hd4/ failed: Device or resource busy
ln: /media/drive1/My Video/Video: File exists
ln: /media/drive1/My Music/Audio: File exists

Anyone got any ideas what is going on?


New Member
Ok, I have got this working - think it was due to using a 16GB flash drive rather than a larger hard disk.

One other question though...

I have a 640GB USB portable disk connected to the HD-FOX T2 via a USB hub and this works fine for recording etc. I am able to boot into HDR mode and copy recordings to the root of the drive, resulting in unencrypted video files which can be copied off the box via FTP.

Ideally, I would like to be able to reboot into HDR mode, attach a 16GB pen drive to the hub and then copy unencrypted recordings to the pen drive but I can't get this working. If I attach the pen drive in HDR mode (I have tried before and after boot up), then the media button on the remote does nothing. I can't browse the media on my hard disk to select a video for copying. I have tried formatting the pen drive in FAT32, NTFS and EXT3 without success.

Does anyone know if this is possible?


Black Hole

May contain traces of nut
AF may be able to look at why this is, but I think you need to accept it as a limitation of HDRmode - the HD-FOX is being tricked into running HDR-FOX code to provide access to the decryption functions, but obviously without an internal hard drive so no doubt it is somewhat confused.

There should be no difficulty copying the files, once decrypted, when you have rebooted to normal HD-FOX.


New Member
Apologies if this question is not pertinent, I am a new user. Is there a way to bootHDRmode into a (large enough) flash drive?


New Member
Black Hole, thank you for reading my post. I was making a reference to thewebtiger comment above "Ok, I have got this working - think it was due to using a 16GB flash drive rather than a larger hard disk." Do I understand well that BootHDR mode requires a hard drive to be connected to the USB? Or is there a way to get it running with a flash drive?

Black Hole

May contain traces of nut
The HD-FOX doesn't like all versions of UPD*, particularly large ones, because it doesn't have a full range of driver support. Normally people who want CF on a HD-FOX have a HDD connected, because the CF is mostly used to manage recordings and a HD-FOX with only a UPD is almost useless for recording on. One problem is that smaller UPDs are hard to find these days and it can be a bit of a lottery finding one which suits the HDR-FOX.

There will be no problem with the capacity of a (say) 2GB UPD for loading CF etc, there just won't be any room for recordings. What you need to do is install the CF, then boot the HD-FOX with a FAT-formatted UPD fitted. Go into the WebIF and you will get instructions about preparing the UPD to receive CF. More information here: Quick Guide to Custom Firmware (click).

Last edited:


Well-Known Member
I did have a HD-FOX set up with a 64GB USB stick (Ext2 format) for a while. I could record programmes and had the custom firmware installed. Unfortunately, when I attempted to boot into HDR mode the box just locked up and had to be rebooted.