BT hub with HDR-FOX T2

PSOK

New Member
I'm having difficulty accessing the custom firmware remotely (web interface) as I can't see to get my BT hub (Home Hub 3.0 type A) working to open up port 80 for access. When I test with e.g. yougetsignal.com the port remains closed. Has anyone else experienced this and is there a fix? (Or is there a better way?). Thanks
 

Ezra Pound

Well-Known Member
What a useful site (yougetsignal.com), I have added it to the WiKi page on accessing the Web-If remotely HERE. Sorry for stating the obvious, but you have set up port forwarding on port 80 for the IP address of your Humax haven't you. It's also a bit safer to use port translation if your router allows it, where you use say 123.234.111.222:12345 and then in your router forward port 12345 external to port 80 internal which is associated with your Humax's Intranet address of say 192.168.1.23, as the 12345 port number can then be any free port number and not the obvious HTTP port of 80
EDIT
You will also need to ensure that your external IP address (the 123.234.111.222 above) does not change, e.g.when you power cycle your router, your Internet Service Provider will allocate it a new IP address, so you need to use a mechanism to handle this (See link above)
 
OP
PSOK

PSOK

New Member
Thanks Ezra. Yes, I have certainly TRIED to set the link between port 80 and the HUMAX. It seems to say I've done it but its still not open. I understand your point on port translation but haven't yet found out if that is supported. I will go through the WiKi info tonight. thanks again
 

Mike0001

Well-Known Member
Thanks Ezra. Yes, I have certainly TRIED to set the link between port 80 and the HUMAX. It seems to say I've done it but its still not open. I understand your point on port translation but haven't yet found out if that is supported. I will go through the WiKi info tonight. thanks again


Go to Advanced Settings, Port Forwarding, Supported Applications. Click the button to Add New Game or Application. Call it HDR, and choose TCP, ports 80-80, translated to 1234-1234, then save. (Substitute your own number for 1234.)

Now go back to Configuration, and choose application HDR, Device (Your HDR), then Add and Apply.

Finally, watch the hackers and botnets congregate to attack your HDR and hack it!
 

prpr

Well-Known Member
I would strongly suggest nobody opens up insecure servers to the internet. Changing a port number is not really very safe.
If you want remote access, you need to:
  • use an SSH server (dropbear on the Humax)
  • change port 22 to something else of your choice (and port forward this on the router to the Humax)
  • use public/private key for authentication (and make sure you keep the private key private)
  • disable password-only authentication (to prevent dictionary attacks)
Then only you should be able to get in to the box (apart from the NSA and GCHQ that is :( ).
 

Dan7712

New Member
I'm having difficulty accessing the custom firmware remotely (web interface) as I can't see to get my BT hub (Home Hub 3.0 type A) working to open up port 80 for access. When I test with e.g. yougetsignal.com the port remains closed. Has anyone else experienced this and is there a fix? (Or is there a better way?). Thanks


I have the same setup as you. I personally use VPNs to connect into the Humax from outside my LAN.

I will have a look at setting this up tonight and see if I have any joy. I will let you know the results.
 
I would strongly suggest nobody opens up insecure servers to the internet. Changing a port number is not really very safe.
If you want remote access, you need to:
  • use an SSH server (dropbear on the Humax)
  • change port 22 to something else of your choice (and port forward this on the router to the Humax)
  • use public/private key for authentication (and make sure you keep the private key private)
  • disable password-only authentication (to prevent dictionary attacks)
Then only you should be able to get in to the box (apart from the NSA and GCHQ that is :( ).

And then, if you really must access the web interface remotely, use ssh port forwarding to reach it:
Code:
ssh -p <port number> -L80:localhost:80 <your public ip address>
 
Top