Cannot access through Samba

Gary

Member
Something has stopped working. I cannot see my HDR from my HD box anymore in the list of usb's (I can still see it as a media server) and windows can no longer connect to the drive.

Previously I could just type \\humaxhdr into windows explorer and up it would come. Now it doesn't find it. (I can ping humaxhdr and putty to it fine).

I can see people have had problems with an OTA upgrade but I think my box is protected from them. The webif shows :

Web interface version: 1.0.10-1
Custom firmware version: 2.17 (build 1699)
Humax Version: 1.02.32

I have tried hard reboots and uninstalled/re-installed the samba package. I think that maybe the samba package was auto upgraded and this may have caused the problem?
 

prpr

Well-Known Member
Does "netstat -tna|grep 139" produce any output if you Telnet (putty) to the box?
 

prpr

Well-Known Member
Looks like the Samba service isn't running. What does the Webif say (or "service" using Telnet)?
Try "service start samba" and see what happens.
Perhaps you need to check your /mod/etc/smb.conf file as well.
 
OP
G

Gary

Member
Ok, it wasn't running, so I started it like you said, and it now shows as running (but not autostart). Still cannot access from windows though

/mod/etc/smb.conf contains :

[global]
coding system = utf8
load printers = no
printing = bsd
printcap name = /dev/null
disable spoolss = yes
guest account = root
guest ok = yes
security = share
encrypt passwords = yes
null passwords = yes
server string = Samba HDR-Fox-T2
workgroup = WORKGROUP
netbios name = %h
client code page=850
character set = iso8859-1
case sensitive = yes
preserve case = yes
short preserve case = yes
interfaces = %h/24
hosts allow = 10.0.0.0/255.0.0.0 192.168.0.0/255.255.0.0 172.16.0.0/255.240.0.0 127.0.0.0/255.0.0.0
# The directories under /media are auto-generated and added to the included
# file. Any additional shares which are not under /media should be added
# to this file (/mod/etc/smb.conf).
include = /mod/etc/smb-hotplug.conf
 

prpr

Well-Known Member
Does repeating the above tests report anything now?
What about "smbclient -L 127.0.0.1 -N"?
 

raydon

Well-Known Member
Ok, it wasn't running, so I started it like you said, and it now shows as running (but not autostart)
You'll need to enable autostart for samba to start automatically at each boot. Use the Service Management page of the Web Interface to enable this, or enter 'service auto samba' from telnet.
 
OP
G

Gary

Member
I can map it from windows now, but strangely previous I mapped to humaxhdr/media but now that doesn't exist and I have to map to humaxhdr/my video.

However it still doesn't work from the humaxhd. Presumably because of the problem with media not existing. How do I map to hd to see my video (I tried My_Video but that didn't work).

I don't see why this has all stopped working all of I sudden. Think I need to stop the HDR auto updating the custom packages?
 

MontysEvilTwin

Well-Known Member
Due to discussions in a previous thread see here, various issues with Samba were ironed out, including a problem with mounting the '/media' folder directly. I believe the mount point in the SMB.conf file has been changed from the media folder to the My Video folder.
 
OP
G

Gary

Member
Ah ok that explains it. So how do I get the mount to work on the HD with network autoshares?
 

xyz321

Well-Known Member
Under "[ModSettings]/smb/mountname/" you should have "folder=media". Rename this to "folder=My Video".
 
OP
G

Gary

Member
mmm, I have this in /mod/settings/smb/HUMAXHDR :

folder=media
host=humaxhdr
mac=ABABABABABAB (only needed for wakeUp)
password=Password
shareFolder=off
user=User
wakeConstantly?
wakeNow?
 

xyz321

Well-Known Member
It appears in two different places in the filesystem - this is quite normal. The settings directory is normally accessed from /media/drive1/[ModSettings]/smb/HUMAXHDR via the Humax UI. However, you can access it from /mod/settings via telnet/FTP if you wish.

Using telnet:
Code:
cd /mod/settings/smb/HUMAXHDR
mv "folder=media" "folder=My Video"

Edit: Changed to /media/drive1 above since the user appears to be mounting from an HD not an HDR.
 
OP
G

Gary

Member
Thanks. It is all working again!

I cannot see the option (on the HDR) to disable auto update of the custom packages - please can you point me to it. Thanks
 

Black Hole

May contain traces of nut
It's a package - uninstall it.

That said, I have three HDRs all on auto-update, and this kind of thing happens very rarely (and when it does it's fixed very quickly). I recommend you leave it installed.
 
OP
G

Gary

Member
ok thanks. Perhaps I will live it there, after all I know where to come for some speedy help if it happens again :)
 
Top