cannot display this video mode error


Ive started getting this ever since i upgraded to 1.03.12 via an OTA. Makes no difference if I have stock or the cfw installed. The error is actually displayed by my TV and not the humax. It happens if i turn the TV off and leave the humax on, say if im nipping off to the shop or whatever.

Ive tried having the humax on 720p & 1080p, no difference. Powering both TV and humax off and back on sometimes fixes, other times needs a hard reset at the plug.

Definitely dont recall it on older firmware. I really like the new iplayer so dont really want to rollback...
This is still happening so have reported it via email to humax. Flashed up TV to latest firmware, no joy :(

Have you tried cycling through the format settings (v-format button on humax remote) whilst the TV is in this state.
Allow a couple of seconds after each press to see if TV detects change.
This will at least cause the HDMI connection to try to re sync.

On some TVs it's quite common for the sync to fail if the TV isn't turned on before the Hummy, if I remember correctly.
Also, on the TV if you do this...
  • select a different HDMI port (whether something is connected to it or not, it doesn't matter)
  • then go back and select the HDMI port the Humax is plugged in to.
Do you get the picture back?
Tried all of those Harvey/dma

Humax advised factory reset. Thats made it worse and the humax totally stopped displaying anything on the TV. took about an hour and downgrading to 1.02.28 before i got anything displaying again. I've tried updating the tv firmware as well to no avail. will email humax again but im not confident.

Im stumped as this was definitely never the case until recently.
One final question. Did you try a different HDMI cable? Sometimes a change of cable can help.
You could also try turning your TV up the right way. But I suppose if you don't have a picture. there's no point.;)
I'll get me coat on the way out.
Bit harsh trev :)

actually i didn't try another cable. I can borrow the cable from my XBOX 360 Slim. Will try that tonight.
Never got far with humax support so had some time to back up my files today and performed full factory reset with format.
Guess what! Issue still occours. No idea whats going on as its a recent development, only started a few months ago. takes 20 mins of power cycling box & tv to get video back

Im moving house hopefully over the summer and thinking of getting TIVO with Virgin, dont make me do it humax!!!!!!
Actually from a post on Philips website for a Philips monitor with the same error I've seen someone suggest a hdmi switcher so I've bought the same one off eBay, worth a punt!

If not I'll try rolling back, I player handy but not massively necessary.
Yes, an active HDMI switch box (which resyncs the HDMI by actively receiving it at the input and re-handshaking the output) could solve it. It would be hard to tell whether any particular switch box does that, but a matrix switch (more than one input, more than one output) would need to.
Well, as they said it works...

HDMI 3 Input Switch Hub Switcher Splitter Box Port for HDTV 1080p

our dedicated customer service will promises to resolve the issue in best way as possible to leave you with satisfied felling.
Why are they offering to chop down a tree?

Jokes aside, might work but I am a little worried by the power arrangements.
Just to update, Manual HDMI switcher does not resolve the issue. Its getting beyond a joke. By kid turned the TV off tonight and it took about 2 hours of powering off / on / mains power down / hit & hope. Fed Up. Need a button to handshake or something. Ive ordered a 3rd hdmi cable to be sure.
So what exactly does this do? Not sure if I want to throw more money at this issue, part of me is tempted just to ditch the humax :(
I would revert the firmware on the Humax if I were you.. I know you dont want to and I would be the same.. But there is is obviously something different on the HDMI handshake side thats not compatible with the Philips tv.

What is the TV model number out of interest?
Oh right.. i thought it was only occurring with the latest 01.03.12.

Just reading the TV firmware release notes..
v2.25 lists this:
TV has no video after startup when you connected a set-top box (STB) through HDMI. (Only applicable to country, France)

Try downgrading the TV firmware if you can find an old copy on the web and see if it starts working again.. maybe they did a bodge job fix for France and its broke it for other regions.. although I struggle to understand how that fix could be country specific..