cannot display this video mode error

Have you tried plugging the Humax into a different HDMI port on your TV? My Samsung TV kept regularly failing the HDCP handshake, so I moved it from HDMI2 to HDMI1 and it then worked perfectly. (Or at least it did for a couple of months, after which it started playing up again, so I moved to HDMI3 and all was fine again...)
Yes tried that Tony.

Chris you are on to something. i do recall flashing the TV firmware sometime in the last year on a whim. So I could have went from 2.2? to 2.25 with that HDMI 'fix' and then 2.26 recently to try and fix. You could well be right.

Ive got TPM62E_2.20 from some old driver site so i'll try that tonight after my wife finishes another game of thrones episode.
Good luck mate.
I'm still struggling to see how that fix would only apply to France.. Lol

Sent from my iPhone using Tapatalk
So what exactly does this do? Not sure if I want to throw more money at this issue, part of me is tempted just to ditch the humax :(
It's an HDMI matrix switch. That means it can feed any of its outputs from any of its inputs - in this case 4 in and 2 out (plus a decoded audio channel parallel with one output). In order to do this it contains electronics which independently negotiate HDMI links on the inputs and the outputs. In fact, every time anything changes on any of its inputs or outputs, all the HDMI links get dropped and renegotiated (annoying sometimes, but not a deal breaker).

The point is that the switch output may well co-operate better with the TV input than the Humax output does. I never understood how a manual 2-way switch was going to help, as I think I said before.
Thanks BH.. i'll have a think if im prepared to drop the £ on it. We are hoping moving house in a month and i might just get a Virgin Media Tivo and come up with a different solution for other media.

I've just finished some downgrades, TV on 2.20 and Humax on 1.02.07 and same error. So to be honest i havent a clue apart from hardware failure of some description?

Only other thing I can think of is install the latest CFW and run all the various disk repair tools on it? As sometimes it sounds like the drive maybe spins up differently - clutching at straws?
I think the tv firmware note was the giveaway.. It must be an inherent problem with the tele. I'd kick off to Philips.

Sent from my iPhone using Tapatalk
New hdmi 1.4 cable didnt make a difference

Philips had a fairly useless reply:

I've double checked the specifications of your TV - it seems that HDCP issue occurs. Every 8-10 minutes new protocol code is generated to connect both devices - that code needs to match - unfortunately in your situation it doesn't.
To connect devices I would recommend you to switch off both devices, unplug the HDMI lead, connect the TV first, and then Humax box.

I would recommend you to have the latest firmware on both devices - you have the latest one on the TV - as I can see there is a new software for your Humax box (dated: 01.07.2014) - please update the software.
There is a new humax firmware??

How old is the tv?
Surely with a fault like that that actually lists the fault in a firmware update, but doesn't actually fix it means the tv isn't fit for purpose?

Sent from my iPhone using Tapatalk
installed CFW / Web interface and noticed error below. trying to fix disk now


There appear to be some hardware problems with the internal hard disk on this device.

Disk pending sector count is: 1
Disk offline sector count is: 1

Go to disk diagnostics
Emailed them, worth a punt!

Don't hold your breath. Same problem with Humax and Yamaha and Onkyo amps too. Everything points to Humax as the source of the problem. On all their range!
well after a 6 hour fix disk, fixed the dodgy block and no additional errors reported. box still behaving the same, immediately booted into 'cannot display this video mode' so that was a red herring.

Yep Mike I do agree. hoping to track down a scart lead tomorrow and will try the tip Black Hole mentioned.. typical i threw out all my old cables a few weeks ago.
Connected to a different TV today (forgot to try and replicate the issue as they only had a shite aerial) Brought it home and reconnected - same issue was replicated instantly. working on getting a scart.
Why did you not try to Play a recording on the other TV? It sounds to me that your combo hummy TV just does not work. It is listed as a problem in firmware update so I would say it's the TV. Now you have to decide which to keep. Give detailed steps of what you tried on the other TV.