can't play with VLC plugin

merlin777

Member
I can't get videos to play in webif using VLC.

When i click on play a new page comes up showing controls and a play window. The play window is black with the VLC logo but nothing plays. I can click on the controls but they have no effect.

I have the latest firmware and latest VLC player (i loaded all options except mozilla).

Can anyone help, please?
 

Black Hole

May contain traces of nut
If it's the same as the HDR-FOX (it might not be), "Enc" means protected from decryption, and lack of "Enc" means "not protected" rather than "not encrypted" (the HDR-FOX WebIF displays "Dec" next to any recording that is decrypted).

However, I do have another idea, and that is that you need the VLC plugin for your browser, not just the VLC desktop program itself.
 

4ndy

Forum Supporter
Are trying to play from an external drive using mvdisks by any chance? That has never worked for me. I have reported this to af123 but no longer use mvdisks.

Sent from my GT-I9505 using Tapatalk 2
 
OP
M

merlin777

Member
Thanks for your responses.

I'm trying to play from the HDR's hard drive.

I thought the browser plugin was installed with VLC unless you chose not to. Please could you tell me where i can get it?
 

fenlander

Active Member
Does the Foxsat do this? In the case of the Freeview box, the output to VLC is from the Hummy's DLNA server, hence no need for decryption.
 

Black Hole

May contain traces of nut
Does the Foxsat do this? In the case of the Freeview box, the output to VLC is from the Hummy's DLNA server, hence no need for decryption.
I'm not sure, in the absence of other answers I am making the presumption the WebIF behaves the same as on the HDR-FOX, and I presume the OP means the "play" option - I don't think that uses DLNA does it?
 
OP
M

merlin777

Member
I did search for the vlc plugin for explorer but i couldn't find one to download and concluded it loaded with the vlc installer. during installation it lists optional extras and it looked like the IE plugin was included. If anyone can point me to a seperate download i'd be grateful.
 

fenlander

Active Member
I think the plugin is nominally for Mozilla, though once installed it also works in Chrome. I don't recall anyone using it in IE.
 

Trev

The Dumb One
I have VLC media player installed on my W7 PC (no browser patch) and it plays SD and unencrypted HD (settop patch) just fine. I go to Media ~ Open File. Then poke around my drives until I find my Foxsat HDR, double click a .ts file and away it plays. Simples. Is this not what you want to do?
 

raydon

Well-Known Member
The VLC ActiveX web plugin embedded into the Foxsat HDR's web interface Media Browser was working fine in IE10 until the latest v2.06 release of VLC. Fix is to roll back VLC to v2.05. The plugin is also broken for the HDR Fox T2's webif under IE10. I've already filed a bug report with VLC.
 
OP
M

merlin777

Member
ahh - quickfire round....

I've installed everything except the mozilla element.
I can already play in VLC from a file directly, it's the handy play function in the HDR foxsat webif I'm trying to use.
I'll go back to v2.05 and see if that works - do you know if it's available on the vlc site?
 
OP
M

merlin777

Member
Found it tucked away in an archive on the vlc website.

I rolled back to 2.05 but I still have the same issue: the play page comes up but the play window just shows a black frame with the VLC logo displayed in the centre. Buttons can be pressed but nothing happens.
 
OP
M

merlin777

Member
ok, tried that on both my W7 and vista laptops. both have 2.05 and i have restarted the browser but still same problem on both.
 

raydon

Well-Known Member
O.K. but I can assure you that it v2.05 works for me in Firefox, IE10, and Chrome. Have you tried using another browser ?
And bear in mind that you can only use the VLC web plugin to stream SD recordings, or unencrypted HD recordings (those made in non freesat mode, or with nowsters settop patch).
 
Top