can't update packages - latest firmwares applied...

simonmac2

New Member
screenshot.jpg
I've read the previous posts to try and sort this

I updated to the latest firmware 1.02.32/2.16 without any issue, and wanted to install the NFS server package. weirdly it comes up with a blank white box with an "ok" button . I know the package is available as I can pull it down using the browser, but don't know why the humax doesn't seem to be making the external connections
I tried doing it from the telnet session instead of the webif interface and get a wget error 4
I can ping externally (which answers the IP & gateway question), and am currently running fix-disk anyway.
Any ideas why it isn't making the external connections to download?

Thanks

Simon
 

af123

Administrator
Staff member
Well, wget error 4 indicate network failure, and I suspect the blank alert box in the web interface is the same thing (related the incremental ajax callback code), but that isn't consistent with your other tests.

What happens if you try and telnet to the package update server telnet hummypkg.org.uk 80 from the Humax command line?
 
OP
S

simonmac2

New Member
Perfect - many thanks af123

the fix-disk mentioned delete loops, so I told it to fix it and after the reboot..
I CAN was able to install from the package manager, update the package list from the net, and upgrade all packages using the package manager.
carried on doing some checks - all seemed well. I tried to copy a large file (7Gb) over to the humax (the original driver for mucking about in the first place) and the same error message (delete some files - not enough space yada yada - but there is over 200Gb free.

thought i'd go old school with it, and install the betaftp server on it and upload the file that way (rather than trusting the mapped drive in windows explorer) and I get the same wget error 4, can't update the package list from internet etc. again.

I don't fancy having to run fix-disk every day to clear out something in order to be able to update/install.

I looked at the fix-disk log and all I can see that it did was to create a lost+found directory on each partition. I'm going to run the fix-disk again and see if that permits me to install the ftp server on it. really frustrating.

All I am really after is to be able to copy large files across to the hummy, but can't seem to get there.
 

Black Hole

May contain traces of nut
You need to use FTP for this, we are aware the Humax doesn't advertise its disk space properly across a network share.

betaftp conflicts with the native FTP server, so make sure it is turned off (or use the native one - it provides adequate access for uploading media files).
 
Top