1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CIFS issues (again?)

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by Chris Walker, Jan 7, 2018.

Tags:
  1. Chris Walker

    Chris Walker New Member

    Back in June of 2017 I posted a question about NFS (https://hummy.tv/forum/threads/network-shares-automount-package-released.1126/page-35#post-111228).

    Following a recent update of my linux machine I'm finding that I cannot access the shares on my Humax HDR-T2 machine. I seems it's related to the samba version which is where I came in back in June.

    Is there a likelihood of an update to the Humax to enable my linux machine to access the shares or should I try and find a workaround in linux?
     
  2. prpr

    prpr Well-Known Member

    It seems hugely unlikely (IMHO).
    Yes.
    You probably need to tweak "client min protocol" in smb.conf and set it to "NT1". Which Linux are you running?
     
  3. Chris Walker

    Chris Walker New Member

    OK. I added the
    and set it to NT1. I then rebooted the Humax and then logged in to this machine which is running Mageia 6 linux. Uname -a produces this :- Linux Mageia6 4.14.10-desktop-1.mga6

    I still couldn't mount the shares on the Humax so looking at dmesg on this machine I saw this :-
    CIFS VFS: cifs_mount failed w/return code = -112
    No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not sup
    port SMB3 (or SMB2.1) specify vers=1.0 on mount.

    So I added vers=1.0 to the relevant lines in the /etc/fstab file. Still got the same error I'm afraid.
     
  4. Black Hole

    Black Hole Felinos Monk

    Why aren't you using an NFS mount (rather than SMB)? I believe NFS is more "Unixy". If you need SMB for Windows, they can both run at the same time.
     
  5. Chris Walker

    Chris Walker New Member

    I've never used NFS before, that's really the only reason. I've now installed NFS on the Humax and then reconfigured the fstab file on this machine and I can mount the usb drive which is attached to the Humax but I can't see the subdirectories such as the iPlayer folder. Ah, of course. <Slaps forehead with palm of hand> They're specified in the smb.conf file so looking at the nfs.conf, that's just 2 lines :-
    MOUNTD_OPTIONS=""
    NFSD_OPTIONS=""

    Doing a search I see that I need to amend the exports file. Ok. Assuming that goes well, you can assume that the problem is solved. Thanks for your help.