CIFS issues (again?)

#1
Back in June of 2017 I posted a question about NFS (https://hummy.tv/forum/threads/network-shares-automount-package-released.1126/page-35#post-111228).

Following a recent update of my linux machine I'm finding that I cannot access the shares on my Humax HDR-T2 machine. I seems it's related to the samba version which is where I came in back in June.

Is there a likelihood of an update to the Humax to enable my linux machine to access the shares or should I try and find a workaround in linux?
 
OP
OP
C
#3
OK. I added the
client min protocol"
and set it to NT1. I then rebooted the Humax and then logged in to this machine which is running Mageia 6 linux. Uname -a produces this :- Linux Mageia6 4.14.10-desktop-1.mga6

I still couldn't mount the shares on the Humax so looking at dmesg on this machine I saw this :-
CIFS VFS: cifs_mount failed w/return code = -112
No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not sup
port SMB3 (or SMB2.1) specify vers=1.0 on mount.

So I added vers=1.0 to the relevant lines in the /etc/fstab file. Still got the same error I'm afraid.
 

Black Hole

May contain traces of nut
#4
Why aren't you using an NFS mount (rather than SMB)? I believe NFS is more "Unixy". If you need SMB for Windows, they can both run at the same time.
 
OP
OP
C
#5
Why aren't you using an NFS mount (rather than SMB)? I believe NFS is more "Unixy". If you need SMB for Windows, they can both run at the same time.
I've never used NFS before, that's really the only reason. I've now installed NFS on the Humax and then reconfigured the fstab file on this machine and I can mount the usb drive which is attached to the Humax but I can't see the subdirectories such as the iPlayer folder. Ah, of course. <Slaps forehead with palm of hand> They're specified in the smb.conf file so looking at the nfs.conf, that's just 2 lines :-
MOUNTD_OPTIONS=""
NFSD_OPTIONS=""

Doing a search I see that I need to amend the exports file. Ok. Assuming that goes well, you can assume that the problem is solved. Thanks for your help.
 
OP
OP
C
#6
Assuming that goes well, you can assume that the problem is solved.
It worked for a little while but I've had a change of drives and now it's all stopped working. I have a 2TB USB drive hanging off the back of the box and despite specifying the mount in the exports file, I can't access it from my linux machine.

If I look at the permissions (the error in linux is 'mount.nfs: access denied by server while mounting hummy:/media/Hummy_Films/' it shows them as 'root root 69632 Jul 2 10:26 Films' whereas for the 'My Music' folder on the hard drive, they're shown as '1000 default 4096 Jun 27 10:34 My Music'. The linux machine can happily mount the My Music folder on boot and does so every time.

I tried doing a chown on the Hummy_Films but that made no difference. For reference, the settings in the /mod/etc/smb.conf file all specify the same permissions for the Media and the /media/Hummy_Films.

Where am I going wrong with this?
 
OP
OP
C
#7
Arrgghh.

Why is it that as soon as I post something, I see the solution? The answer was staring me in the face in #5. It was a typo in the exports file so usual, the problem lies between the keyboard and the chair!
 
OP
OP
C
#9
It happens - still worth sharing as others may experience it too.
Absolutely. I get annoyed when searching through a thread to find that the resolution hasn't been added. So here's the problem.

my /mod/etc/exports file looked like this :-
Code:
"/mnt/hd2"    0.0.0.0/0.0.0.0(rw,async,insecure,no_root_squash,all_squash,no_subtree_check,anonuid=0,anongid=0)
"/media/Hummy_Files" 0.0.0.0/0.0.0.0(rw,async,insecure,no_root_squash,all_squash,no_subtree_check,anonuid=0,anongid=0)
whereas the relevant line in the /mod/etc/smb.conf file looked like this :-
Code:
path = /media/Hummy_Films
Spot the deliberate mistake! I'd looked at that loads of times and yet I failed to spot it.
 
Last edited by a moderator:

Black Hole

May contain traces of nut
#10
I get annoyed when searching through a thread to find that the resolution hasn't been added.
Sometimes there isn't one.

Spot the deliberate mistake! I'd looked at that loads of times and yet I failed to spot it.
It is quite normal to see what you expect instead of what is actually there. The human visual system (and no doubt also the other senses) is not simply a camera; in order to make sense of what we "see" the scene is broken down into elements and triggers responses in the brain recognising "chair" or "horizontal line" (for example), and what we think we see is actually a mental impression based on a lifetime of experience - and we can't tell it isn't real (it is as real as it can be, but what's in your head isn't the photographic image it appears to be). Hence the unreliability of witness statements, and that you didn't see the cyclist coming even though you looked (briefly).

If at all possible, always have someone else check your work. The original author has a preconceived idea that it is right, and an actual inability to see anything else. It takes a great deal of experience as an editor to overcome preconceptions of ones own work.
 
Top