Custom Firmware -Removal Failure

michael.h

Member
I have been having some problems with my original Hummy running 1.02.32 and
CF HDR_FOX_T2_1.02.32_mod_2.18

Having followed the instructions given in http://wiki.hummy.tv/wiki/Remove_Modified_Firmware.
From the Web Interface I ran Menu select >> Diagnostics >> Set-Return-to-manufacturer (RMA) Mode.
However, after a reboot the 'RMA' message failed to appear on the units display in stead it displayed something about 'Cust Fw 2.18' during the boot.

Using Putty in telnet mode I made the following check
humax# ls -al which revealed
'lrwxrwxrwx 1 root root 11 Jul 12 21:25 mod -> mnt/hd2/mod'

I have tried diag setrma
which ran reporting no problem
Is this directory the cause of the problem? Should I remove the 'mod' directory with
humax# rm -r mod
this fails with the following message
'rm: can't remove 'mod': Read-only file system'

I ran the following
humax# cd mod
humax# ls -la
drwx------ 2 root root 4096 Sep 12 11:03 .
drwxr-xr-x 8 root root 4096 Sep 13 17:13 ..
-rw-rw-rw- 1 root root 108 Apr 8 10:19 .env
-rw-rw-rw- 1 root root 0 Oct 4 2012 .epgkeyword
-rw-rw-rw- 1 root root 0 Sep 9 10:27 .unprotect.last

Then I tried
rm: can't remove '*': No such file or directory
So I removed the three file individually

humax# rm -r .env
humax# rm -r .epgkeyword
humax# rm -r .unprotect.last
humax# ls -la
drwx------ 2 root root 4096 Sep 13 17:35 .
drwxr-xr-x 8 root root 4096 Sep 13 17:13 ..
humax#

Rebooting the display still showed 'Cust Fw 2.18'
so presumably there is still some remnant of the Custom Firmware lirking somewhere on the Hummy.

I am not very familiar with Linux so I would be greatful for the detailed commands I should use to clean up so that I can reinstall Humax FW 1.02.32 and CF HDR_FOX_T2_1.02.32_mod_2.18.

Michael.h
 

Ezra Pound

Well-Known Member
Your hard disk has gone read only, this was probably the cause of your original problem, I would run fix-disk from the Telnet maintenance menu, details HERE. Once the disk has fixed the read only problem, it should be possible to remove the Custom Firmware, however it is possible that you will have also fixed the original problem that made you decide to remove the CFW
 

af123

Administrator
Staff member
I don't think it has gone read only. The root directory is always read only. That looks like RMA has done its job so you should now install the official software to remove the last traces.


Posted on the move; please excuse any brevity.
 
OP
michael.h

michael.h

Member
Having managed to clear the old installation and reinstalled Humax FW 1.02.32, CF the core package, and added other packages as with my original installation I discovered the there must still be left over files or DB as all the auto-shrink and auto-dedupe settings were in tact!
I have now moved on as in thread cfw-2-19-customised-firmware-version-2-19.3903
 

Black Hole

May contain traces of nut
Good point. For a complete leave-no-trace RMA, all the CF dot-file flags and magic folders would need to be removed.
 
Top