• The forum software that supports hummy.tv has been upgraded to XenForo 2.1!

    This upgrade brings a number of improvements including the ability to bookmark posts to come back to later. Please bear with us as we continue to tweak things and open a new thread for any questions, issues or suggestions in Site/Forum Issues.

EPG possible errors ?

mihaid

Active Member
in rs the epg seems to show quite different versions for the bbcone regional and bbconehd which can't be just due to the regional differences.
 

Attachments

zekepliskin

Member
The only BBC ONE error I've seen recently is that yesterday Six Nations Wales v England wasn't on the list despite Radio Times showing it as 4:15pm program start this Saturday and no sign on it on the EPG, but an EPG refresh today has corrected that.
 

Luke

Well-Knwοn Мember
in rs the epg seems to show quite different versions for the bbcone regional and bbconehd which can't be just due to the regional differences.
It has corrected itself overnight for Sunday. On RS, the two BBC ONEs are now consistent with each other. On the box itself they were OK yesterday and so I presume that they are still OK on the box.

Monday's and Tuesday's are still inconsistant on RS. I'm not at home right now, and so can't check if the difference also shows up on the box.
 
I had noticed on Sunday that rs & webif for Sunday 24th BBC ONE HD showed Les Miserables (which finished the previous Sunday). The epg on the box was correct, showing Baptist.
Yesterday, Monday 25th showed similar problems with the new series Warren.
Today, both seem to have sorted themselves out. Cannot tell off-hand if Tuesday 26th is ok or not.
 

zekepliskin

Member
It has corrected itself overnight for Sunday.
Yep that was my experience too, when the Humax grabbed updated EPG data it sorted the errors out. I wonder if it's a problem with the Freeview scheduling or rs/webif versions of it only. If/when it happens with something I want to record next time I'm gonna cross reference with Radio Times online and the inbuilt EPG on my main Sony BRAVIA TV.
 

peterworks

Ye Olde Bowler
The BBC had the same sort of problem two weeks ago - the six nations matches were all over the place and the Sunday still showed the previous Sunday's schedule (but only in parts).
At the time I checked on my TV and that had the same symptoms...
 
I wouldn't be blaming Freeview for this; my on-box EPG was correct, it was only the webif & rs that showed the historical schedule data.
I am certain of this because on Monday I wanted to schedule next Monday's new series, Warren. When I couldn't do it by webif or rs, I did it on the box.
 
OP
M

mihaid

Active Member
Match of the Day on BBC 1 HD on Saturday night is a bit messed up too. rs is showing it starting at 2 different times. 22:20 and 22:40
I've got that as well.

if you use rs epg and select day time from the bar above you get the correct motd for sat at 22.20

if once you are on the rs epg you click on the bbconehd link you get what you and I found out.

there is a bug there for af123 to solve.
 

zekepliskin

Member
there is a bug there for af123 to solve.

Has he been made aware of this, or if not is there a process for notifying him? I know a lot of developers use github for this sort of reason... you can just create a New Issue and go from there. Nice easy process, does he use one for [rs]?
 

MymsMan

Ad detector
The forums are the usual reporting mechanism but the tracking and fixing can be a little hit and miss,
 
OP
M

mihaid

Active Member
just found another problem: the epg has the programmed recs highlighted in orange and yet the rs visual does not show programmed recordings at all.
 

MymsMan

Ad detector
just found another problem: the epg has the programmed recs highlighted in orange and yet the rs visual does not show programmed recordings at all.
This is the normal, expected behaviour if the episode has already been recorded or the episode has been marked for skipping.

The RS also sometimes shows recordings in orange if the RS EPG is out of sync with the webif EPG, it can also occur if the EPG start time has been changed by a few minutes and the recording schedule doesn't match the EPG. You can use the Refesh Events option on the schedule panel to fix this (it might be the cause of back2back recording issues)
 
OP
M

mihaid

Active Member
You can use the Refesh Events option on the schedule panel to fix this (it might be the cause of back2back recording issues)
are you saying that I need to time myself exactly as the first prog has been recorded to hit the refresh events so that the prog about to be recorded can kick in?
 

MymsMan

Ad detector
are you saying that I need to time myself exactly as the first prog has been recorded to hit the refresh events so that the prog about to be recorded can kick in?
No, Refresh events can be done at anytime to rebuild the recording schedule if it appears to be incorrect.
 
OP
M

mihaid

Active Member
I see. it seems to have fixed some stuff. not others.

on the rs visual when you click one episode the whole series gets highlighted. the apprentice episodes on sunday night even though are part of a series seem to be independent (even though they do have same series crid), the only way I got them both recorded was to record the second one as a separate series recording. what is going ?
 

Black Hole

May contain traces of nut
I just had a play:-

For info: there are two episodes of The Apprentice USA on BBC ONE Sunday night (2335 and 0020). They carry different P-CRIDs and the same S-CRID.

On the SUI: Set the first episode for series record, and all is well (both episodes are marked as set for recording). But, set the second episode and the first episode is not marked as set despite a reboot. However, having rebooted, setting the second episode also marks the first! (unit 1)

On the WebIF: Setting the second episode only marks the second episode (even after reboot, and even as reported by the SUI). Setting the first episode marks both episodes. (unit 1)

On RS: before sync, setting the second episode only marked the second episode as pending; setting the first episode only marked the first episode as pending. After sync, with the first episode pending both became marked as set (unit 2), with the second episode pending only the second episode became marked (unit 3).

I suspect that, nevertheless, both episodes will record. I will leave these settings in place and report back what actually happens (I don't care whether they record or not).

The only observation which breaks the general pattern is what happened after a reboot, when the SUI started working properly, consistently. Note I have not rebooted units 2 or 3.

My hypothesis is that (when working properly) the SUI maintains a database of series linked episodes and sets all the items in the list when you set any of them (which had failed before I rebooted), but maybe WebIF/RS doesn't look for episodes that occur earlier than the specific one you set. If so, I'm surprised nobody has spotted this before. If not: I have no idea how the SUI can mark the first episode to record by setting the second episode, but the WebIF and RS do something different.

Questions (for somebody else to have a play): Are my observations repeatable? Does this only apply to The Apprentice USA - are there other examples of multiple episodes, and do they work properly or show the same effect?
 
Top