Firmware update problem [ Solved ]


I've just bought a "new" HD-FOX to replace my old one that died. I have tried to put the custom firmware on but am not having much luck.
The download and install seems to go OK, but when I press the power button to restart it just "hangs" at the initial startup screen, with the LED segments rotating round the display. I have tried (multiple times!) with both 1.03.02 and 1.02.20 firmware; effect is the same.
I did remember to remove the USB drive with the CFW on before rebooting, but haven't put in a new EXT3 drive.
Is it possible that the Flash is corrupted?
The device did work OK when I tested it on the standard FW, though I seem to remember I did get one instance of a similar "hang" that required a mains cycle to cure.
Any suggestions?

My only other option is to swap the PSU from the new unit to the old. I managed to fry the old unit with a power surge while trying to fix my oven; it's possible that it's just the PSU that has failed.
What version of firmware was originally loaded before the upgrades?
Good question - I should have checked before I over-wrote it!

In the end I installed standard software 1.02.29, which worked OK. I then installed custom firmware 1.02.31_mod_3.13, which also worked. So something of a mystery - but it's working now, which is what matters. Thanks to Black Hole for the suggestion of going back to standard.
Last edited:
If you had version 1.01.xx installed then you would have had to install the standard 1.02.xx before installing the CF.

The upgrade from 1.01.xx to 1.02.xx changes the internal flash layout.
Would it now be possible to create a self-contained CF update, containing a full OEM firmware image with the CF modifications? This might be convenient now that OEM updates seem to have dried up (iPlayer client certificate, anyone?).
It is possible to upgrade to version 1.03.02 using the latest CF update, providing that the current installed version is at least 1.02.xx.
containing a full OEM firmware image with the CF modifications?
I thought they are - or is that only HDR-FOX? We stopped applying CF over a SF update yonks ago (CF update includes the SF updated version).
OP seemed to have an issue applying CF over an obsolete SF, which is why I asked.
Yes, but the 1.01 to 1.02 shift involved a loader update as well, and maybe some embedded commands which have never been examined. It is an edge case that anyone is still updating from <1.02.
  • Like
Reactions: /df
What is a power surge?
And how do you create one (whilst trying to fix an oven or otherwise)?
I'm not sure if "surge" is the correct term, but some kind of "disruption" to the mains.
I was trying to diagnose why my oven kept tripping the RCD, so I was working on it with it "live". During the process, something shorted to ground resulting in some sparks before the breaker tripped. After that, the HD-Fox wouldn't turn on and the TV attached to it wouldn't respond to the HDMI input.