• The forum software that supports hummy.tv has been upgraded to XenForo 2.0!

    This is a major upgrade which changes the look and feel of the forum somewhat but brings a host of improvements too. Please bear with us as we continue to tweak things and report any issues or suggestions in Site/Forum Issues.

ftp 503 Bad sequence of commands.

#1
Hi,

Anyone know why im getting the following while trying to connect to the humax hdr t2 with ftp?

Status: Connecting to 192.168.0.22:21...
Status: Connection established, waiting for welcome message...
Response: 220 Welcome to connection.
Command: USER root
Response: 332 Need account for login.
Command: PASS *****
  • Response: 503 Bad sequence of commands.
Error: Critical error
Error: Could not connect to server
 

af123

Administrator
Staff member
#2
The FTP server that is on the Humax by default only implements a subset of the FTP protocol (and is pretty unstable besides). I imagine your FTP client is sending commands it doesn't recognise. In particular passive mode isn't supported so I'd start by trying to switch the client to active.

With the custom firmware, there's the option to install a better FTP server.
 

Black Hole

May contain traces of nut
#3
User name = "Humax", password = "0000" (unless you've changed the pass code in the Humax settings, same as you need to get to the installation menu).
 
OP
OP
sohlinux
#5
User name = "Humax", password = "0000" (unless you've changed the pass code in the Humax settings, same as you need to get to the installation menu).
I tried both user names root and humax and password 0000, I also tried the same password which I set in the web interface but non of them will work

ssh will not work either
 
OP
OP
sohlinux
#7
now the ftp is ok, anyone know why ssh will not work? should the default password be the same as ftp? so root/0000 or humax/0000?, anyway neither of those work on my box :(
 

Black Hole

May contain traces of nut
#8
Hmm... I have "Humax" in my FTP credentials - strange!

Edit: I just had a play and both "humax" and "humaxftp" worked (on an HD-FOX with betaftp installed).
 

af123

Administrator
Staff member
#10
Betaftp doesn't care what is used for the username in general. It just distinguishes between root and non-root.

SSH is only available if you have installed the custom firmware and dropbear-ssh package.
 

af123

Administrator
Staff member
#11
To get BetaFTP working you need to also disable the built-in FTP server. Default SSH credentials are root/humax
 
Top