1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HDD now not recognised on HD Fox T2?

Discussion in 'HD-FOX T2 Freeview Receiver' started by Colossae3.23, Feb 29, 2016.

  1. Colossae3.23

    Colossae3.23 New Member

    Hi,

    I have been recording to a 1TB HDD since late 2012, but yesterday the HD Fox T2, stopped seeing it. Tried unplugging and then a factory reset, but still no joy. The HDD was quite full, probably about 24MB left, but it has been fuller than this before and not had this problem.

    Does anyone have any ideas on what to do. I really don't want to lose the files on the HDD, so I'm not keen on reformatting it. Besides, I can't format it anyway, because it doesn't show up on the list in Data Storage.

    Thanks,
    Bill
     
  2. af123

    af123 Administrator Staff Member

    Do you have the custom firmware installed? If so we will be able to talk you through getting in to the command line and running some diagnostics to see what's wrong.
     
  3. Colossae3.23

    Colossae3.23 New Member

    No, I don't sorry. Can I move those files to a Win 10 laptop, then try to format the Ex. HDD to Ext3 again, and then move the files back on it?

    I know I can't play these files on Windows, but can I move them, store them and reload the HDD?
     
  4. Black Hole

    Black Hole Felinos Guru

    Yes, as long as you keep the .ts (video) file complete with its sidecar files (at least the .hmt, preferably the .nts as well).

    Note that you might need to give Windows some help to access the Ext3-formatted drive.

    Alternatively, if you feel intrepid, load custom firmware now and we'll see what can be done from the command line.
     
  5. Colossae3.23

    Colossae3.23 New Member

    Think I'll try the custom firmware. Nothing to lose. Can you please point me to the instructions? I know I've seen them, but not sure where. Thanks
     
  6. Black Hole

    Black Hole Felinos Guru

    Quick Guide to Disk Recovery (click) - but I'm not sure how the instructions translate to an external drive on an HD-FOX, so just follow the installation and access to the Telnet command line for starters.
     
  7. Colossae3.23

    Colossae3.23 New Member

    Thanks mate. Slightly confused by the versions. I'm on the factory version 1.02.28, and my hardware has the vertical tuner port configuration. Going by that does it matter which version I install? Also, the unit doesn't have internet connection. It's too far from the phone box. Is an internet connection necessary, if so, would a temporary connection be suitable to just sort out the disk?

    Thanks
     
  8. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    I suggest HD_FOX_T2_1.02.31_mod_3.03

    An Internet connection is necessary to install the full custom firmware but the install from USB would be enough to give telnet access but this will require a temporary connection either to your router or direct to the PC.
     
  9. Colossae3.23

    Colossae3.23 New Member

    Thanks Martin, so just dump the extracted files above to a clean USB stick and then insert the stick into the HD Fox T2?
     
  10. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    Basically yes. Might be worth reading the Wiki notes on the process at http://wiki.hummy.tv/wiki/Install_Modified_Firmware (making sure you scroll down to the HD FOX notes.
     
  11. Black Hole

    Black Hole Felinos Guru

    It's all explained in my reference if you follow the links.
     
  12. Colossae3.23

    Colossae3.23 New Member

    yeah sorry, its me
     
  13. Colossae3.23

    Colossae3.23 New Member

    Hi, got firmware installed. Connected to internet. Accessed TelNet through PuTTY. Chose option 1 (Maintenance Mode) Box rebooted, ran TelNet again, now option 1 says: "cat: can't open '/sys/block/sda/removable' : No such file or directory"

    Is there a diag code that I can run? I have looked for a code on the Wiki before asking, but can't find anything.

    Thanks again
     
  14. Black Hole

    Black Hole Felinos Guru

    This is where you need guiding through by the experts. At least you've done the groundwork.
     
  15. prpr

    prpr Well-Known Member

    Does your USB adapter get recognised if plugged in to a PC?
     
  16. Colossae3.23

    Colossae3.23 New Member

    I would be grateful for any guidance that you can give me, if you have the time. If so, would it be best to do this through pm?
    Thanks, Bill
     
  17. Colossae3.23

    Colossae3.23 New Member

    no, it doesn't show in Win 1o or Win 7. Thinking I need to load a 3rd party app to see it. Installed Ext2Fsd last night on Win 10, still no joy. I've been reading that Win 10 doesn't do well with Linux files. Win 7 machine is at work, so I need find out if our IT guy will let me load a 3rd party app, as I don't have admin rights.
     
  18. Trev

    Trev The Dumb One

    But that would deprive us interested lurkers of the final outcome and how it was resolved.:(
     
  19. Colossae3.23

    Colossae3.23 New Member

    no problem. This stuff is way over my head and I figured I'd need to ask loads of questions, so I was afraid of clogging the thread with dialogue. But, I'm happy to stay public if it helps others.
     
  20. MontysEvilTwin

    MontysEvilTwin Well-Known Member

    Ext2FSD works fine on Windows 10 for me, though I have seen problems reported. You have to start it manually, it doesn't autorun. Open the program, start the service and then plug in the USB drive: hit 'refresh' if you don't see the drive listed. The drive should be listed as 'ext3'. If not you have a problem: try ejecting and reloading. There are good, free, alternatives to Ext2FSD like this one from Paragon you could try if you are still having problems.