HDR Fox T2 not behaving - any pointers please?

dragon-it

Member
Currently sat in front of Humax having had small operation and not wanting to move frankly and trying to fix it from laptop... I have trawled through forum and wiki and getting nowhere at the moment.

Issues just recently have been:

Items deleted from the TV remote don't disappear "deleting" sits there ...
Items watched on the TV don't lose their "unwatched" flag.
Live pause was not working until running diag to re-enable

Disk diagnostics in the web-if shows a blank page
Maintenance mode and trying to run fix-disk says this:

Running /bin/fix-disk
Custom firmware version 3.00
Checking disk sdb
Unmounted /dev/sdb1
umount: can't umount /mnt/hd2: Device or resource busy

Running update of web-if packages said that partition was read only.

Going back into the normal mode after maintenance mode have deleted entries OK from TV remote and the space shows recovered and Space goes up again and watched markers work again.

But then web-if disappeared , reboot to maintenance mode again....

I've tried looking with fuser and lsof etc. and nothing showing as holding the partition from unmounting.

Is there one of the packages that could be holding that partition from unmounting even in Maintenance mode that doesn't show up, NFS maybe?

Steve
 

af123

Administrator
Staff member
I'm not sure what could be using the partition once you're in maintenance mode. Services like NFS don't run.

You could try to force unmount it from the maintenance mode command line with 'umount -f /mnt/hd2' then exit back to the menu and run fix-disk again. This does look like a partition that has gone read-only due to corruption.
 
OP
D

dragon-it

Member
Thanks for very quick reply and delay relying again. Yes I tried umount -f on it from cli but wouldn't unmount still, tried to run fsck directly but of course can't unount.... looking back at the web-if now it says, for instance looking for new packages:

>>> opkg update
wget: can't open '/Packages.gz': Read-only file system
Downloading http://hpkg.tv/hdrfoxt2/base/Packages.gz.
Collected errors:
* opkg_download: Failed to download http://hpkg.tv/hdrfoxt2/base/Packages.gz, wget returned 1.
* rm_r: Failed to open dir : No such file or directory.

SMART disk diagnotics came up for a minute there in webif after reboot and didn't show any issues, and with cli I was able to fsck the other partitions, just not sdb2

If it wasn't painful to move and stuck in the house for a couple of days I'd bung a new disc in and copy over the recordings... suppose sounds likely I'll have to do that and deal with the rath of Coronation Street and Power Rangers not recording properly meanwhile!

Steve
 

prpr

Well-Known Member
What does /bin/ps report in maintenance mode?
Also try:
Code:
lsof -X|grep /mnt/hd2|cut -d ' ' -f1|sort|uniq
 
Last edited:
OP
D

dragon-it

Member
Thanks, odd isn't it... normally when we get a read only file system on a Linux box say is easy enough to fix but seems not on this ... this is after fresh reboot to maintenance mode after fresh power up from mains off. That was what I was seeing with lsof, i.e. only itself and associated progs using that disc.

Disk diags show no SMART errors or anything in webif and webif showing drive OK again for now but will find it goes read only again, scheduled recordings seem to stop after 7 minutes for instance.

I don't understand how it fails in maintenance mode..

If I cant figure it soon time to grab a new disc and re-install I guess

Steve

humax# cd /etc
humax# p
/bin/sh: p: not found
humax# ps
PID TTY TIME CMD
1307 pts/0 00:00:00 tmenu
1309 pts/0 00:00:00 tmenu
1351 pts/0 00:00:00 sh
1360 pts/0 00:00:00 ps
humax#
humax# lsof -X|grep /mnt/hd2|cut -d ' ' -f1|sort|uniq
cut
grep
lsof
sort
uniq
humax#
humax# umount /dev/sdb2
umount: can't umount /mnt/hd2: Device or resource busy
humax# umount -f /dev/sdb2
umount: can't forcibly umount /mnt/hd2: Device or resource busy
humax#
 

prpr

Well-Known Member
"/bin/ps" or "ps ax" as you have procps installed. Just "ps" with the latter is not very interesting.

It is odd, but I've had similar before - when mucking about with shells, I ended up in maintenance mode with the shell running from /mod/bin/busybox/sh, hence the request for full ps details.
You could try "umount -l /mnt/hd2" and then exit out of the shell and try connecting again and see if anything's different.
It's just a matter of killing off whatever's holding the device, as I'm probably sure you're aware.

Of course, copy off, format, and copy back will no doubt fix it. You don't really need a new disk.
 
OP
D

dragon-it

Member
Thanks again. Will try some of those when I get a slot on the telly later and keep digging. If all else fails I'll pull the files off it or try and fix it offline on a pc I suppose.
 
OP
D

dragon-it

Member
Sorted I hope. I'd never used the lazy option before on umount. Nothing showing in different process lists still but umount -l ... and it just did this time :) Ok it's going to trickle through running fsck for ages (stuck at 3.2% for a while so far) but it is running now so lots of things crossed. This forum and community around Humax come up trumps as usual.... hmm is that still classed as a complement?
 
OP
D

dragon-it

Member
To finish this off... the disk check kept getting stuck around 20% but refreshing the telnet window with Return every now and again kept it running OK and a couple of hours later problem corrected and HDR back to normal. Still don't know what was stopping the partition unmounting but thanks again for suggestion..
 
Top