HDR-Fox-T2 Real and Web remote problems and configuring Logitech Harmony 350

I thought it best to start a new thread, even though these topics turn up in many other existing threads. This is because I think I am about 90% on the way to success, so my efforts are worth pulling together. Also, I hope this is a good time to ask for some advice about the best way to finish the job.

My Fox-T2 is pretty old - I bought it in the UK roughly 10 years ago, but it has been superbly reliable. I also have a 4-ish year old Aussie 1TB Humax which has happily sat on top of the T2 ever since it arrived. (There is another thread about this - the UK humax is completely incapable of tuning the TV stations here on the Sunshine Coast in Queensland). Significantly, the two Humax boxes have their own remote control handsets, which have NEVER interfered with each other.

Last week the UK remote started playing up. Many buttons stopped working altogether, e.g. Media (BIG issue!), while others did the wrong thing (e.g. Guide acted as if it was Info). It rapidly went downhill until nothing worked, even the Power button, by the next evening. I was surprised to discover the Web GUI remote IR simulator didn't work either and guessed the real remote had mangled some setting during its failure.

I waited until I could spend some patient time on the problem, while we simply watched stuff recorded on the Aussie Humax that evening. We had just experienced a "wet season"" spell of a week with 30+C days, 24C nights, 90+% humidity, and a foot of rain in 24 hours. Not the best conditions for ageing electronics!

I was pleasantly surprised to find I had missed a couple of customised firmware releases, so I upgraded the box from 3.07 to 3.13 in a single hit over an ssh session. The upgrade went perfectly, but the remote still didn't work. I tried both the real and web GUI remote after the upgrade, but they still didn't work, so I updated all the packages, including ir and the web server itself from the "old" web interface. The updates went well, so there were none pending or available. However, the real and simulated remotes still didn't work. The gui told me the remote was set to the default mode of 1.

(more soon...)
It didn't take me long on this forum, and elsewhere to decide the Logitech Harmony would make a good replacement. I've always hated the remote for the Aussie Humax, so the Harmony could replace both Humax remotes in time. The Logitech told me the Harmony 350 would be compatible with the HDR-Fox-T2 based on its database of 270,000+ database entries. My local hi-fi shop had one in stock at a special discounted price of AUD 38 (GBP 20-ish), so I clicked and collected. I knew there were loads of issues with linux and I'm a "pure" linux-only user, but luckily I had not yet got round to wiping a windoze system that came pre-installed on my laptop.

But then the fun(?!) started!
I arrived home with the Harmony and installed the windoze customisation software. Yes, it did support my HDR-Fox-T2, but there was a huge catch! It refused to configure the interface unless I could provide the original remote! I started by lying to the question, but immediately was told there was nothing more it could do to support this particular Humax... sigh.

This forum had a really clever tip, which I didn't know about. My digital camera can see the infra red flashes from my remote as pretty bright purple flashes on the view finder. I quickly cleaned the remote battery chamber (there had been some leakage of battery "blood") and fitted new batteries. Some buttons worked, but most of the important ones didn't flash at all, and some others only worked intermittently.

I decided to delete the entry for the Fox-T2 and start from scratch with the Aussie Humax. The setup software claimed to identify the remote from its database and loaded the I/R codes for the buttons. However, with the Fox-T2 powered off, the Harmony was a complete mess. Most buttons were dead, while others had the wrong function.

Undeterred, I used the configuration software to teach it many buttons and their assignment on the Harmony remote. 5 or 6 at a time, it started to have the appropriate effect and I was wiser as well as happy. It is a long way from ideal, but I've put the old remote away until I want to finish that job properly.

Then I powered-off the Aussie Humax, powered-on the Fox-T2, and told the truth about having the remote control. It went into a dialog of asking me to press a small number of buttons while pointing the I/R transmitter at the I/R receiver on the bottom end of the Harmony. It kept asking for buttons that didn't "flash purple", so I had to tell it to skip those and try others. Eventually it would be satisfied and tell me it had identified my Humax and loaded the correct codes.

Testing immediately showed the configuration was hopelessly wrong again, but I now knew how to "teach" the customisation software some of the buttons that actually "flashed purple" reliably and assign those functions to sensible buttons on the Harmony. Sometimes, the assignment was correct, but sometimes the Harmony button still didn't do what I had assigned.

I decided I was close enough to winning the battle to take the risk of "opening the box". I followed the excellent photo-and-word instructions in this wiki (I loathe uTube videos that show/tell me how to do something tricky in 30 seconds).

Once I had the Fox-T2 remote in bits, I could relax a bit. I already had a large bottle of Iso-Propyl Alcohol (yes, you can buy it in JCar over here), so didn't bother with the recommended Methylated Spirits. The inside of the battery chamber and the edges of the rubber button mat both had some "battery juice", but that cleaned off easily.

The inside of the conductive rubber buttons (called waffles in the instructions) looked as-new to me, so I started to clean the contact "fingers" with iso-prop and a soft cloth, gathering a small amount of black dust. Because opening the case was quite scary, and I now knew it would be essential to get more buttons flashing properly, I used Q-tips with iso-prop rubbed in circular patterns to clean the contact fingers. After I had used both ends of about six Q-tips, they were coming away clean even though the fingers seemed to be a dark matte grey, with just the odd spot where shiny copper winked up at me. I stopped rubbing because I decided the matte grey must be a conductive coating over the copper, rather than a deposit of dislodged waffles.
I re-assembled the Fox-T2 remote, which simply required careful alignment of the components and snapping the back cover in place. More camera "selfies" to verify the more important buttons "flashed purple" nicely, although several down the left side weren't perfect, and back to the Harmony configuration software.

I deleted the device and started afresh. It told me it had identified the Humax remote and loaded the most common of the alternative button mappings, although it couldn't recognise some of the buttons it asked me to press, I used the "skip" option to get it to ask for different buttons. Amazingly, the Harmony remote got the Fox--T2 to power up from standby, but it wouldn't do much else of value.

I went back to teach it some of the more basic buttons such as the arrows, OK and Guide. They all flashed nicely and my efforts were gratifyingly successful. I was on a roll!

I assigned some more buttons, including false starts for a few important left-side things such as Media (where this story began). I stopped as soon as I could view and navigate the list of my recordings on the hard disk, use the program up/down rocker, play, pause and stop. My suitably boggled and appreciative wife sat to watch a couple of programs last night after dinner.
I know I shouldn't have tried too much in the day, but I switched the Harmony to instruct the Aussie Humax and watch a pre-recorded news program before I went to bed. Instead of the Aussie Humax coming out of standby, the Fox-T2 went INTO standby!

OK, I thought to myself, this must be an omen to give up for the day. I switched off power to the Fox-T2 and this time the Harmony brought the Auussie Humax out of standby. It's small subset of working buttons were sufficient to let me watch my program and prove the addition off the Fox-T2 configuration had not accidentally corrupted the previously-working Aussie Humax configuration.
So what next? Do I painfully and painstakingly configure every button on the two Humax remotes a few at a time until each box can be properly controlled when the other is powered off?

That worries me because I might need to trash an entire configuration to start again after assigning a new "mode". Even though the two real Humax remotes never interfered in the slightest, there is clearly a major overlap with the two Harmony configurations because I deliberately and carefully "taught" it the codes for their respective power on/off buttons (I realised these were too fundamental to trust to some software wizard).

Earlier in my fun and games, I suspected the lack of response from the Fox-T2 web remote simulator was due to the mode having been scrambled during the firmware update. I tried uninstalling the ir package, which logged success, but remained installed. Its setting is still the default value of one. I found a forum post about mode setting and tried to use the original remote to display and change the mode. After a couple of attempts, where nothing was displayed on the TV screen, it seemed to be successful because after a reboot quite a few buttons on the remote actually controlled the Fox-T2 and did the correct things. It was probably already in mode one, because the Harmony didn't require re-teaching.

I guess the "real mode" is held somewhere in the Fox-T2 configuration files, but perhaps only in the firmware "blob". I haven't grepped the file system yet, but another post about setting the mode configuration simply failed with "unknown command". Obviously, the remote itself must squirrel the mode value in its own NVRAM, otherwise it can't "talk I/R" in the correct dialect for one of multiple Humax boxes. I guess the zero and OK buttons must map to the same I/R signals within all six possible modes.

Have I got things basically correct so far? Is there a neater way to coerce the Harmony configuration to recognise and keep separate my two Humax boxes? If not, is there a way to do it for the Fox-T2 with its unreliable original remote that I realise is too precious to use every day or risk breaking? I don't mind struggling with the Aussie Humax because its own remote works fine and does not accidentally control the Fox-T2.

Any words of wisdom, criticism, or encouragement would be very welcome! In the meantime, I have some other chores before dinner. Then we will sit down to enjoy watching a pre-recorded movie on our Fox-T2 using the Harmony remote!
Last edited:
The ir package will give you web browser remote control – all you need to do is go to WebIF >> Settings >> Settings for ir package >> Remote Control Mode and make sure the selected mode number matches the current mode. If you don't know the current mode number, try them all until it works.

If even that doesn't work, you have a problem with the HDR-FOX – not the handset. On the other hand, if browser remote control does work, there is no guarantee that the signals from a real handset are being received correctly. The front panel assembly (with the IR receiver components) has been known to fail.

I bought it in the UK roughly 10 years ago
By my estimation, they went on sale in 2010.
The ir package will give you web browser remote control – all you need to do is go to WebIF >> Settings >> Settings for ir package >> Remote Control Mode and make sure the selected mode number matches the current mode. If you don't know the current mode number, try them all until it works.

If even that doesn't work, you have a problem with the HDR-FOX – not the handset. On the other hand, if browser remote control does work, there is no guarantee that the signals from a real handset are being received correctly. The front panel assembly (with the IR receiver components) has been known to fail.

Thanks for your quick and helpful reply, which got me thinking in the correct direction. I have now solved my problem(s):-
  1. Although I don't remember doing it, the UK Humax was actually setup for mode 2, as was its own remote. This explains why there was no cross-communication between the two boxes and their remotes. The Aussie box is probably still on mode 1, the default.
  2. The custom firmware upgrade didn't reset the UK Humax mode, or its remote.
  3. The Web GUI remote simulator wasn't working because the update to a new version probably reset it to use mode 1.
  4. The humid weather and old age were probably the cause of the UK remote buttons ceasing to work reliably. Taking the cover off and carefully cleaning the contacts restored the button functionality well enough to use it to "program" the Harmony remote handset.
  5. The remainder of my problems were explained by a lack of understanding about the rather fussy dialogues used by the MyHarmony windoze app. (If anyone else needs help with this, I can explain further). Having worked out the correct but painful sequences, I gave up completely with it's 270,000+ database and programmed the new remote entirely using the two Humax individual I/R transmissions and assigning each one to the appropriate buttons on the Harmony. Except for a couple of irritating bugs to be reported to Logitech, my Harmony 380 remote is now successfully (95%) controlling both Humax boxes, without any nasty cross-talk.