Help: Check ‘n repair keeps reporting “Error at LBA 0”


New Member
Hi, I’m new to custom firmware - I was having some problems with the machine and decided it was the best way to go. Anyway, I’ve enabled maintenance mode and ran ‘check and repair hard disk’, which informs:

“Error at LBA 0 Do you wish to attempt repair of the bad block? [Y/N]”

If I respond ‘Yes’ to this, the error message is repeated, and similarly it is repeated again, and again if I keep responding with a ‘YES’. If however, I respond with a ‘No’ the check and repair process continues. Please, can anyone advise if this is serious issue and what, if anything, can be done in terms of a fix.


Well-Known Member
It's not great. I would recommend you backup anything you want off the disk (if you can) and then have a read of this thread.
You may need a new disk if you can't resolve it.


Well-Known Member
I have used the security erase procedure referenced above, for a different reason, on a 500 GB Seagate Pipeline in a HDR-FOX successfully. A few points additional to the reference:

Install the 'hdparm' custom firmware package
Before booting to carry out the security erase, disconnect any USB flash/ hard drives: this will ensure that the drive you wish to erase is 'sda'
There is a spelling mistake in the 'hdparm' security erase command in the reference: it should be 'hdparm --security-erase PASSWD /dev/sda'
When you list the drive parameters with the 'hdparm -I /dev/sda' command it will say how long the erase procedure will take
When you issue the erase command (Telnet in maintenance mode), if you don't immediately get an error message it is probably working, but you might not get a message telling you that it has finished. I just left it an hour or so longer than the projected time to be safe, before rebooting and formatting the drive.
Last edited:


New Member
Many thanks for your advice guys. I'm not really a techie and I'm still just a newbie to the custom firmware. The check and repair hard disk process possibly improved things a bit and I've now ran the Humax format command from the box, though the Humax HD Test now reports 'error code 5' so it seems I'm not out of the woods.

I have read the thread suggested by 'prpr' and had a good look at the maintenance mode wiki, but I'm quite apprehensive that I may screw things up in now needing to run the hdparm security erase command. I'm presuming that its all very straightforward to install the 'hdparm' custom firmware package and that I will be accessing this via the 'cli' command line option available from maintenance mode. I'm guessing here, but I presume that I then enter:

1) hdparm -I /dev/sda and check that it says "not frozen";
2) hdparm --security-set-pass PASSWD /dev/sda and hdparm -I /dev/sda and check that it says "enabled" two lines under "Master password";
3) hdparm --security-erase PASSWD /dev/sda as hopefully spelt correctly and wait for this to finish;
4) hdparm -I /dev/sda and establish if it still says "enabled" two lines under the "Master password";
5) hdparm --security-disable PASSWD /dev/sda then hdparm -I /dev/sda and check that it says "not enabled" two lines under the "Master password"; and then
6) reboot the machine, reformat the HD again, test it (and fingers crossed it will be good this time), then finally reinstall the custom firm again.

Does that sound right?


Well-Known Member
It sounds good (he says, having not personally had to do it).
Might be interesting to run fix-disk after 5) and before 6) just to see what it says.

I would make sure you have the fan package installed before you start as well.


Well-Known Member
After I ran the security erase and let the HDR-FOX format the disk, I ran fix-disk again. There were some inode related errors still, but these were sorted by one fix-disk pass.