Huamx demanding I reformat the disk

Theothersimon

New Member
I have a HD-Fox T2 with an ext3 formatted external hard drive.

Earlier this week there was a power glitch (thank you Doris), and since then the Humax has been unhappy.

It would not show the whole webif pages (just the top banner) and it would not process any of the dedup or auto-shrink commands. I checked the disk with e2fsck, and it is showing no errors.

I tried reinstalling webif (fixweb from the telnet interface), but it failed due to the favicon.ico file being locked. So I used reset on the telnet interface to reinstall the custom firmware.

So I now have fully functional custom firmware apart from one thing - it won't record. Every time I reboot the box I get an on screen message complaining the disk is not formatted and would I like to format it. If I say no, the disk mounts anyway and I can play anything from it, but nothing will record. e2fsck thinks the disk is fine.

I have a bunch of recordings that it would be a pain to move and restore, so anyone any ideas on how to convince the Humax that the disk is OK, without letting it format it?
 
OP
T

Theothersimon

New Member
You sir, are a genius.

I had already tried the HD assigning from the on-screen menu, but that didn't work. I didn't know there was another way via the diag commands. And it worked.

Thank you.

TOS
 
Top