1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Humaxrw to recover files

Discussion in 'PVR-9300 Freeview Recorder' started by Mark X, Jan 28, 2014.

  1. Mark X

    Mark X New Member

    My Humax PVR has lost all its recordings (record menu has disappeared). I have hooked up the
    HDD to a PC and am running humaxrw to try to recover the files.

    If I run almost any command. eg.

    > humaxrw -l 0:

    I see the following error message:
    "Directory 1: Permission denied"

    I am running it as Administrator on Windows 7

    If I use the "-n" option I see

    1: ***Buffer***
    2: ***Info Disabled***
    ...
    159: ***Buffer***
    160: ***Info Disabled***
    ...
    207: ***Info Disabled***

    I have tried ext2fsd but this does not recognise the file system (shown as RAW).

    Any ideas?
     
  2. prpr

    prpr Well-Known Member

    Get XP?
     
  3. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    Are you sure? If I recollect correctly you need to go to Start>All Programs>Accessories and then instead of left clicking on command prompt right click and select "Run as Administrator".
     
  4. MikeSh

    MikeSh Well-Known Member

    ^^^ What he says is certainly worth trying. (You'd think using the computer Admin account would make you Admin, but it doesn't - probably to do with the UAC (I think) thingy.)
     
  5. xyz321

    xyz321 Well-Known Member

    I think the permissions issue is a red herring. There is a mismatch between the compiler's list of errors and that of Windows so that humaxrw produces the wrong error message. Humaxrw is able to read (parts of) the disk because the '-n' option seems to work. I think I/O errors are actually been generated when a directory listing is attempted without the '-n' option.

    My advice would be to use the -n option to read as much as possible but be aware that the disk is failing, so you may see further errors.
     
  6. Mark X

    Mark X New Member

    I did suspect that the permissions message was a red herring. However I am unsure how I could use humaxrw to recover data from the disk given that it is corrupted. The "-l" option doesn't seem to give me anything I can understand.
     
  7. xyz321

    xyz321 Well-Known Member

    You should be able to run it in recovery mode but will not get any epg data. Assuming you don't want to download the buffers then the following should get everything:
    Code:
    humaxrw -r -n -g 2-158,160-207 0:
    
     
  8. Mark X

    Mark X New Member

    I've tried this command. It works for a while and then ends like this:
    Code:
    188: ***Info disabled***
    Copying av file...
    Copying elu file...
    Rec: 189
    189: ***Info disabled***
    Copying av file...
    269.av: Permission denied
    Any ideas?
     
  9. xyz321

    xyz321 Well-Known Member

    You have a faulty disk. Assuming it is a Seagate drive, try downloading Seatools from the Seagate website, it may be able to repair the faults.
     
  10. Mark X

    Mark X New Member

    FYI: I have managed to recover all/most of the recordings onto another HDD. I haven't had time to view any of them yet. The disk is a Western Digital and I will test it when I have more time. Thanks for the help.
     
  11. motco

    motco New Member

    I just wanted to thank xyz321 for the humaxrw program, without which I would not have been able to restore peace and harmony to the motco household! Thank you. ;)
     
    MartinLiddle likes this.