Install FW via telnet or CLI?

loffler

New Member
I am in a bit of a pickle.
I tried updating my CFW as I have many times before.
I downloaded and extracted the file, put it on the USB stick I have always used, which I know works.
Turn it off and back on, nothing is recognised, either original FW or Custom FW.
I have tried both USB ports, front and back, but does not recognise the update.
I have tried other USB sticks and older OFW & CFW - nothing is working

I thought something was broken with my current FW so I tried to start again and RMA mode which appears to have worked as it says RMA on ther front, but now I still cannot install original FW and am left with an incomplete CFW as it shows version number in window on boot.

What are my options for getting original FW back on there when USB isnt working? I can still telnet and run CLI to the humax.

Any ideas?
 

Black Hole

May contain traces of nut
There are no other options. The firmware update process is completely separate from the normal operating system, and requires detection of the correct file on a USB drive to initiate it.

You can however clear the RMA flag and restore the custom firmware functionality from Telnet commands.
 
OP
L

loffler

New Member
Yeah thats what I did.
I removed the RMA flag and reinstalled the webif. That got me back to where I was before and managed to fix it and update.
Turns out it was a problem with the USB FAT32 format. It showed and operated fine in windows explorer, but showed errors when I opened with Minitool Partition Wizard (free 3rd party partition tool). Something must have been corrupt even though it operated fine.
I deleted all partitions, wiped the drive and created a new partition.
I put the HDF file on and the Hummy recognised it straight away.
 
Top