is custom FW required to watch recordings from one T2 on another T2 on same network?

I have custom FW 3.02 on both of my T2s. they are both on the same network at home and content share is turned on, on the remote control when I click the media button and change the storage option from HDD to network shouldn't the other T2 show in the list?

I tried to search and I'm sure that the answer is on here somewhere but I just can't find it. Thanks for any help in advance.
 

Black Hole

May contain traces of nut
First things first, you do know that by selecting Media >> Storage (blue) >> Network each can access the other by DLNA, even without custom firmware?

Installing CF does not immediately provide file share access. You need to install the relevant additional packages, which are samba or nfs-utils for the HDR-FOX to provide network access to the internal storage (by SMB or NFS respectively - Windows uses SMB, Macs use NFS), and then you need to mount the remote device into the file system for the client HDR.... and the content you are sharing needs to be decrypted.

All this is configured for you using the network-shares-automount package (although you will still need to install samba or nfs-utils according to your preference), full instructions are in the relevant topic: http://hummy.tv/forum/threads/network-shares-automount-package-released.1126/
 
Last edited:
OP
J

Jailbrkr21

Member
First things first, you do know that by selecting Media >> Storage (blue) >> Network each can access the other by DLNA, even without custom firmware?

Installing CF does not immediately provide file share access. You need to install the relevant additional packages, which are samba or nfs-utils for the HDR-FOX to provide network access to the internal storage (by SMB or NFS respectively - Windows uses SMB, Macs use NFS), and then you need to mount the remote device into the file system for the client HDR.... and the content you are sharing needs to be decrypted.

All this is configured for you using the network-shares-automount package (although you will still need to install samba or nfs-utils according to your preference), full instructions are in the relevant topic: http://hummy.tv/forum/threads/network-shares-automount-package-released.1126/

so my 2 T2s should see each other without using any custom FW? they are both on the same network and both have content share on yet they don't show up in Media>Storage (blue button)>network. Should FTP server be on?

Thanks Black Hole, do you and Ezra not sleep?
 

Black Hole

May contain traces of nut
so my 2 T2s should see each other without using any custom FW? they are both on the same network and both have content share on yet they don't show up in Media>Storage (blue button)>network.
Try rebooting your router.

Should FTP server be on?
FTP is irrelevant to this, and note that you should not have the native FTP server turned on at the same time as having the improved CF FTP server (betaftp) installed.
 
OP
J

Jailbrkr21

Member
Just got home and rebooted both t2s and the router and none are showing in media>storage>network. Both are on the network as both have ip addresses. Both on CF 3.02


Sent from my iPhone using Tapatalk
 

MontysEvilTwin

Well-Known Member
Just got home and rebooted both t2s and the router and none are showing in media>storage>network. Both are on the network as both have ip addresses. Both on CF 3.02

Sent from my iPhone using Tapatalk
Check your router settings, sometimes there is a specific option to enable UPnP traffic.
 

Black Hole

May contain traces of nut
It has been experienced that it takes a long time to do the discovery first time, but I don't know why that is. Routers have proved to be a problem on occasion.
 
OP
J

Jailbrkr21

Member
ImageUploadedByTapatalk1443907591.290676.jpg

This is the setting on my router, since my last post I have restarted the router and had both t2s on and it still isn't showing in media>storage> network


Sent from my iPhone using Tapatalk
 

MontysEvilTwin

Well-Known Member
Try resetting the DLNA databases on the HDR-FOX units. Turn off content share with the remote control, then open Web-If and navigate to Diagnostics>DLNA Server. The status should be 'Disabled - not running'. Click on the reset DLNA database button and then turn content share back on with the remote. The status should change to 'Enabled - running' (might need the webpage to be refreshed or reloaded) and you should see the number of indexed files increasing. If you see this the server is active.
 
OP
J

Jailbrkr21

Member
Try resetting the DLNA databases on the HDR-FOX units. Turn off content share with the remote control, then open Web-If and navigate to Diagnostics>DLNA Server. The status should be 'Disabled - not running'. Click on the reset DLNA database button and then turn content share back on with the remote. The status should change to 'Enabled - running' (might need the webpage to be refreshed or reloaded) and you should see the number of indexed files increasing. If you see this the server is active.

ImageUploadedByTapatalk1443912516.290081.jpg
This is what it is saying right now without resetting, I did turn off content share and it said server status: disabled then I turned content share back on and refreshed the webif page and this is what it shows.

Is it just a case of being patient and waiting for it to show up or could there be an issue with the other t2?

Thanks


Sent from my iPhone using Tapatalk
 
OP
J

Jailbrkr21

Member
ImageUploadedByTapatalk1443912773.213970.jpg

This is what is shows for the other t2 (upstairs) via webif.

I don't know what the problem is?

Do I need to install some other package on the t2? I did install the dnld filter because of a twonky issue with the mycloud drive.


Sent from my iPhone using Tapatalk
 

MontysEvilTwin

Well-Known Member
View attachment 1929
This is what it is saying right now without resetting, I did turn off content share and it said server status: disabled then I turned content share back on and refreshed the webif page and this is what it shows.

Is it just a case of being patient and waiting for it to show up or could there be an issue with the other t2?

Thanks


Sent from my iPhone using Tapatalk
That looks fine: your DLNA server is running. Discovery should not take too long: you ought to see it on the network within minutes, if not quicker. Can you see either DLNA server with an iPhone DLNA client app? Another (remote) possibility is that the two HDR-FOX units have been accidentally given the same IP address. Check this to be safe and ensure that each unit can see your network: try and connect to iPlayer on each. The one other thing I can think of is to check that the firewall rules on your router are not too aggressive: if set to high, try medium.
 

MartinLiddle

Super Moderator
Staff member
I did install the dnld filter because of a twonky issue with the mycloud drive.
Yes that will be the problem. You need to edit the iptables rule so that only packets from the MyCloud drive IP address are dropped: Web-If >> Settings >> Settings for DLNA-Filter package
 

MontysEvilTwin

Well-Known Member
View attachment 1930

This is what is shows for the other t2 (upstairs) via webif.

I don't know what the problem is?

Do I need to install some other package on the t2? I did install the dnld filter because of a twonky issue with the mycloud drive.


Sent from my iPhone using Tapatalk
I've not used the DLNA-filter package myself, but if you have not configured it just to block your NAS it will block other DLNA servers by default. This sounds like the culprit. You need to go into the settings page and just block the IP address of the NAS.
 
OP
J

Jailbrkr21

Member
I've not used the DLNA-filter package myself, but if you have not configured it just to block your NAS it will block other DLNA servers by default. This sounds like the culprit. You need to go into the settings page and just block the IP address of the NAS.

So it's the ip of the mycloud that I need to put into the filter setting or the ip of the other t2? I have tried both and the mycloud still shows in media>storage>network no matter which ip I take out of put in.


Sent from my iPhone using Tapatalk
 
Top