It did'nt work??

andy96j

New Member
In an effort to stop the green screen on my TV(now unable to clear), I installed an earlier firmware version incase it was that (.20). No luck.
From what I have found up to now its something to do with whats called the 'HDMI Handshake'.
Any ideas?
 

MontysEvilTwin

Well-Known Member
Try a different HDMI cable and make sure it is well-seated. I've seen green screen caused by a bad connection. Try the very latest firmware (1.03.12 - currently being transmitted OTA, or available on the wiki) if you have not done so already to ensure that you have the latest handshaking protocol installed. If possible try it on a different TV: it could be an incompatibility but it could also be a fault.
 
OP
A

andy96j

New Member
Tried 2 other cables with no change. It worked on the same TV for nearly a year with only minor hiccups.
It works fine on my other TV, so it is looking like a compatabilty issue or fault with TV.

Out of interest which is the favoured firmware release. (Having read the info page some of the updates are prefered more than others due to new issues created).
Also I can't find the download that stops the ota and channel search issues.

Cheers
 

HarveyB

Active Member
Have you turned on "development and advanced packages" in "advanced settings" in webif settings.

You then need to install disable_ota and disable_dso in package management
 

MontysEvilTwin

Well-Known Member
OK cheers.
Any preference in firmware releases?
I think several changes were made to handshaking. I don't suggest going any earlier than you already have (1.02.20). I would try 1.03.12, if you have not done so already, and 1.02.32. Does other HDMI equipment (e.g. blu-ray player) work with the TV in question?
 

Black Hole

May contain traces of nut
Any preference in firmware releases?
You have to decide which one provides the best balance for you. 1.02.20, 1.02.32, and 1.03.12 are (as I mentioned elsewhere) supported with CF, for the very good reason that each has properties which users might prefer. 1.03.12 because it is the latest, but 1.02.20 and 1.02.32 because firmwares later than either of these lose something as well as gaining - as described in Things Every... (click) section 1.

It is not sufficient to decribe a particular firmware as ".20", the prefix numbers mean something.
 
OP
A

andy96j

New Member
I've tried the 1.02.20 and the lastest 1.03.12 which has'nt cured it. The picture sometimes comes on for approx 2 secs then switches to the green screen.
Blue Ray 9/10 times works fine.

I'll have a read through the firmware description and see whats best for me then. I don't like the part of slow epg on the later releases!
 

dma

Member
It's a long shot, but I wonder if it's something to do with how the TV communicates during power up of the Humax unit. You could try this setting on your Humax...

Menu -> Settings -> System -> Power Management
Power Saving in Standby = Off
 

ChrisDaniels

Well-Known Member
Andy, Check if there is updated firmware for your tv.

If not try box fully off, tv off. TV on followed by box on.

Hdmi handshake problems I have seen always seem to be when the box is on before the tv or when the box is recording.
 

rpb424

Active Member
I had a similar thing a couple of years ago with, and the problem turned out to be with the TV (a Philips). The solution was a complete mains out repower of the TV with no HDMI leads connected, and then progressively plug them back in. Apparently the TV was 'remembering' characteristics of what was plugged in (whether powered or not) and this was a way to clear them. Sounded dubious to me, but can't deny that it did the job.
 
OP
A

andy96j

New Member
dma - I have tried turning the power saving off, no change.

Chris - The TV has the latest firmware installed. The sequence of turning on/off the box/TV used to work, now it does'nt!

rpb424 - So I need to remove the HDMI leads, fully power down the TV at the socket, leave a few minutes, then power back on, plug the HDMI leads back in? I will try anything right now! I have done a factory reset of the TV and latest firmware update to no effect, but leads were in.

It seems like some sort of total incompatability between the two sets. None of them individually seem to be at fault. The humax works with other TVs, the TV works with other HDMI devices. Totally miffed at the moment.

Thanks for your replies
 
Top