"Jim" update - have I broken the custom firmware?


I tried the Package Mangement / Update package list from Internet option and it showed that there were several updates available for something called "Jim" (forgive my ignorance!). I used the Upgrade all packages option to update them.

Now the web interface no longer shows what I'm watching / recording (it just shows "Status..."). The package management screen no longer lists any packages under Installed, Available or Upgrades. I did have the auto unprotect, disable auto-update, and remote scheduling packages installed but they are no longer listed. Schedule and EPG screens are also empty.

Rebooting the box makes no difference. Have I broken it? What's the best way to get it working again?

I'm running:

Web interface version: 1.0.9-5
Custom firmware version: 2.21 (build 1897)
Humax Version: 1.02.32

Thanks in advance!
Thank you!

I couldn't see any upgrades listed due to the problem, but clicking "upgrade all packages" got me to 1.0.9-6 and all is working again.

While I'm here I'd like to say thanks to all involved in the custom firmware. It turns a good device into an excellent one. I've been using it for over a year and apart from this minor glitch (which I think may have been bad timing of running the update on my part) it was worked flawlessly.
Hi guys. I've got the same issue. There's no package upgrade button or anything. All I've got is a page showing status an the system versions.

Web interface version: 1.0.8-2
Custom firmware version: 2.15 (build 1496)
Humax Version: 1.02.32

I'm using android Chrome or Firefox.

Sent on the move.
Hi guys,

Can anyone help me with this.

All I've got coming up is what's below. The last thing I did was upgrade jim executables.

Web interface version: 1.0.8-2​
Custom firmware version: 2.15 (build 1496)​
Humax Version: 1.02.32​
Try going to this URL in your web browser:

http://<ip address or name or humax>/cgi-bin/opkg.jim?cmd=upgrade

That should upgrade everything to the latest version.
Not long, and it should tell you what it's doing on the screen. If that doesn't work then you'll have to get onto the command line and upgrade that way with the command being:

humax# opkg update && opkg upgrade
That's fixed it.

Thanks a lot for your help.

Is that process documented on the wiki anywhere? I tried looking for it. I have had several issues when upgrading the webif in the past.
Command line via telnet cli.

The url just sat there processing. I had to reboot due to locked files at the command line. I waited about 10 minutes before rebooting.

Sent from my HTC One X using Tapatalk