1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MHEG info disappears from radio stations

Discussion in 'HDR-FOX T2 Freeview Recorder' started by Last.To.Know, Dec 31, 2012.

  1. Last.To.Know

    Last.To.Know Member

    Hi

    The radio station graphics that display the programme and song being played (delivered by MHEG, I believe) disappears now and again.

    I have to reboot to have it reappear.

    Is this a known bug?

    Is there a cure?

    Also, I don't turn off the T2 at night (I think I read something about that in this forum, but I can't remember the reason!), though I do have the 4.20am reminder.

    I also have a Switch On set to 6.00am to switch the channel to BBC1HD:
    could that be the, or a, problem?
     
  2. Black Hole

    Black Hole Felonius Gru

    A timer on not matched with a timer off is known to cause problems (it can get into a half-awake state), as is running continuously (things start to drop off). Leaving it on overnight used to be associated with running unencrypt, which by default only runs in the early hours but has since been found unnecessary (change the cron settings so it runs every 5 mins all the time).

    Whether either of those is your problem is another matter.
     
  3. Last.To.Know

    Last.To.Know Member

    Thanks, Black Hole.

    I'll set it to go off at 1.00am and see it that cures it.
     
  4. Last.To.Know

    Last.To.Know Member

    Well...

    I set the timer off to 2.00am and the T2 failed to wake up at 6.00am and wouldn't switch on, so I had to reboot.

    A timer off set to 11.30pm garnered the same result, so I'm back to having no Timer Off setting.

    Could you point me to instructions on this?
    (I still have the factory firmware)

    I'm reasonably OK with telnet.
     
  5. Ezra Pound

    Ezra Pound Well-Known Member

    As stated a timer off without a timer on will cause problems and should be avoided, if you want an auto On/Off period you can set a repeat 'reminder' and then don't use On/Off timers at all. For information on the custom Firmware see the WiKi guide HERE
     
  6. Black Hole

    Black Hole Felonius Gru

    My comments about unencrypt are irrelevant if you are not using the custom firmware. All I was saying is that it is inadvisable to have the Humax on all the time, and the only reason to leave it on is for unencrypt activity in the wee small hours.
     
  7. Last.To.Know

    Last.To.Know Member

    Hello again.

    I'm having problems with the T2 'freezing' overnight and needing a reboot.

    This has happened with no On/Off timers and with On/Off timers.

    I do have the 4.20am-4.40am reminder.

    Believe me, I have studied the forum before posting this, but didn't see a solution (is there a Troubleshooting section?)

    I've seen mentions of the T2 not behaving well if left on all the time, but as I say, the On/Off timers seem to make it worse.

    So, I would welcome any help on this: particularly:-
    • can this be solved using the standard firmware, and
    • would the custom firmware help?
     
  8. Black Hole

    Black Hole Felonius Gru

    What exactly do you mean "freezing"? Describe in detail what you do in the lead up, and what happens.

    Regarding your original problem, I find the slide on a radio station drops to the screen saver after a few minutes. This is normal (for Humax). Pressing the play button (a harmless operation during normal play) brings the slide back (temporarily).
     
  9. Last.To.Know

    Last.To.Know Member

    Thanks for the reply.

    The lead up is either being left on overnight, interrupted only by a 4.20am-4.40am reminder, or
    being switched off by a Timer Off at 11:00pm and being switched on by a Timer On at 6.00am, again with a 4.20am-4.40am reminder.

    The T2 does not respond to the remote: either the original factory remote or my Harmony 300; pressing the Big Button on the box itself does nothing either.

    Another, possibly related, behaviour I have noticed is the my T2 has now started to freeze due to prolonged pausing.

    I got into the habit of leaving a recording paused on the Tivo, and I also find it useful for the morning news.

    Today, I paused a recording and noticed after about 30 minutes that the screensaver had stopped moving, and the clock was ramdomly peppered with green pixels.

    When I remember, I'll check the serial number against the ones listed on this site, as this T2 was a Manager's Special.

    [Edit] In the interests of full disclosure, I will add that used the Sort option in Media a few times, finally settling on Sort by Date: it had been Sort Alphabetically.
     
  10. Black Hole

    Black Hole Felonius Gru

    Sounds like the humaxtv process is crashing.

    What firmware are you on?
     
  11. Last.To.Know

    Last.To.Know Member

    My firmware version is 1.02.27.

    Speaking of crashing, I was just watching a recording when the T2 spontaneously rebooted, sticking on the Humax logo screen with System Start on the LED display.

    I rebooted and it stuck on an Orange Screen of Death, again with System Start on the LED display (I think).

    It took another reboot to restore functionality.

    I'm now considering buying a new HDD for my PC and FTPing my files across, whilst also reading up on the custom firmware
     
  12. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    Do you have another DLNA server on your network? Some versions of Twonky can cause the Humax to reboot and there have been reports of some other programs that do not interact well with the Humax.
     
  13. Last.To.Know

    Last.To.Know Member

    Hmm...

    My network is as follows:-
    • WinXP PC
    • Tivo Series One
    • Raspberry Pi running XBMC on Raspbmc
    • Humax HDR-FOX T2

    The Raspberry Pi can stream from the PC and it can be seen from the Humax T2 and from there the T2 can browse the PC.
    (Yes, I was surprised, too.)

    What would a DNLA server look like?
     
  14. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    The Raspberry Pi running XBMC would be a candidate. You might want to look at the Raspberry Pi thread on the Forum as I think there have been one or two reports of problems.
     
  15. Last.To.Know

    Last.To.Know Member

    Thanks for the tip, Martin.

    I powered down the Raspberry Pi last night; the Humax T2 had a couple more freezes so I powered it down overnight.

    This morning it took two power ups to restore functionality: I did a HDD Test - no faults, and turned off media sharing on the T2.

    I shall use the T2 today and tomorrow to see if there are any more crashes, freezes etc. which might give me a clue as to whether DNLA is the issue.

    Either way, I shall be installing the Custom Firmware after that because it looks useful and my T2 was bought from Humax Direct (Grade A) and, although it seems unlikely, I fear my problems are caused by flaky firmware.
     
  16. Last.To.Know

    Last.To.Know Member

    Well, the T2 spontaneously rebooted again, sticking on the Humax logo screen with System Start on the LED display.

    So I've installed "Custom firmware version: 2.15 (build 1504); Humax Version: 1.02.29".

    I'm hoping it will either fix the problem, or at least identify it.

    Now I've got to work out what I can do with the CFW. :)

    Is there a specific sub-forum and/or thread for Custom Firmware?
     
  17. Ezra Pound

    Ezra Pound Well-Known Member

  18. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    If it isn't the known DLNA problem (and you doing the right things to eliminate that as a possibility) then in my view it is much more likely to be flaky hardware.
     
  19. Last.To.Know

    Last.To.Know Member

    I did the Diagnostics >> Hard Disk test...not sure what I'm looking for.

    It says "SMART Status PASSED"; apart from that, I don't know whether the displayed values are errors or not.

    The T2 just froze so I'll telnet in and try the fix-disk.
     
  20. Ezra Pound

    Ezra Pound Well-Known Member

    O.K. in the Hard Disk (Check) good signs are :-
    SMART Status = passed
    Attributes ID 5 raw =0
    Attributes ID 197 raw =0
    Attributes ID 198 raw =0
    Self test logs #1 to #4 status = Completed without error

    Note : Self test logs may only be displayed after a fix-disk, not sure