Missing Recordings/Unable to Playback or Record

Jim Craddock

New Member
Wonder if anyone has seen anything like this before? And what caused it/solved it?

Yesterday, I watched a recording on my Foxsat-HDR - worked perfectly. Then, a short while later, pressed Media to watch another recording - no recordings were listed! It did show HDD was 69% full. Exiting Media, tried to record the current program, but the Rec button just showed Live. Also, using the guide to select a program to record allowed me to pick something to record, but at the start time it did not record.

Not happy! Not happy at all!

Have another (smaller HDD) Foxsat-HDR, so was able to start copying off recordings using FileZilla, then install them on the replacement (via USB drive). This is an arduous and time-consuming task, so set some copying overnight.

Meanwhile, I could access the list of scheduled recordings, jotted them down, and set up on the replacement. Not ideal, as wife was giving grief about wanting to see last night's recording of Emmerdale (or some such rubbish)!

Then today I plugged the faulty Foxsat in, went to Media, and all the recordings were visible and playable again!

I did initially think that there was some fault with the HDD or controller, although I could see the files from the PC. So, I have no idea what the problem was, or how to resolve it if it happens again. Might it be time to replace the HDD, or is this Foxsat starting to show it's age?

I expect there is some filesystem problem (probably making it read-only) and/or physical disk problem. It is impossible to tell without either installing the customised firmware and running some tests, or removing the disk from the machine and connecting it to a Linux PC to perform similar tests.
The fix may just be a simple one of fixing the filesystem, or it may involve replacing the disk. It depends what the problem actually is as to what the best solution is.
I found this, but the post referred to the HDR-1000S rather than the Foxsat:
There is a known bug where if you try and look at the list of recordings immediately after the box has booted then they appear to be missing. Putting the box into standby; leaving it standby for a short period (say a minute) and then restarting and again awaiting for a short period before looking at the list should see the recordings return.
Thanks guys.

My thoughts were along the same lines, ie file system related (either software and/or hardware). The custom FW is installed, what tests could I run?

This is a fault that I have never experienced before, and I must have pressed Media straight after booting up many, many times.
Which version? Install the smartctl package first (and telnet package if you don't have it already).
Telnet (or Putty or similar) to the box and at the command prompt enter the following and report the output: smartctl -a /dev/hda
Then the mount command and report the output.
Then you might want to try running fix-disk and follow the instructions.
FW v4.1.3 is installed. Web Interface v2.91. Telnet is installed in Package Management. I have found and installed smartctl. (Reading suggests this is software to check HDD for faults)

Sorry but I have no idea how to "Telnet to the box"
Thanks, I think I have managed to extract the data prpr asked me for (attached)


  • HDR1000 smartctl.txt
    10.9 KB · Views: 8
Model Family:     Seagate Barracuda 7200.12
Device Model:     ST31000528AS

  5 Reallocated_Sector_Ct   0x0033   081   081   036    Pre-fail  Always       -       797
  9 Power_On_Hours          0x0032   091   091   000    Old_age   Always       -       8201
 12 Power_Cycle_Count       0x0032   098   098   020    Old_age   Always       -       2485
197 Current_Pending_Sector  0x0012   066   066   000    Old_age   Always       -       1403
198 Offline_Uncorrectable   0x0010   066   066   000    Old_age   Offline      -       1403
You need a new disk. It's pretty terrible for something that has had less than a year of (equivalent continuous) use, but it looks like it's a 'desktop' drive rather than a 'video' drive, so I guess it came out of something else before it went in to the Foxsat.
I had noticed the 340 days too in the report (I bought it second hand 18 months ago), so what you've spotted makes sense. I had presumed that it contained the original Humax 1TB disk it was built with, but obviously that is not the case.

I'm currently using the 320MB Foxsat, whilst copying recordings off using FileZilla.

I would like to replace/upgrade the HDD - what would you suggest? And the bigger the better (I believe 2TB or even 4TB can be fitted).
I had presumed that it contained the original Humax 1TB disk it was built with, but obviously that is not the case.
Indeed not. Has somebody pulled the wool over?
I would like to replace/upgrade the HDD - what would you suggest? And the bigger the better (I believe 2TB or even 4TB can be fitted).
Apparently, the Foxsat will only partition/format up to 1TB disks automatically. You would need to do anything bigger externally on a Linux machine first. The limit for a Foxsat is 2TB.
The following still seem to be available from the A company (other suppliers may, or may not, also be available):
Seagate ST2000VM003 Pipeline HD
Seagate ST1000VM002 Pipeline HD
These are likely to be old stock but should be unused i.e. 0 hours etc. on the clock (you now know how to check!).
Caveat emptor!

Thanks for your invaluable input, I now have some reading and research to do.

There may (will) be some further questions later!
Although whether the dodgy SMART stats are responsible for the original problem, is another matter.
A quick update, and thanks again to all who helped me.

Ordered the ST2000VM003 Pipeline (new stock on Amazon, £27), stuck it in a docking station, partitioned as 4 EXT3 partitions (using EASEUS Partition Master), removed old drive, put in new drive, started the Foxsat and now have 1.72TB available.

All is good and working!

Thanks again for all your assistance