Mp4 files playing full screen when should be 16:9???

Hi All

Just a quick question, I use Freemake to convert files to mp4 to play on my humax and it seems to work nicely however for some reason it outputs them all full screen rather than in widescreen format with black bars top and bottomso everything is a little tall and narrow.

Is there anyway round this?

When I create the mp4 files I opt to keep dimensions the same as the original file so they should still be in a wide format and they appear to be when played on my pc. I'm assuming it's the hummy scaling the file to the output format I have set in the settings but is there anyway to stop this?
 

Kev_w

Member
This is a known issue.

The work around is to go to the display settings on the humax and select 4:3 ratio. That in itself wont make a difference but now the option below will allow you to set "letterbox" - after that the aspect ratio will be correct.

You will need to turn it back afterwards...

Posted on the move
 
OP
V

valve90210

Member
Cheers, that's not too bad a workaround really, tis a shame the boxes doesn't automatically sort things like this out but I guess everything has it's limitations and the hummy is doing a pretty amazing job as a digibox already what with the web if stuff, remote scheduling etc etc...
 

sooty83

Member
The shape of a video depends on 2 things: the number of horizontal and vertical pixels that makes up each frame and the shape of each individual pixel, i.e. the pixel aspect ratio (PAR).

When a video file doesn't play with the correct shape on the Humax, usually it is because the PAR is missing. While most media players on a PC assume a default PAR of 1:1 (i.e. square pixel), the Humax assumes that the overall video has an aspect ratio of 4:3. You may think that a PAR of 1:1 is the obvious choice to use as a default, but actually most programmes, all standard def ones in fact, transmitted over the air do not have square pixels.

You can fix this by setting the PAR of the video file using the MP4Box command line utility. I believe there is a GUI for it called YAMB but I have never used it.
 

Black Hole

May contain traces of nut
The Humax can only be told to distinguish between 16:9 and 4:3 and whether the output display has a 16:9 or 4:3 screen format. It doesn't matter what the pixel aspect ratios are, the raster gets scaled to the 16:9 or 4:3 that it is set for. Telling the Humax that the TV is 4:3 when it is really 16:9 tricks it to display at 2.37:1.

See Things Every... (click) section 16 (and the reference therein).
 

sooty83

Member
Black Hole, you are right. When I read the title of this thread, I thought the Op was playing a 16:9 recording, expecting a 16:9 output but got 4:3 (tall and narrow), and I assumed the Humax was set to pillar box mode. In that case, the cause is what I described and setting the PAR fixes it. For recordings wider than 16:9, then you are correct and your workaround is needed.
 

peterpi

Member
Try altering the settings in Freemake. Edit the file you want to convert so you get a twenty second or so video. Click on cog to get into the settings window. Click the Frame Size button and set it to whatever size your file is at present, but don't select the "Original Size" button. Then click the "Adjustment" button and try "Auto", which will usually produce a video which looks right. There are a few other options which you can try, but the one I've mentioned does it for me.
 

Black Hole

May contain traces of nut
The only way to make a wide-screen video file play without distortion (other than using the 2.37:1 trick) is to re-encode it with black bars to pad out the top and bottom and produce a 16:9 frame. This is what films on Blu-ray or DVD do (or the player imposes black areas before sending out the video).
 
Top