My Web IF stopped working


New Member
HDR Fox T2 with 1.02.32/2.15 firmware.
I have been using my HDR with customised software with no problems for many months. Suddenly I am not able to get the web interface to work. The browser connects and displays a wide light grey bar at the top but nothing else. Reloading gives same result.

If I Telnet into the box and look at services it shows Mongoose as autostart but NOT started.
If I give a start Mongoose service command, it tries to start but then gives message;

humax# service start mongoose
Starting mongoose...
humax# Loading config file /mod/etc/mongoose.conf
Failed to start Mongoose. Maybe some options are assigned bad values?

Try to run with '-e error_log.txt' and check error_log.txt for more information.

If I look for error_log.txt I don't find anything.

I'm stuck can anyone help me get my web browsing back. I've reloaded firmware 3 times now and tried different browsers on different computers.

p.s. sorry for bold but trying to make it easy to see what is my text and what is message text.
Mongoose was the old Web-If program, it was replaced by lighttpd, if lighttpd is running mongoose should not be running. If lighttpd is doing the Web-If server duties, I would expect service to show :- mongoose. . . installed = Yes, autostart = No, running = No

lighttpd was introduced in webif 1.0.13 (released 11MAY2014), what do you get if you enter command line opkg info webif e.g. :-

humax# opkg info webif
Package: webif
Version: 1.0.15-5
Depends: webif-channelicons (>= 1.1.11), lighttpd (>= 1.4.35-2), jim (>= 0.75-1), jim-oo, jim-sqlite3 (>= 0.75), jim-cgi (>= 0.7), jim-binary (>= 0.75), service-control (>= 1.2), busybox (>= 1.20.2-1), lsof (>= 4.87), epg (>= 1.0.13), hmt (>= 1.1.21), ssmtp, anacron, trm (>= 1.1), openssl-command, nicesplice, id3v2, file, rsvsync (>= 1.0.2), webif-charts (>= 1.2-1), stripts (>= 1.2.5-3), smartmontools, tmenu (>= 1.08), ffmpeg, id3v2, multienv (>= 1.6), mongoose
Status: install user installed
Section: web
Architecture: mipsel
MD5Sum: c2f868961ac441b121a81dc7883faaac
Size: 1641098
Filename: webif_1.0.15-5_mipsel.opk
/mod/webif/html/css/EXTRA.css 2296ae44e6bee6d5946db4587739bbfd
/mod/webif/html/favicon.ico 5b0d687146e283edcd282a214b25061c
/mod/webif/html/img/fav/57.png 51792cfa41206972f824d58c1a545c0d
/mod/webif/html/img/fav/72.png 7450d014122e48bee30868a11ab29b47
/mod/webif/html/img/fav/114.png 6ca7f47962eecf576053c8bd41c97b9e
/mod/webif/html/img/fav/144.png 5486867673594037e0a585e8f48abef4
Description: An evolving web interface for the Humax.
Installed-Time: 1403737946
How do I check if lighttpd is installed and working ? As I previously said, this box has been working perfectly and suddenly stopped giving correct web interface.
My telnet showed mongoose installed, set to autostart but not started.
I'm really puzzled, the box works, it is connected to network, I can telnet into it and the web browser page opens with no error message but just a light grey bar approx 1 inch high across the page.

I have no idea what to try next.
It would help I knew what version of Web-If you were running (as in #2), you can get info for lighttpd with :-
humax# opkg info lighttpd
Package: lighttpd
Version: 1.4.35-2
Depends: swapper
Status: install ok installed
Section: web
Architecture: mipsel
MD5Sum: 5ce685f654c827b1a39a61679ed6163d
Size: 233092
Filename: lighttpd_1.4.35-2_mipsel.opk
/mod/etc/lighttpd/extra.conf 7bfa62271212309f1568ac2a03a2532e
Description: Lightweight web server
Installed-Time: 1400090771
Thanks for trying to help me.

Sorry, going blind missed your previous code;
Forum will not let me send you copy/paste of full telnet because I don't have 10 posts.
webif version 1.0.15-9

Information basically same as your example

the lightttpd shows version 1.4.35-2 with info same as your example.

O.K. so mongoose shouldn't be running and lighttpd should be, I suggest you reload the Web-If with :-

humax# diag fix-webif
OK diag fix-webif as suggested, seemed to go ok but my problem still persists.
Crazy huh !!
It seems humax web server is sending the grey bar as a png but nothing else to the browser
I've tried 3 different browsers and 2 different computers already, as my first thought was a browser problem as box had been working fine for many months.

Black Hole; are you suggesting I may need to re format hard drive, does firmware live on the hard drive ?

thanks and regards
are you suggesting I may need to re format hard drive
No need to go that far yet.

On the Telnet command line (from the Telnet menu select "cli", the command prompt should be "humax#") type
opkg install webif --force-reinstall

does firmware live on the hard drive ?
The WebIF is a package, not part of the custom firmware that is installed from the USB. With very few exceptions, only the USB installation is installed in the non-volatile memory - the rest is on the HDD. See Glossary (click), entry "CF / CFW".
No need to go that far yet.
On the Telnet command line (from the Telnet menu select "cli", the command prompt should be "humax#") type
opkg install webif --force-reinstall
The OP has already done this, by sending
humax# diag fix-webif
In desperation ran suggested telnet anyway.
When I ran; opkg install webif --force-reinstall it went through a download and an install but ended with following message.
Don't know if this is significant ??

Collected errors:
* file_md5sum_alloc: Failed to open file /mod/webif/html/favicon.ico: No such file or directory.


Thank you, thank you, thank you, gentlemen, problem is solved, running maintenance disk check fixed the problem, everything back to normal.
Fantastic help, my best wishes to you both
Alan :D