NAS Share Broken, Is virtual-disk2 To Blame?

Hello. I have an HDR Fox T2 running customised firmware v3.13. I've installed the virtual-disk2 package and until recently was able to view and stream video files from a NAS in my network using the smb option in the [ModSettings] folder. Recently the NAS did a big firmware update and (possibly coincidentally but probably not) I can no longer see the NAS from the Hummy. In other words I press Media, then Blue (Storage), then USB and all I can see listed is "VirtualUSB". Previously I could also see my NAS listed by name. I've checked all the settings in the [ModSettings] directory and they look OK. Smb is still enabled on my NAS. Any suggestions how I can find out what's wrong? Thank you for any help you can offer.
 

Black Hole

May contain traces of nut
Smb is still enabled on my NAS.
...but maybe not SMB1. Check that, because SMB3 won't do. If NFS is available, use that instead (and set up a NFS share in [ModSettings]). Alternatively the NAS might now be on a different IP address.

BTW (updated): this has nothing to do with the thread it was posted in ("[virtual-disk2] Virtual USB drive"), so a new thread has been started.
 
Last edited:
OP
B

bingbonglong

Member
...but maybe not SMB1. Check that, because SMB3 won't do. If NFS is available, use that instead (and set up a NFS share in [ModSettings]). Alternatively the NAS might now be on a different IP address.

BTW: this has nothing to do with the title of this thread.
Thank you for your reply. I'm sorry my post is in the wrong place. I thought I was posting about a virtual USB drive and virtual-disk2. I must have misunderstood.

It turned out my NAS was offering SMB1 and SMB2. I've limited it to SMB1 now, but it hasn't made a difference.
I've tried nfs too, but that doesn't seem to work either. I'm not sure about some of the nfs settings, though. The only documentation I can find is here (https://wiki.hummy.tv/wiki/Custom_Firmware_Package_Notes#Virtual-Disk2) and it doesn't really explain the options. I did note there's nowhere to put a password in the nfs settings.

The NAS is definitely still at the same IP address.

All very mysterious.
 

Black Hole

May contain traces of nut
I thought I was posting about a virtual USB drive and virtual-disk2. I must have misunderstood.
It's the network-shares-automount (NSA) package which reads the [ModSettings] folder for the desired configuration and then automatically mounts the target network storage as if it were a USB drive.

virtual-disk2 is a tool for mounting HDD folders as fake USB drives, and is only required to fool the Humax firmware into accepting that it has USB drives and make them available in the Media >> Storage >> USB menu, and you only have to do this if you don't have any real physical USB drives plugged in. Without an existing real USB drive (or virtual-disk2), the Humax firmware doesn't go looking for NSA pseudo-USBs to mount. The original virtual-disk package creates virtual USB mounts but still needs a physical USB drive as well (including for its own mounts).

In other words: NSA is doing the heavy lifting; virtual-disk2 is an accessory.

The only documentation I can find is here
You should be looking at the details in the network-shares-automount thread. Readers can locate threads relevant to any particular package via https://hummy.tv/forum/threads/index-of-package-primary-topics.8005/, pinned near the top of the Custom Firmware section of the forum.

It turned out my NAS was offering SMB1 and SMB2. I've limited it to SMB1 now, but it hasn't made a difference.
You don't need to limit it, so long as SMB1 is available.

The NAS is definitely still at the same IP address.
Dunno then. Read up about network-shares-automount and see if it gives you a clue. However, the mistake was in updating your NAS – don't fix what ain't broke.
 
Last edited:

/df

Well-Known Member
Maybe your NAS update has enabled some firewall-ey module that blocks SMB1 regardless of how SAMBA is configured?.
 
OP
B

bingbonglong

Member
If it turns out that this is the cause of the problem it would be helpful to know the make and model of your NAS.
[My Synology DS218j has an option to check for updates but not install them automatically.]
My NAS is a Synology DS218play. It's tricky to ignore updates, because they usually fix a security issue, and it's not usually obvious that something will break until after you've done the update. I updated the DSM to 7.0.1, if it's relevant/useful.
 
My NAS is a Synology DS218play
Thanks, if I understand Synology's model designations I think they are quite similar, your DS218play being a bit more powerful than my DS218j.
For what its worth I'm on DSM 6.2.4-25556 Update 2. I'll certainly watch out for any firmware update (nothing so far in nearly 3 years).

I expect you have checked that nothing has changed on the HDR side but just in case.....

On the HDR my Mount Name is 'NAS' so the SMB connection parameters in MyVideo/[modsettings]/smb/NAS are:
folder= [name of the shared folder defined on the NAS for the HDR to access]
host= [the NAS network ip address, with '.'s replaced by '_'s]
password= [password defined for HDR's username on the NAS]. I've set this to 'always valid'.
user= [username assigned to the HDR on the NAS]
All other parameters are left as default.
 
OP
B

bingbonglong

Member
In parallel with posting in this forum, I contacted Synology to see if they could help. They were able to look at the NAS logs and solved it for me. The answer is twofold:

1. Control Panel -> File Settings -> SMB -> Advanced Settings -> Minimum SMB protocol -> SMB1 (as suggested by @Black Hole )
2. Control Panel -> File Settings -> SMB -> Advanced Settings -> Others -> Enable NTLMv1 authentication.

These settings are for a Synology DS218play NAS but might help others identify how to solve a similar problem with their own NAS.

It's all working again now. Thank you for all the help offered.
 

/df

Well-Known Member
As the old newspaperman's saying goes, if a headline ends in a question-mark, the answer is "No"!

Could point 2 above be relevant in the other thread too?
 
Top