No effect of custom encryption key

The Baron

New Member
My HDR-FOX T2 died, so I bought another and moved the hard disk across. I thought that by changing the custom encryption key in Webif Advanced Settings to the encryption key of the original box I would be able to immediately watch my old recordings, but on playback I'm still getting the encrypted message.

I also tried making a new recording, then changing the encryption key, but after a reboot I could still watch the new recording, which is not what I expected. Have I got the concept wrong?
 

Black Hole

May contain traces of nut
No, you've got it about right, so it ought to be working.

Be specific: give us a screen grab of the details in your Advanced Settings:

1597823247463.png
(that's one of mine)

How did you determine the correct string?
 
OP
T

The Baron

New Member
Thanks for the confirmation that it should be working. I had the key written down from when I'd used stripts previously.

You led me to believe I hadn't got everything installed properly, so I ran the fix-flash-packages diagnostic and that has got it working perfectly.

My error was that after I moved the disk into the new machine and installed the custom firmware I found that my previously installed packages were already present, so I assumed that I was done at this point. There must have been some flash changes to complete.
 

/df

Active Member
Presumably nugget, which causes its library /var/lib/humaxtv_backup/mod/libnugget.so to be loaded into the Humax settop binary and hooks into its private parts, including the encryption key. The /mod/bin/nugget program is used to change the key.
 

Black Hole

May contain traces of nut
One of the more interesting things about this thread is yet another non-posting member or even non-member coming out of the woodwork as a long-term CF user familiar with things such as fix-flash-packages. I wonder how large this silent community is?!
 
Top