No more package updates for Custom Firmware 2.xx (after March 2015)

af123

Administrator
Staff member
Now that Custom Firmware 3 has been out for a while I plan to retire support for older versions as of the 1st of April 2015. This means that after March 2015 any Humax devices running CFW versions below 3.00 will be unable to download package updates. They will, however, continue to work as they are.

Removing support for older versions will allow me to clean up some things that have had to stay around to help with older versions (such as the mongoose package) and reduce the amount of regression testing that needs to be performed for new and updated packages.

Please consider upgrading any devices running pre-3.00 custom firmware to the latest version, thanks.

See http://wiki.hummy.tv/wiki/CFW2.xx_End_of_Life for more information and a summary of the pros and cons of the different underlying Humax software versions.
 
Last edited:

Owen Smith

Active Member
I had just last week decided it was time to upgrade to CFW 3.00. However I try to keep my boxes, my Aunt's and my parents' boxes running the same software which requires some coordination. Christmas is a good opportunity to upgrade them all.
 

Wallace

Traveler 34122
Yes. When I saw 'End of life...' in my email header I thought af123 had thrown the towel in.

Glad that is not the case!
 

Black Hole

May contain traces of nut
I'm not sure even "withdrawal of support" describes it properly - we will presumably continue to answer questions raised, usually by saying "update to..."!
 

Black Hole

May contain traces of nut
:indignant:

It's relevant to this topic. Titles should say what they mean and mean what they say. "End of life" sends the wrong message.
 
OP
af123

af123

Administrator
Staff member
I'm not sure even "withdrawal of support" describes it properly - we will presumably continue to answer questions raised, usually by saying "update to..."!
True - although when you first proposed the term it felt better than end of life to me. People will still be supported by the community I just want to reduce the overhead on maintaining packages.
 

raydon

Well-Known Member
:indignant:
It's relevant to this topic. Titles should say what they mean and mean what they say. "End of life" sends the wrong message.
Please spare us the righteous indignation. You're the last one who should be telling anyone how to describe anything. You go to extreme lengths to defend and justify your right to use your own words to say what you mean, so please allow others the same freedom.
 
Last edited:

Ezra Pound

Well-Known Member
Now that Custom Firmware 3 has been out for a while I plan to retire support for older versions as of the 1st of April 2015.
I think it would help if an on-screen Web-If message could be displayed for pre-CFW Ver.3 users, as it would help with the inevitable flood of potential users posting "What Has Happened To My Package Updates ! ! !" around April time
 

Wallace

Traveler 34122
On the face of it that would be a good idea. However, wouldn't they have to get an update for the WebIf to display something like that? If they do, then they might as well update to v3 anyway.

Just a thought.
 

Ezra Pound

Well-Known Member
Agreed, but a Web-If update is achieved automatically (if auto package update is installed) or with a simple manual package update, whereas the jump to CFW Ver. 3.00 is a Firmware upgrade via a USB. I have to confess that I still get a bit nervous about doing the latter, even though I have done it many times without a problem (other than the still painful "why won't the Humax see my USB device? It worked last time" problem)
 
Last edited:

Wallace

Traveler 34122
Good point. I must get around to updating my spare HDR, it is still on CF v2.22. Mind you, its in a bag in my wardrobe at the mo!
 

farrow

New Member
Having never previously updated the firmware, is it just a case of installing over the top? Will the packages need re-installing/configuring?

Current:
Web interface version: 1.0.13-2 (Lighttpd)
Custom firmware version: 2.23 (build 2035)
Humax Version: 1.03.12 (kernel HDR_1.03.12)
 
Top