Oddity copying to USB 3.0 drive

catnap

Member
I have 3 x 1TB external USB 2.0 drives each formatted as NTFS. I have for some time used them without difficulty to copy both to and from the HDR T2.

Finally got round to purchasing a 2TB USB 3.0 drive - one suggested by hairy_mutley in another thread: http://www.amazon.co.uk/Toshiba-HDTC720EK3CA-Canvio-External-Drive/dp/B00CSH1CUA

I am running 1.03.12 and CF 2.22 with the ntfs-3g and ntfsprogs packages installed.

I formatted the new drive as NTFS and found the following:

1. Files copied from other drives to the new one, via laptop, play without problem on the HDR regardless of whether the drive is connected before or after startup.

2. If the new drive is already connected at startup, navigation is slow and attempts to copy from the HDR to that drive result in a message "Cannot copy files to the USB storage device because the type of the files system is NTFS".

3. If I then also connect one of my old USB drives to the other USB port on the HDR I can copy from the HDR to either of the USB drives without problem.

4. If I connect the new drive to the HDR after startup, copy to it from the HDR works fine.

5. If both the new drive and any of the old ones are already connected at startup, only the new drive shows and copy to it may or may not result in the "cannot copy....NTFS" message. Disconnecting the old drive then reconnecting, it while the HDR is still powered up and the new drive is connected, results in both drives showing and copying as in 3 above.

I haven't yet tried other permutations. I suspect part of the above may be related to the power drawn by the USB 3.0 drive though I don't see how that would relate to the NTFS/copy issue.

Any thoughts or suggestions - other than just being a bit more considerate when using the new drive?
 

MontysEvilTwin

Well-Known Member
I have seen this too with a 2TB WD drive. I have a theory as to why it happens. Initially the NTFS-formatted drive mounts with the standard Humax read-only driver, then NTFS-3g takes over. This seems to be slower with larger drives. If you select Storage>USB using the remote control before NTFS-3g has started, the unit gets stuck using the default driver: you will see the amout of disk space available on screen (this is not available with NTFS-3g) and menu navigation will be like wading through treacle. You should be able to eject the drive and remount using the Web-If eject button, though this will also be slow to access drive information.
The way to avoid the problem is to wait until the drive is mounted with NTFS-3g before selecting Storage>USB with the remote control. You can monitor this with Web-If. If you press the eject button and the drive is mounted as 'Usb-drive1' for example, it should be OK. If it is still mounted as 'Drive1' it is not ready. If it gets stuck at 'Drive1' then you will have to eject and remount the drive.
 
OP
C

catnap

Member
Thanks Montys. Your description is consistent with my experiences right down to the disk-space display and need for waders.
 
OP
C

catnap

Member
Yes it seems the same issue h_m. The fact that your drive is always connected at start-up is key. I have tried mine a few more times and it always shows as read-only if connected at start-up, but is read/write if connected afterwards which works fine for me.

Thanks again for the recommendation on the drive itself. Looking back through my Amazon history I see that I paid £250 for a 500GB external drive in 2006. £60 for 2TB seems a bargain now.
 

hairy_mutley

Active Member
I have tried mine a few more times and it always shows as read-only if connected at start-up
Since mine is always connected, I think that I would have noticed if mine exhibited that behaviour.
Further tests confirm that it simply varies which mode it ends up in; sometimes ro, sometimes rw.
Past observations agree with MontysEvilTwin; it initially connects as drive1 (read-only), the problem is whether it then switches to usb-drive1 (read-write).
It may be that some times, I have simply accessed it to quickly and locked it into the ro mode?
Using the Web-if to eject and rescan normally (always?) solves the problem, but is a pain if you are working from the SUI and does take a time about a minute to complete.

Anyone got any ideas for diagnostics for this one?

I see that e-buyer have recently been offering a desktop (i.e. uses a power brick) external drive; USB3 5T for £114
 
OP
C

catnap

Member
An important limitation in my observation is "a few more times". I have though this morning tried the drive with another HDR T2 with the same results.

For me the Hummy startup process itself is much slower if the new drive is already connected (consistent with MontysET findings) but if it and another of the older proven ones are both attached this is not so noticeable and both drives are rw (well so far for me).
 

Trev

The Dumb One
I had a portable USB3 HDD that would not start if it was connected when I started my TV, Hummy or computer. It was OK if I plugged it in when the computer/TV was already switched on. I suspect it was something to do with the source PSU not providing enough start up current for the HDD when the TV/PC is first switched on.
I wonder if this is the same as in your case? I changed it for a Toshiba drive and that works just fine. I suspect that if you had a mains powered HDD with an external wall wart, it will be OK.
 
OP
C

catnap

Member
I have a WD USB3 drive that behaves as you describe Trev and I suspect this is related to power requirement. The new one is a Toshiba and it connects, but with the behaviour described. Its not that much of a problem for my use now that I am aware of (I was almost foolish enough to write "understand") the limitations.
 

Trev

The Dumb One
The original USB3 portable drive that gave me the problem was a WD one, but the Toshiba one is fine.
 
Top