Package Management Not Working Properly

I have just tried to update the packages on my Humax and I ended up having to shutdown the Humax after upgrading each package, a white box would appear with no message in it as if to say there was an error.

I was only able to upgrade one package at a time and then I could not access the Humax after each one from the webif, it now all seems to be ok, but this has never occurred before.

Using :-
Web interface version: 1.2.8-11
Custom firmware version: 3.00 (build 2137)
Humax Version: 1.02.32 (kernel HDR_CFW_3.00)
Loader Version: a7.30

Any ideas anybody ...
 

af123

Administrator
Staff member
Yes, unfortunately this was a fault introduced by the web server software upgrade last month. Every time you install a package it tries to complete the configuration of that package which results in the web server software being shut down halfway through.

This can be fixed by running a package upgrade from the command line but I'd like to try and fix this centrally for everyone as it is still catching people.

Would you be able to run the lig diagnostic and post the output here?
 
I don't know what a lig diagnostic is so I ran the general diagnostic, does this help ?.

>>> Beginning diagnostic general

Running: general

*** Directory Structure ***

Checking /mod partition type : Pass
Checking /mod filesystem type : Pass
Checking /mod/tmp directory exists : Pass
Checking /mod/var/opkg/tmp is a directory : Pass
Checking /mod/boot is a symlink : Pass
Checking /var/lib/humaxtv/mod is a directory : Pass
Checking /var/lib/humaxtv_backup/mod is a directory : Pass
Checking /mod/boot/2 is a symlink : Pass
Checking /mod/boot links correctly : Pass
Checking /mod/boot/2 links correctly : Pass

>>> Ending diagnostic general
 
Last edited:

af123

Administrator
Staff member
Just type the word 'lig' into the bottom box and then click on Run Diagnostic.

upload_2016-3-22_11-32-20.png
 
OK, Done.

>>> Beginning diagnostic lig

Running: lig
Package: lighttpd
Version: 1.4.39-1
Depends: swapper, service-control (>= 2.0), libpcre (>= 8.37-1)
Provides:
Status: install ok unpacked
Architecture: mipsel
Conffiles:
/mod/etc/lighttpd/extra.conf 41252aa0a4d43cd9131da349bb46d1b9
Installed-Time: 1458636489
Auto-Installed: yes

Package: anacron
Version: 2.3-1

>>> Ending diagnostic lig
 
Last edited:

af123

Administrator
Staff member
Thanks - if you run the 'fixpkg' diagnostic that should sort it out for you.
There will be another webif and rs update tonight so that will provide a chance to test.
 
Top