Packages Disappearing

4ndy

Forum Supporter
I know that this may sound a bit strange, but I noticed this first last week. Packages I have had installed for over a year, are becoming uninstalled.

Last week I noticed that my [deleted] folder was not emptying. Turned out to be the undelete package was showing as not installed. I installed it again through the package management and all seems fine. I put it down to a "one off" gremlin in the auto update, as that package was updated on March 15.

Tonight I noticed that although I had two recordings going at the same time, the ring was not purple. The Redring package seemed to have uninstalled itself. I remember seeing the purple ring as recently as last night. I have reinstalled, but not yet able to reboot. This time there doesn't appear to be a related update which kills my previous theory.

Does anyone have any ideas as to what is going on?




Sent from my iPad using Tapatalk
 

prpr

Well-Known Member
Crash protection has disabled packages such as this. Run the fix-flash-packages diagnostic (and check the crash.log files while you're on the Diag page). This is probably in BH's list of things every owner should know, but ICBA to look it up.
 
OP
4ndy

4ndy

Forum Supporter
The last crash logged was 10th January.

Does disabling a package move it from the installed package list to the available package list? I can see how it might clear them out of flash, and fix-flash-packages restore them, but this seems to go beyond that.


Sent from my iPad using Tapatalk
 
Top