recmon queries

Sim1

New Member
1. recmon seems to be stuck on a verbose logging level. I think I increased the logging level in settings and then reduced it, but recmon is still logging at 10 second intervals. Any idea how I can reduce the logging level for recmon again?

2. I've been using a script as a cron job that copies swept files to an nfs mount. This seems to crash the humax sometimes, despite attempting to run it with 'nice' and not running it when autorun or autotrigger is running. It might be an nfs thing, might need to look at fuse/sshfs. A better way to do it might be to execute the copy script after autotrigger using recmon - can I just add a script to the /mod/etc/recmon.d folder to do this, is there any man info on how to use recmon? No worries if not.

Simon
 

af123

Administrator
Staff member
Any idea how I can reduce the logging level for recmon again?
I'd guess you've edited the recmon startup script and added the -d flag to the command. A force reinstall of the package is one way to undo that.
is there any man info on how to use recmon?
No but it's easy enough to describe. It runs every script in /mod/etc/recmon.d in response to events. The order that they are run in is not guaranteed (they actually run in parallel).
The commands are run with two arguments, a switch saying which event triggered this and the base name of the recording file (no extension).

e.g.

/mod/etc/recmon.d/test -start "/media/My Video/path/to/recording"

Flags are -start, -stop, -move and -delete. Usually -move is called twice, once for the source location and once for the destination.
 
OP
S

Sim1

New Member
Thanks af123. I wondered if the scripts could be ordered or not, thanks for including the info, appreciate your help!

Simon
 

The Greek

New Member
I've also found that recmon is logging every 10 secs. I've tried performing a forced re-installed of the package, but with no improvement. Is there anything else I could try?
 

MymsMan

Ad detector
Try editing /mod/etc/init.d/S54recmon and remove -d (lower case) from the startup command

It appears the package is shipping with the debugging option set which it shouldn't be
 
Top