• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
  • The forum software that supports hummy.tv has been upgraded to XenForo 2.0!

    This is a major upgrade which changes the look and feel of the forum somewhat but brings a host of improvements too. Please bear with us as we continue to tweak things and report any issues or suggestions in Site/Forum Issues.

Remote stops working after a while

#1
Hi all,

I have a problem with my HDR-FOX-T2 where the remote stops working after a time (a minute or two), and then later will start working again (about 30 mins). It will then stop/start working at random intervals after that. It is very frustrating and makes a very good bit of kit very hard to use.

It is not the remote at fault: Earlier in the year Humax sent me a replacement and there was no change, and the remote can be used to control other equipment.
It is not the box locking up: the buttons for volume and channel on the front work fine
It is not user error: I know there are many posts on making sure that the correct mode is selected. It is.

It was fine for the first 10 or 11 months, and then starting doing this. The only change at about that time was that we had a new TV, and started using HDMI instead of SCART. Connecting to the new TV via SCART makes no difference though.

I have kept the firmware up to date at all releases, and that has not changed it. I noticed that the 1.02.28 (I think) release claimed to have fixed a problem with the remote not responding after about 10 seconds, so was hoping that would have fixed my problem, but it didn't.

Does anyone out there have the same problem? Has anyone managed to fix it?

Thanks,

Paul.
 

Ezra Pound

Well-Known Member
#2
As unlikely as it sounds it has been reported HERE (#29), that a faulty HDMI cable was the cause of erratic Remote Control behavior. When you switched to Scart did you completely remove the HDMI cable from the Humax, If not, it might be worth a try
 
OP
OP
Paul Vickery
#3
Thanks Ezra, I'm pretty sure I completely disconnected the HDMI lead, but I'll try that again tonight just in case, and post back.
 
OP
OP
Paul Vickery
#5
Thanks Ezra, but disconnecting the HDMI hasn't helped.

Thanks BH - tried that, and checked for other IR sources etc.

So, still no solution! Ho hum. I guess I'll have to find my receipt so I can get it replaced.
 
#6
I too have found that my remote was causing issues. However in my case the problem was with the battery compartment. The short metal springs holding the battery did not make sufficient contact to allow consistent usage. As the remote was handled it obviously made or broken contact sufficient to cause it stop working. I initially resorted to giving it a whack to reset the battery. This was sufficient for a time. But in the end I got fed up and inserted a couple of small pieces of kitchen foil between battery and clip and since then I have had no issues.
 
OP
OP
Paul Vickery
#7
Unfortunately it's not that simple for me:
It is not the remote at fault: Earlier in the year Humax sent me a replacement and there was no change, and the remote can be used to control other equipment.
 
#8
I have a similar issue to the OP. I will try to detail the background.

Bought the HDR-T2 in February 2011, at the time we had a Sagem HD45 connected via a HDMI/DVI-D cable.
All was generally well, occasional green screen if the HDR was recording when the TV switched on, could live with that as connected via Scart too.
The remote was programmed with a code for the Sagem TV and also a Panasonic DVD player and worked well. Occasionally it would stop working, it would not work either the HDR, the TV or the DVD. Removing and reinserting the batteries would cure this.

Fast forward about a year to when the Sagem TV died. We were able to borrow a Panasonic LCD TV whilst deciding what to replace the Sagem with. The Panasonic was connected via HDMI. Remote reprogrammed with a Panasonic code. After a couple of days it would lock up, still working the TV and DVD, but the HDR would not respond. Remote was sending something as observed using a phone camera. Powering off at the front panel and restarting would sometimes cure the situation, but not always, and I think that if the unit was recording then powering off at the front would not help. Keeping the unit running at version 1.02.20 would help, though not always. Humax sent a replacement remote but the problem appeared with this too. Meanwhile we purchased our own Panasonic plasma TV.

In a moment of inspiration I programmed the Sagem codes back into the remote handset and it ran OK for some months. Then I returned to the Panasonic codes and it was OK for a while, but the problem came back so I tried another Panasonic code (working backwards from the end of the list) and it was OK again for a while.

About 6 weeks ago I started to use the customised firmware as I'd purchased a 2TB USB drive and wanted fuller control of the unit. Soon afterwards the remote behaviour crept in again, but now I had the chance to still control the HDR through the ir package.

I though I'd switched on some IR diagnostics somewhere but I can't find a reference to it now.

What I was wondering, is can the ir subsystem be somehow restarted, perhaps on a cronned basis so the outage need only be one minute.
 

Black Hole

May contain traces of nut
#9
Do you mean the standard Humax remote system? As far as I know the Humax code does not break down into modules, there is one big program which does it all so you would have to restart the whole thing.
 
#10
I do mean the Humax remote system.

I read the thread about the HDMI cable with interest, and in the past I have swapped cables around, the trouble is as the problem can come and go, you do get false positives as the issue can just go away at the same time as you switch or pull a cable, and there's no way to know (yet) what is going on

Read up on ir3debug_on and going to reset the unit in a few minutes once it finished with some recording.
 

Ezra Pound

Well-Known Member
#11
I though I'd switched on some IR diagnostics somewhere but I can't find a reference to it now.
Enter this in Web-If >> Diadnostics :- ir3debug_on = Enable remote control input to be logged in the humaxtv.log detailed HERE
Note :- It also requires a reboot, there was also a ir3debug_off command but it doesn't seen to work, if you need to turn it off you can telnet :-
Code:
rm /var/lib/humaxtv/mod/ir3debug
reboot
 
#12
Thanks, I'm getting some entries into humaxtv.log now. Now we wait for the remote to hang up ? I've set the Humax remote TV settings back the Panasonic code 359, pressed every button on the Humax remote with it in TV mode, and nothing appeared in the humaxtv.log, whereas I do see entries with it in PVR mode.

Interestingly, using the other remote with the Sagem code 182 in, I do see entries in the humaxtv.log when pressing buttons on that remote with it in TV mode.
 

Ezra Pound

Well-Known Member
#13
That's interesting, I wouldn't have expected the Humaxtv.log to show anything for Remote codes from other devices, maybe the Sagem code 182 is equivalent to one of the other 'Humax Modes' e.g. modes 2 to 6
EDIT
I have just realised that you will get an entry in the Humaxtv.log for the 4 'White' keys e.g.

Code:
Real IR code: 00000000 0x7f801000 = PVR
Real IR code: 00000000 0x7e811000 = TV
Real IR code: 00000000 0x7d821000 = DVD
Real IR code: 00000000 0x7c831000 = AUDIO
 

af123

Administrator
Staff member
#14
Enter this in Web-If >> Diadnostics :- ir3debug_on = Enable remote control input to be logged in the humaxtv.log detailed HERE
Note :- It also requires a reboot, there was also a ir3debug_off command but it doesn't seen to work, if you need to turn it off you can telnet :-
It's ir3/debugon and ir3/debugoff - I think ir3_debugon is still hanging around too.
 
#16
That's interesting, I wouldn't have expected the Humaxtv.log to show anything for Remote codes from other devices, maybe the Sagem code 182 is equivalent to one of the other 'Humax Modes' e.g. modes 2 to 6
EDIT
I have just realised that you will get an entry in the Humaxtv.log for the 4 'White' keys e.g.

Code:
Real IR code: 00000000 0x7f801000 = PVR
Real IR code: 00000000 0x7e811000 = TV
Real IR code: 00000000 0x7d821000 = DVD
Real IR code: 00000000 0x7c831000 = AUDIO
Remote stopped working tonight, so I went and ran a tail -f on the humaxtv.log
Nothing in the log as buttons are pressed.
I can still use the web interface and the command line, does this indicate a poor connection of the IR receiver on a circuit board somewhere, perhaps ? Or could be some intermittent software issue. This wouldn't explain any perceived correlation between the codes entered in the remote handset though, or why it only started 2 days after making the first full HDMI connection to a TV.
 

Ezra Pound

Well-Known Member
#17
It does look like a faulty infra-red receiver, unless, of course the sensor is being blocked or swamped by unwanted IR sources. It's location is HERE, I think it's very unlikely to be problem with the HDMI connection
 
#19
Same problem here for the last 2 days but it only occurs when recording and then not always, putting the Hummy on standby for a minute seems to cure it for a little while. Leads are fine, batteries replaced.
 
#20
Same problem here for the last 2 days but it only occurs when recording and then not always, putting the Hummy on standby for a minute seems to cure it for a little while. Leads are fine, batteries replaced.
I gave the area around the IR receiver a good clean, and it behaved itself for a couple of days, but went back to its old ways afterwards.

I've tried, on the TV, switching the 'Viera Link' option to 'Off', let's see how that goes.

Switching the HDR off and on again will often fix the issue, but you can't truly switch it off whilst recording and so switching to standby with the front button has, IIRC, never provided a temporary fix if there is a recording in progress though usually does if not recording, switching off with the main switch on the back has always provided some temporary respite.