Retune BBC A

Trev

The Dumb One
I have found that my T2 BBCA is tuned to Bexhill (local) transmitter on CH46. It should be on the stronger Hastings CH25. OK, I know how to manually tune it to CH 25, but how do I get rid of CH46 and its associated LCNs first to avoid getting LCNs in the 800s?
 

prpr

Well-Known Member
If you were in the CF section of the forum, and if you were up to a bit of Telnetting, then you could do it as follows:
Code:
humax# /etc/init.d/S90settop shut
humax# sqlite3 /var/lib/humaxtv/channel.db "delete from tbl_svc where uslcn in (select uslcn from tbl_svc as s join tbl_ts as t on s.ustsid=t.ustsid where ((t.ulfrequency+200)/1000-306)/8=46);"
humax# sync
humax# reboot
Not quite sure if that's optimal, but it works, although it would be better wrapped up into a script or similar (or tunefix).
 
Last edited:
OP
Trev

Trev

The Dumb One
Thanks for that. The only reason that I didn't post in the CF section was that it seemed to me to be a bog standard question with a bog standard answer (that I couldn't find). :roflmao: It appears that it,s not so though.:(
I suppose I could do an auto tune and pull the aerial after LCN30 if it fails to tune LCN25, then tune 25 manually after (and probably the T2 LCN on ch22. ) That was a sort of question.:)
 

prpr

Well-Known Member
Not quite sure if that's optimal...
Duh. How to make something simple into something complicated. Here's a better one:
Code:
humax# sqlite3 /var/lib/humaxtv/channel.db "delete from tbl_ts where ((ulfrequency+200)/1000-306)/8=46;"
 
OP
Trev

Trev

The Dumb One
Still sounds un simple to me;)
Upgrading computer to W10 at the mo, so will try later.
Can I do that through af's fancy new WI?
 
OP
Trev

Trev

The Dumb One
How does that fix it? I can't see a method of tuning different channels in tunefix, only LCNs?
 

prpr

Well-Known Member
Tunefix 1.0.8 will give you another option, but you have to configure it manually (at least for now).
Add a line containing:
MUX:46
to /mod/boot/tunefix.conf
and reboot. All services will disappear from the mux. which is on RF channel 46.
You can use multiple lines, or ranges (xx-yy) or a comma delimited list (or any combinations thereof) to get rid of anything you don't want.
 
OP
Trev

Trev

The Dumb One
Tunefix 1.0.8 will give you another option, but you have to configure it manually (at least for now).
Add a line containing:
MUX:46
to /mod/boot/tunefix.conf
and reboot. All services will disappear from the mux. which is on RF channel 46.
You can use multiple lines, or ranges (xx-yy) or a comma delimited list (or any combinations thereof) to get rid of anything you don't want.
Where to? I can't seem to find anything in tunefix settings to enter such a line
I admit I haven't used it, but I think you do an auto-tune and then tunefix sorts it out.
I can't find anywhere to set the channel, only LCNs
 
Last edited:

prpr

Well-Known Member
Like I said, you have to add it manually to the config. file. There is no GUI for it. Use the WebIf file editor if you like.tunefix_mux.png
 

af123

Administrator
Staff member
Like I said, you have to add it manually to the config. file. There is no GUI for it. Use the WebIf file editor if you like.
prpr If you want you could add that file to the quick-edit list on the editor page by creating /mod/webif/plugin/tunefix/quickedit.hook and putting this in it:

Code:
quickedit /mod/boot/tunefix.conf
 
OP
Trev

Trev

The Dumb One
Like I said, you have to add it manually to the config. file. There is no GUI for it. Use the WebIf file editor if you like.
Thanks, but you didn't mention the config file in your first post

Will this force it to tune to ch46, as it's ch 25 that I want it to tune to.
I'm starting to think that a complete manual retune would be the easiest way for a simpleton such as me.
 

prpr

Well-Known Member
Thanks, but you didn't mention the config file in your first post
I'm sorry, but I did:
Add a line containing:
MUX:46
to /mod/boot/tunefix.conf

Will this force it to tune to ch46, as it's ch 25 that I want it to tune to.
I'm starting to think that a complete manual retune would be the easiest way for a simpleton such as me.
Just do an auto-retune, reboot, then a manual tune for channel 25 (having added the MUX:46 line and upgraded tunefix of course).
 
OP
Trev

Trev

The Dumb One
No, you just told me to add a line without telling me where to add it to. And to a simpleton like me, that's a bit confusing.;)
It was only the addition of the "Tuned multiplex information" screen led led me to believe that it was tuned to ch46 instead of 25 in the first place. I had no other reason to suspect any anomalies.:)
 

prpr

Well-Known Member
No, you just told me to add a line without telling me where to add it to.
The evidence says otherwise. Just because you couldn't see something doesn't mean it wasn't there.
And to a simpleton like me, that's a bit confusing.;)
What can I say?!
It was only the addition of the "Tuned multiplex information" screen...
That's been there for eons. It was called "Channel information" or similar before.

(Why has FF underlined "eons" as a spelling error?)
 
OP
Trev

Trev

The Dumb One
Well, did an autotune and it tuned the right MPXs, but also picked up some more channels from ch 46. but all looks ok in the diagnostics now.:) Why I hadn't noticed BBCA was dodgy was because I only tune to BBC1 HD. I tried swapping to BBC1 and got the 'dodgy signal' message.
I suppose that tunefix got rid of the duplicates in the 800 range.
I upgraded tunefix to 1.0.8 and got the dreaded server error, and had to reboot to get the WI back again.:(
 
Top