[RS] Time range settings not working as expected

renzz

Member
There seems to be an issue when setting a time range on a Standard RS rule, resulting in it not finding everything you would expect. I first noticed it when I had a rule to search for the text '1984' on June 3rd between 00:10 and 03:00. There are two top-of-the pops related programs on BBC4 HD at that time, and RS was only scheduling one of them.

Doing a bit of testing using Eastenders as an example, I get the following. Setting up a rule for June 2nd with a time range of 20:00 to 20:30 (ie the exact time it's on):

Capture1.JPG

When I do a Show Matching Events, it finds nothing:

Capture2.JPG

Changing the end time to 20:40

Capture3.JPG

Gives the same, "No results found". However, change the end time to 21:00

Capture4.JPG

and it finds it

Capture5.JPG

I notice in Advanced Rules there is no ability to set start and end times as you can in Simple Rules - it seems you can only set the hour in which the event starts - maybe that has something to do with it?
 
OP
renzz

renzz

Member
Thanks af, that seems to have fixed the example I gave for Eastenders, but it's still not working for the Top of the Pops '1984' search which I originally had the problem with.

I have an auto search:

Capture1.JPG

When you run it, it finds just one programme:

Capture2.JPG

However, in that time range there are two programmes containing '1984':

Capture3.JPG

So it's still not finding the first one.
 
OP
renzz

renzz

Member
That's got it - thanks!

Is it intentional that you can't specify time ranges in Advanced Rules, only the hour in which something starts?
 
Top