Start Up Fails When HDD Connected

Black Hole

May contain traces of nut
Taking up the baton from here:
Thanks for the suggestions, but I don't have a 'scope or any idea how to get the test subject onto Black Hole's bench.
I have purchased a docking statation with an eSata output and a eSATA to SATA cable for connecting my HDD, whilst powering it externally.
But the humax doesn't always detect the HDD. Some fiddling about with connections and restarting sometimes works, but often I get webif messages "The system is initialising" followed by "No internal disk found". There is an "Access Telnet Menu" option.
Any suggestions on how to help humax find the HDD? Perhaps a System Command line instruction?

Some initial findings:

The supply to the HDD is unswitched on the 12V rail but switched on 5V, and the 5V supply turns on when the HDR-FOX comes out of the initial boot phase (indicated by the VFD "Cust FW #.##" turning off).

The HDD 5V comes from a TO252 surface mount component marked on the PCB as "U52":

F4F97626-10FD-43C5-8089-6D2CFADAB836.jpeg

This is a 1A variable voltage low drop-out regulator with on/off control: https://fscdn.rohm.com/en/products/databook/datasheet/ic/power/linear_regulator/baxxbc0-e.pdf

It appears to work with the HDD disconnected: 5V is present on the HDD power connector at the right time and the HDR-FOX starts up correctly.

However, with a HDD connected (even a Seagate Pipeline 500GB) I can see no disturbance on the inputs to U52 (the input voltage is about 5.9V, and present all the time the unit is switched on), but the 5V rail to the HDD only reaches less than 2V. The HDR-FOX enters a continuous cycle of reboots, restarting each time the 5V should be turned on. It does this even with the SATA cable disconnected. That there is still 5.9V on the input to U52 rules out the PSU as the cause of the problem.

What I believe is happening is the HDD 5V also supplies something else on the main board, and it is that causing the reboot when the rail is out-of spec. It crosses my mind that an input-output differential of 0.9V is quite low (even for an LDO reg), but the datasheet indicates these are able to handle it down to 0.3V typical, 0.5V max (remarkable), so that isn't the problem.

U52 has over-current and thermal protective shut-down, and I suspect it is faulty and shutting down the output prematurely. My next move is to obtain a replacement part and see what happens (ordered, but estimated delivery up to 3 months!).

Something to note is that a HDD with 5V current requirement greater than 1A would not be supported.
 
Last edited:
OP
Black Hole

Black Hole

May contain traces of nut
Not needed to 'scope it so far - the low voltage is a smoking gun. When the inputs to a device look fine but the outputs don't, it's a pretty clear signal.
 

everthewatcher

Forum Supporter
Not needed to 'scope it so far...
Thought so.

As with most of these devices an output capacitance is needed for stability and from the datasheet it's picky about value and ESR. A DVM won't tell you if it's oscillating and 2V is pretty close to half 5V.
 
OP
Black Hole

Black Hole

May contain traces of nut
Good point, I can look. I must say I prefer the idea that a cap has gone out of spec than a semi going west, and I admit I didn't read the datasheet well enough to spot the criticality. Ugh! Maybe that's a consequence of the very low ΔV capability.
 
Last edited:
OP
Black Hole

Black Hole

May contain traces of nut
Can anyone think of a reason they've used BA00BC0W instead of BA50BC0W (pre-programmed 5V instead of requiring an external potential divider for feedback)? The only idea I have is that these are used elsewhere in the circuit at other voltages so it reduces the inventory.
 

/df

Well-Known Member
...
Something to note is that a HDD with 5V current requirement greater than 1A would not be supported.
But a 3.5" USB disk with a separate power supply is fine, as is a 2.5" USB disk attached via a powered hub. In my configuration with the latter case, the hub needs power to run both the disk and the WiFi dongle.

Pending the component delivery, what happens if you break the 5V o/p line and insert an external 5V/1A supply that you turn on (measuring the current drawn) as the built-in regulator's 5V is enabled?
 
OP
Black Hole

Black Hole

May contain traces of nut
But a 3.5" USB disk with a separate power supply is fine, as is a 2.5" USB disk attached via a powered hub. In my configuration with the latter case, the hub needs power to run both the disk and the WiFi dongle.
I fail to see what that has to do with this thread.

what happens if you break the 5V o/p line and insert an external 5V/1A supply that you turn on (measuring the current drawn) as the built-in regulator's 5V is enabled?
What point would that exercise have?
 

/df

Well-Known Member
...
As with most of these devices an output capacitance is needed for stability and from the datasheet it's picky about value and ESR. A DVM won't tell you if it's oscillating and 2V is pretty close to half 5V.
That seems to be the required 22+μF Ta cap on the voltage setting pin Vo. It's also strangely reticent about the specification of the cap for the VCC pin.
 

/df

Well-Known Member
...
What point would that exercise have?
It would distinguish if the problem is the 5V regulator o/p, vs some issue in the supplied circuit itself (excessive current draw, eg), wouldn't it, without the risk of introducing a replacement part and possibly having it fail in the same way? I assume that the BH bench is over-stocked with 5V/1A supply cannon fodder.
 

xyz321

Well-Known Member
Can anyone think of a reason they've used BA00BC0W instead of BA50BC0W (pre-programmed 5V instead of requiring an external potential divider for feedback)? The only idea I have is that these are used elsewhere in the circuit at other voltages so it reduces the inventory.
Possibly because the variable voltage version is available in a surface mount package which is more suitable for mass assembly (but more difficult to remove - you may have to preheat the board in an oven).
 
OP
Black Hole

Black Hole

May contain traces of nut
It's also strangely reticent about the specification of the cap for the VCC pin.
Never so critical in my experience. Just make sure the supply doesn't droop and has enough HF rejection.
vs some issue in the supplied circuit itself (excessive current draw, eg)
Previously ruled out by trying another (known working) HDD.

Possibly because the variable voltage version is available in a surface mount package
TO252-5 available for all voltages, with or without enable input (according to the datasheet).
 

xyz321

Well-Known Member
In the datasheet this parameter is the "Minimum I/O difference". The regulator will dropout (no longer regulate the output) if the difference between the input voltage and output voltage is allowed to go below below this level. In previous generation linear regulators (non-LDO) this parameter would typically be 3V (e.g. for an LM317).
This differential voltage would translate into power dissipated by the device, so LDO devices would usually require smaller heatsinks for a given output current.
 

/df

Well-Known Member
While attaching the problem HDD triggers the issue, it's surely possible that there's some other stuff going on in the rest of the supplied circuit that acts together with the disk attachment to pull the 5V o/p down or make it oscillate? Or has the problem HDD (which presumably works elsewhere?) been measured to (eg) draw a lot more current than a known good one?
 
OP
Black Hole

Black Hole

May contain traces of nut
Ah, I wondered what LDO stood for, seeing as it's not defined anywhere on the datasheet.
But what does it actually mean in this context?
This is a 1A variable voltage low drop-out regulator with on/off control...

...It crosses my mind that an input-output differential of 0.9V is quite low (even for an LDO reg), but the datasheet indicates these are able to handle it down to 0.3V typical, 0.5V max (remarkable), so that isn't the problem.
One expects a regulator categorised as LDO to b specified to work down to an input to output voltage differential (ΔV) of no more than 1V. If the input voltage is not great enough, the output voltage is no longer regulated (and tends to track the input voltage minus a voltage loss). Design of an LDO is quite tricky because there's not much voltage margin for the series pass element when it might need to drive 1A.

I don't know why it was designed this way, or where the 5.9V input comes from. I have not found anywhere else being driven from the HDD 5V rail (definitely not the USB), but it must drive something or be sensed by something otherwise the unit would not reset when out-of-spec.

Early results have not found any oscillation, it just turns on and turns off again (leaving the rail to decay exponentially).

Or has the problem HDD (which presumably works elsewhere?) been measured to (eg) draw a lot more current than a known good one?
I don't have a dual-rail bench PSU, so it would require effort to knock up some kind of test adapter (but it might be worth it, sacrificing a Humax HDD loom in the process).
 
Last edited:
OP
Black Hole

Black Hole

May contain traces of nut
Start-up transient (vertical 0.625V/div, horizontal 0.4s/div):
E72E4E8C-49BF-44C1-B260-236FA44F1942.jpeg
Peak voltage is about 2.5V.

Close-up (vertical 0.625V/div, horizontal 20ms/div):
F09B1B5D-7F78-4C71-A4D1-C751AE36F7E8.jpeg

The double edge is curious, I don't know how to attribute it. There is no apparent oscillation even at much shorter timebases.

Same HDD, working HDR (vertical 1.25V/div, horizontal 20ms/div):
46C2409D-A73C-42A3-8506-CA0B49CFE9B8.jpeg

No HDD, non-working HDR, results identical to a working HDR with HDD (vertical 1.25V/div, horizontal 20ms/div):
5F1C8C63-E2DA-44AA-997A-8080B2C9FB8C.jpeg


Same results using four different HDDs (three Pipelines and one SkyHawk). It doesn't really matter whether one HDD is a little heavier on current than others, there would have to be enough margin.
 
Last edited:

bottletop

Active Member
I wonder if you'll get meaningful results with a 2.5 (laptop) drive? I thought I had read previously some people use a 2.5 drive when the motherboard can't support a 3.5 drive.
 
Top