• The forum software that supports hummy.tv has been upgraded to XenForo 2.0!

    This is a major upgrade which changes the look and feel of the forum somewhat but brings a host of improvements too. Please bear with us as we continue to tweak things and report any issues or suggestions in Site/Forum Issues.

System stuff deleting*

#1
My Humax has got stuck in the deleting* section.:frantic:
I can use the system to watch TV but not pause live TV.
I can't delete any thing.
I can't record anything even though the light says it is recording. Manual recording says it has recorded less than 30sec so won't save it.
The Humax Menu is blanked out in parts as it thinks it is doing stuff even though it is not. (So I can't even reformat)
Tried Rebooting and Power off.
I can Telnet into system OK but can not delete any files or create any new ones.
System says it is a 'read only system file'.
Ran /etc/fstab and it is listing hda2 as 'ro' however fstab file seems to show that it should be mounting as 'rw'
So thought I would use the Humax 'copy' to backup the stuff I had recorded before but that does not seem to work.
I can use 'Filzilla' to copy the files but then these are still encrypted :mad:

Does anyone know what I can do about this?
An help greatly appreciated.
I am at work at the moment but will try anything this evening.
 

af123

Administrator
Staff member
#2
I can Telnet into system OK but can not delete any files or create any new ones.
System says it is a 'read only system file'.
Ran /etc/fstab and it is listing hda2 as 'ro' however fstab file seems to show that it should be mounting as 'rw'
If there is an error detected on the hard disk, then the Linux kernel can automatically remount it read-only, and it sounds like this is what's happened. The Humax software does not expect this, as you might imagine, and doesn't handle it well.

You can telnet in so you're running the custom firmware which means you can reboot it into maintenance mode and check the disk. I'd suggest you do that as a next step.

There are some instructions on the Wiki at http://wiki.hummy.tv/wiki/Maintenance_Mode which should get you started (they may need improving as they were written by people quite close to it) and there was a small change made to maintenance mode in CF 2.10 so if you're on a lower version then you might need to run an extra command depending on how unhealthy the disk is.

Do copy the files you care about off first if you can, even though they're encrypted they'll be playable once restored to the same box.
 

4291

Well-Known Member
#3
I had a similar problem. Here's what I did to cure it.

Customised Firmware 2.00

Be sure to copy off all the recordings want to keep. Copying them back afterwards works fine, including DECrypted and MPGs.

:oops: Just noticed you have an HDR
 
OP
OP
Karl Harrison
#4
Hi - Carried out af123 instructions.
Managed to get into maintenance mode and run e2fsk on the drives and got a few errors from it that it fixed.
Now all back to normal I think.
Going to copy some more stuff off it before I reboot and hope all is still okay.

Thanks :byebye:
 
Top