Telnet User & Password?

Cancunia

Member
I have Dropbear enabled , but telnet is also enabled (i.e. not disabled) and passwords set to no, all seems fine with SSH access via keys. I was trying to use telnet on the local network, when I do I'm asked for a user-id and then a password. I can't find any references to them and thought Telnet went straight to the prompt? I also have expertmode telnet set on and the tmenu package loaded.

Any thoughts? Perhaps a conflict somewhere?

I'm using CFW 2.14 & The latest Webif from last night.
 

af123

Administrator
Staff member
The telnet server doesn't ask for a user-id and password. In non-expert mode it does ask for the system PIN but in expert mode it drops straight to the prompt. The 'passwords set to no' relates to the SSH server, the setting isn't used by the telnet server.
 

Black Hole

May contain traces of nut
The Telnet client will resolve between the SSH and the standard Telnet by port number. IIRC standard is port 23 and SSH is port 22. Check which you are trying to access.

Depending which CF version you are using, you might need to input the system PIN (0000 by default).
 
OP
C

Cancunia

Member
Hi BH, am using port 23 & Telnet from Putty. SSH is set for Port 22 on the settings page. I did try 'root' & the system pin but no luck.
 
Top