1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

trusty 9300t finally had enough?

Discussion in 'PVR-9300 Freeview Recorder' started by hu12, Sep 2, 2016.

  1. hu12

    hu12 Member

    Hi all

    Turned on the box and continuous fan with 9300t showing in led screen and machine trying to load data continuously.

    Read around problem on internet - looks like HD full/corrupted.

    (Previous eve. watched older date recording of Thurman and Tarrantino - so guess all that jumping around with loud music upset it).

    Having read around looks like I have to:

    Get films off HD
    Reset HD
    Reset Channels?

    Located HumaxRW and front end (thanks to previous posts etc) So will be able to do this. Can someone tell me which SATA USB cable required? (eg pins number etc or link to Amazon - cheapo cable).
    Also after taking back off 9300t do I have to take HD out or just plug the cable in and link to my comp?

    When I have taken off films I want how do I reset HD? I am Assuming HD loads up ok when cleared maybe just do via menus on screen (not showing at moment).

    I assume the channel selection will still be in place or will I need to reset? Saw on a previous thread how to do that.

    Thanks

    HU12
     
  2. Black Hole

    Black Hole Usain the Whippet

    I'll leave the technical details to others with relevant experience. As far as interfacing the HDD ("HD" is too easily confused with "High Definition") to a PC is concerned, first you need to be sure it's a SATA drive you are dealing with rather than PATA. Assuming it is SATA, any SATA to USB adapter should do it - but I strongly recommend you buy one that comes with a power supply brick even if it does cost a bit more. Here's an adapter that does everything, well worth having IMO:

    http://www.ebay.co.uk/itm/EXTERNAL-...NNECTION-KIT-With-UK-Mains-POWER/251493222595
     
  3. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    The drive is SATA. I suggest buying an adapter from eBay with a power supply, something like http://www.ebay.co.uk/itm/UK-Plug-U...588441?hash=item51e79404d9:g:xgUAAOSwvg9XfjFG Nb don't be tempted to have the Humax powered up with the lid off. It is far to easy to touch the power supply and destroy it (as well as giving yourself a shock).

    It sounds to me as though the problem could be to do with the cached EPG. Later versions of humaxrw have a -Z option to fix the problem by deleting the file that holds the cached EPG . I suggest trying that before copying off or formatting the drive. If you need to format the drive it is done from the HDD Control menu item in the Record menu. You shouldn't need to retune as the tuning data is held in Flash RAM not on the hard drive.
     
  4. hu12

    hu12 Member

    Thanks very much for those prompt replies and suggestions.

    Am I right in thinking I can just gently pull out the SATA (unplug it) and sit it into the adapter, power it and then use the SATA USB to do the necessary? Sorry I have never done this stuff before.

    Thanks for the tip on the EPG and Z option. I will try that first.
     
  5. Luke

    Luke Well-Known Member

    Its been a couple of years since I did this on a 9300T but the SATA USB connection was very easy. The one I used looks almost identical to Martin's link. Mine looks like this: http://www.ebay.co.uk/itm/2-5-3-5-I...-0-Cable-UK-Fused-Power-Adapter-/320895175406. Spot the difference.

    The HDD will be attached to a removal chassis and you unscrew the chassis and unlpug the 93000T data and power plug from the HDD. No need separate the HDD from the HDD's chassis. I used windows 7 and it just seem to recognise the SATA/USB adapter without any issues. Presumably you have already read up on that fact that it wont assign a windows dive letter and that you don't want it to?

    I take it that HU12 is your postcode and you are in Hull? I've got a 320GB 9300T to get rid of and it looks as though it will end up in a weee bin but Hull is a bit too far for me to drop off.
     
  6. hu12

    hu12 Member

    Cheers for that Luke. Sorry, I'm not in Hull but 'darn Sarth'.
     
  7. Luke

    Luke Well-Known Member

    What I meant was that I am no where near Hull either. I am in Essex, south of the Sudbury transmitter and if your 9300T turned out to be unfixable I have one going spare.
     
  8. hu12

    hu12 Member

    Ok thanks for the offer - that might be a deal. I will give the fix a try and if no go I will give you a shout here?
    Should take a week or so while I get the cables etc.
     
  9. hu12

    hu12 Member

    Hi Guys, I have now got the relevant cables etc.

    Martin I assume the Z option (to try before offloading films etc) is in humaxrw and not the front end.
    I also see that humaxrw is controlled using command line. Can yo give me a run through on what to enter there
    to get to the z option and make it work?
    as my experience with cmd is limited to a few plays with linux.

    Thanks
     
  10. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    I have always used the command line so can't comment on whether it is supported in the front end. It was a relatively late addition to humaxrw so may well not be supported by the front end.
    You need to extract humaxrw from the zip file and place it somewhere convenient. Then start a command prompt (if you are using Windows Vista or later then I think it will need to have administrative privileges) so for Windows 7 Start> Accessories>Command prompt then instead of left clicking on command prompt right click and select "run as administrator". For Windows 10 right click on the Window icon at the far left of the taskbar and select Command Prompt (Admin). Then with the USB adaptor plugged into the drive and power applied issue the following commands (for the purpose of the example I have assumed you have placed humaxrw in a folder called humax directly below the root of the C: drive)

    C:
    cd \humax

    humaxrw 1: -l (This is dash numeric one colon space dash lower case L)

    if this works and gives you a listing of programs then you are in business. If not try increasing the 1: parameter until you get a listing up to say 12

    Once you have a listing then type

    humaxrw 1: -Z (replace one with whatever number gave a listing and note that it is dash upper case Z).

    That is it. Reconnect the drive to the Humax and see if it will now boot.
     
  11. hu12

    hu12 Member

    Cheers Martin. I will try it now and report back later.
     
  12. hu12

    hu12 Member

    Getting Permission denied - tried both xp and W7. Trouble is for invisible drives (as humax is to windows) you need to right click on the drive to change permission. Any ideas? - up to that point very good.
     
  13. Luke

    Luke Well-Known Member

    One possibility is that when Martin said
    "Windows 7 Start> Accessories>Command prompt then instead of left clicking on command prompt right click and select "run as administrator""
    that you did not select "run as administrator".

    That would have produced what you are describing.
     
  14. MartinLiddle

    MartinLiddle Super Moderator Staff Member

    You do not need to right click on the drive. Are you sure your command prompt has administrative privileges.
     
  15. hu12

    hu12 Member

    Thanks Luke. I just tried a few times to run as administrator exactly sa instructed, but no go. That is irritating. Typical Windows. If I cannot get permissions I cannot enter the files to readjust.
     
  16. hu12

    hu12 Member

    I will just check that Martin. Thanks
     
  17. hu12

    hu12 Member

    So, I obtained administrator privileges (apparently there is a hidden admin built in
    on W7 onwards so the User Account is just a ????). I have now activated the administrator account and went through the cmd line to try and get the list of programs on Humax HDD via humaxrw. Looks like partition2 and it is
    still coming up 'permission denied'? Very strange.
     
  18. hu12

    hu12 Member

    Just to let you know if its any use, I have a live linux OS (Mint) operating on a seperate machine if we can use that?
     
  19. Luke

    Luke Well-Known Member

    To quote one of Martin's many posts:
    "Under Vista and windows 7 you need not only to be logged on as administrator but to run as administrator."
    https://hummy.tv/forum/threads/help-with-humaxrw-humaxcheck-please.1597/#post-21077
    Did you still 'run as administrator'?
     
  20. hu12

    hu12 Member

    I will double check that Luke and come back . I just noticed that in many of my programs eg cmd, 'privilege level - run as administrator' is greyed out - I am trying to find out why?