Twonky Server v7 crashing HDR-FOX T2


There have been numerous reports here, and on the Twonky community forums, that version 7 of Twonky Server will cause an HDR-FOX T2 on the same network to crash, if the HDR-FOX T2 is set to share its content via DLNA. I believe I have found a solution to this problem, at least for Mac users and possibly also for Windows users.

Reading the Twonky forums suggests that the problem is due to the "nmcmode" setting on Twonky Server. By default in version 7 that is set to 4, and this setting appears to upset HDR-FOX T2s attempting to share content on the same network. It's not easy to work out how to change this setting, but here's how to do it on a Mac:

  1. Go to ~/Library/Application Support/twonkymedia. (To get to ~/Library/, hold the alt key down and click on the "Go" quick navigation item in the Finder menu: Library will appear in the list of locations you can navigate to. You can also click "Go" and then press the alt key to make Library appear in the list.)
  2. You should find a file called twonkymedia-server.ini.
  3. Open that file with TextEdit and find the line which reads "nmcmode=4". Change the "4" to a "0" (zero), save and exit.
  4. If you now start (or re-start) Twonky Server, you should find that your HDR-FOX T2 no longer crashes.

I believe Windows users should be able to do something similar, if they can track down the twonkymedia-server.ini file.

I made this change earlier this afternoon to my installation of Twonky 7.2.3 and my HDR-FOX T2 has been fine since.
Good news, it would be useful to find the config file for the Linux version, as I'm guessing quite a few NAS boxs will be running Twonky on some flavour of Linux. There is a twonkyserver-default.ini in the Linux version but no nmcmode line
Come to think, I am currently running the 1.03.06 firmware so it's just possible that this version doesn't suffer from the Twonky v7 bug anyway. If I get a chance I'll try downgrading to 1.02.32 and see whether or not that crashes with the fix in place for Twonky v7.

UPDATE: Since writing that, the Humax has crashed twice :-( Maybe Twonky hasn't been tamed after all. I've turned the Twonky server off for now. If the Humax crashes again then that would point to the 1.03.06 firmware. If it remains stable for several days then the finger of suspicion will definitely be pointing Twonky-wards.
Just to add to the reports - my HDR FOX T2 started crashing this week. Thanks to this and other reports, I eventually suspected the DLNA server on a Win8.1 laptop, and disabling this solved the problem. There was no problem before Monday 05jan2015, so I suspect an automatic Windows update has caused the trouble and hence it's likely that others will see this too.
P.S. we weren't using the DLNA server on the laptop and hadn't chosen it; it was just on by default but I had noticed it on VLC while browsing UPnP to play Hummy recordings.
P.P.S. running firmware HDR_FOX_T2_1.03.12_mod_3.00

I have started to have an issue where the Humax HDR running the custom software freezes up sometimes with just the time showing on the front of the screen, the TV screen shows like a green pattern on the screen, a detailed green smudge veil type of pattern. If recording it continues to record. Powering off fixes it. Done it a few times now.

I have installed an Asus RT-AC3200 router recently with it's built in DNLA server which I've activated and have a splattering of Bubble UPnP server software on Android devices. I was thinking whether I had a Twonky type situation. I have installed the DNLA-Filter package. Do you think I'm barking up the wrong tree and something else is happening ?. Least it might help.
Good question. I haven't tried since I sought of thought it's the Twonky thing and read up about it from how I remembered it. The plan would be to see whether this stops it, I did that tonight, just installed the DNLA -filter module, powered off and on to be safe, then if it continues pull out the network cable. I have it connected to my favourite IP address ending in 101. The rest of the network is well behaved so I don't think it's that and I have it set on MAC / DLNA issues IP address. So I'm sort of thinking it's a DNLA thing. I never had a Twonky so I don't know how the problem manifests itself.
Work through my checklist - you will at least find out whether it is an internal problem or an external one.
I expect it's 2B since that's the only thing that I've changed. I tend to point my finger at Asus MiniDLNA - but I do note it's a Twonky thread. The culprit could be Bubble for DLNA / Chromecast that I have on three devices. Think I will put my money on the Asus MiniDLNA software on balance.

Will see whether the DLNA Filter stops it, if not then carry on down your list from 2B. e.g. pull out the Ethernet cable. It's done it about three times in 10 days - but as said the screen effect is a new one on me (green veil smudgy effect when on channel 200). So will take a few days to check it. Thanks.
Last edited: