Unable to Re-install webif.

4ndy

Forum Supporter
When I went to one of my boxes via webif today, I got the " Custom Firmware Successfully Installed" screen with the option to "Download and Install Full Web Interface". Had this in the past, but this time can't get out of the loop.

The install option gives the error in the screenshot. Installing webif via the telnet option gives the same errors. I have tried several reboots and re-installed the CF from USB. Also tried opkg-update as suggested in the Telnet error message.

What should I try next? Ideas please.

 

Attachments

MymsMan

Ad detector
you previously had the beta webif installed but the new install doesn't know about the beta package catalogue.

Can you telnet into the machine?

Try opkg install opkg-beta and then opkg install webif

If that doesn't work you may need to down load webif and ir from the catalogue https://hpkg.tv/packages.html (wgets below)
and then
Code:
cd /mod/tmp
wget -U '' http://hpkg.tv/hdrfoxt2/base/webif_1.4.8-8_mipsel.opk
opkg --force-downgrade --force-depends install webif_1.4.8-8_mipsel.opk
wget -U '' http://hpkg.tv/hdrfoxt2/base/ir_1.17_mipsel.opk
opkg --force-downgrade --force-depends install ir_1.17_mipsel.opk
 
Last edited:

Black Hole

May contain traces of nut
(edit: post in preparation before the above)

I guess you were using the beta WebIF, and maybe removed opkg-beta in an attempt to overcome the problem with fix-flash-packages wiping out the beta ir package? Been there, done that.

The problem with ir is that the most recent beta version has been deleted, so (assuming you are using the beta version) fix-flash-packages can't find the version it needs to reinstall having removed it. Maybe it should check before removing!

However, if you remove yourself from the beta programme (by uninstalling opkg-beta), and had the beta WebIF, fix-flash-packages definitely can't find the right version to install (because it can't see it without opkg-beta).

I don't know if there is a less destructive solution (apparently there is - see above), but I ended up setting RMA in the Telnet menu (reboot), then unsettling RMA (reboot), and reinstalling everything from scratch (except you don't need to reflash).
 

MymsMan

Ad detector
My instructions are theoretical and havem't been tested in anger but should allow you to downgrade to the non-beta versions
 
OP
4ndy

4ndy

Forum Supporter
Thanks Mymsman and blackhole

Yes, I did uninstall beta-opkg because of the previous issue with ir (well deduced). I have given up on ir because of the ongoing problems.

I will try a manual install of webif when fixdisk has completed ( in case drive gone read only).

Is af123 the only person with access to the repository? Perhaps a copy of the last non-beta version of ir could be saved as v1.20 in the beta repository?


Sent from my iPad using Tapatalk
 

MymsMan

Ad detector
Is af123 the only person with access to the repository?
AFAIK yes.

I believe we have a couple of forum administrators but #af123 seems to be the sole controller of the repository, GIT library and Remote Scheduling server
We really do need some backup capability since he hasn't been active for a couple of months now.
 
OP
4ndy

4ndy

Forum Supporter
you previously had the beta webif installed but the new install doesn't know about the beta package catalogue.

Can you telnet into the machine?

Try opkg install opkg-beta and then opkg install webif

If that doesn't work you may need to down load webif and ir from the catalogue https://hpkg.tv/packages.html
and then
Code:
wget -U '' http://hpkg.tv/hdrfoxt2/base/webif_1.4.8-8_mipsel.opk
opkg --force-downgrade --force-depends install webif_1.4.8-8_mipsel.opk
wget -U '' http://hpkg.tv/hdrfoxt2/base/ir_1.17_mipsel.opk
opkg --force-downgrade --force-depends install ir_1.17_mipsel.opk
The fixdisk finished with no errors flagged up, but read-only is mentioned below.

I then downloaded webif from catalogue and then tried to copy to the Humax (as I did with my previous issue with ir), but I am not able to get Filezilla to connect. I have tried turning on the native FTP server, but that makes no difference. I can change one digit in the IP address and connect to the correct place on another box, so have ruled out human error.

I then tried the first of the commands you suggested, as it appeared to pull the packages from the repository, and get this error:

Code:
Humax HDR-Fox T2 (HDR2) 1.03.12/3.13                                                                                                                                 
                                                                                                                                                                      
To return to the menu, type: exit                                                                                                                                     
                                                                                                                                                                      
HDR2# wget -U '' http://hpkg.tv/hdrfoxt2/base/webif_1.4.8-8_mipsel.opk                                                                                               
--2020-09-13 22:17:02--  http://hpkg.tv/hdrfoxt2/base/webif_1.4.8-8_mipsel.opk                                                                                       
Resolving hpkg.tv... 2a00:5600:1600::50, 89.248.55.75                                                                                                                 
Connecting to hpkg.tv|2a00:5600:1600::50|:80... failed: Address family not supported by protocol.                                                                     
Connecting to hpkg.tv|89.248.55.75|:80... connected.                                                                                                                 
HTTP request sent, awaiting response... 200 OK                                                                                                                       
Length: 2921742 (2.8M) [application/octet-stream]                                                                                                                     
webif_1.4.8-8_mipsel.opk: Read-only file system                                                                                                                       
                                                                                                                                                                      
Cannot write to 'webif_1.4.8-8_mipsel.opk' (Read-only file system).                                                                                                   
HDR2#
I will hold off on the RMA option until I am certain the disk is not read-only, or in case further advice is forthcoming.
 

MymsMan

Ad detector
If you are in the root directory that will be read only

you would need to switch to a directory that is on the hard disk, /mod is where most of the CF lives
Code:
cd /mod/tmp
I have a default directory set up in my profile so forget it is isn't standard

I added the wget's to do the downloads directly to the humax in a later edit (I needed to look it up) but didn't change the words to clarify that
 
OP
4ndy

4ndy

Forum Supporter
Thanks again Mymsman. That fixed it.
 
Last edited:

Black Hole

May contain traces of nut
I will hold off on the RMA option until I am certain the disk is not read-only
I'm not sure why you are worried about the disk being read-only. If you can still do normal Humax stuff (record, timeshift etc) it isn't read only.

I am not able to get Filezilla to connect. I have tried turning on the native FTP server, but that makes no difference.
That's some other problem. As long as you can get to the Telnet prompt, that's what you need.
 
Top