Webif EPG - Channel Group for EPG not displaying data

tikirhino

New Member
Hi all, I have searched the forum and cannot find a fix for this issue. I am running CF as follows, installed three days ago so EPG package should be up to date:

Web interface version: 1.0.16-3
Custom firmware version: 3.00 (build 2137)
Humax Version: 1.03.12 (kernel HDR_CFW_3.00)

I have Favourites 1 list populated and all is OK on the Humax directly when using this.

In webif, if I select Favourite 1 in the EPG settings, it displays the channels in my list. If I rename it to be 'Faves' it goes to the end of the list in the EPG options drop-down list.

If I then select it in the list and go to the EPG, it is blank. If I go back to the list and select 'Favouirites 2', this will now show the contents of the 'Faves' list in the webif EPG

If I now rename Faves back to Favourite1 it shows as empty until I hard reboot the PVR. All I wantto have is a renamed favourite list that is visible in webif as well as on the PVR itself.

Weird. Anyone seen this behaviour?
 

Luke

Well-Knwοn Мember
Sort of. Difficulty mapping the correct favourite group in the web-if has been reported. In the web-if I'd been selecting each one in turn until the one I wanted showed up. I also seem to recall that I could only get 3 of the 5 to show up in the web-if. There is another thread on it from earlier this year which right now I can't find, but no conclusions were reached and the topic was left hanging.

Edit: This is a link to the thread that I was thinking of:
http://hummy.tv/forum/threads/reset-favourites-lists.4642/
 
Last edited:
OP
T

tikirhino

New Member
Sort of. Difficulty mapping the correct favourite group in the web-if has been reported. In the web-if I'd been selecting each one in turn until the one I wanted showed up. I also seem to recall that I could only get 3 of the 5 to show up in the web-if. There is another thread on it from earlier this year which right now I can't find, but no conclusions were reached and the topic was left hanging.

Edit: This is a link to the thread that I was thinking of:
http://hummy.tv/forum/threads/reset-favourites-lists.4642/

Luke, I saw that post a while ago too. I guess I will just have to put up with it and hope someone finds a fix/workaround. Thanks.
 

peterworks

Ye Olde Bowler
I too have this difficulty. After installing web-if I thought that creating a new favourites with all the channels I watch in it would make the epg more usable for me.
Unfortunately it does as other posters have reported.
Would reinstalling web-if get around this ? or is there a database that can be rebuilt ?
I am finding web-if with rs great and have now set it up just as I want it. A reinstall would be inconvenient but, if that is the only way to go then so be it...
 

peterworks

Ye Olde Bowler
The contents of my rsvsync.log show the following:
>>> Contents of /var/log/rsvsync.log 209 bytes
Opening /var/lib/humaxtv/rsvp.db
Attaching /var/lib/humaxtv/rsv.db
Retrieving pending records.
Attaching /var/lib/humaxtv/channel.db
Restoring any favourites.
Ignoring: no such table: fav (no such table: fav)

Could the fact that the last 2 lines refer to a favourites table but it is not there be relevant ?
Should there be (or have been) a table ?
 

Lefteris

Member
Hi - I have a similar problem with my HDR-FOX T2 1TB machine which I've just got to replace one which was destroyed in a house fire ! I've installed the latest CF software and the system is 1-03-12. With accessing the Humax through a browser direct, the EPG shows fine, though I note now it always defaults to Now/Next view - I can't get it to show Grid by default. Anyway, using the RS interface, I cannot get the EPG to show any detail - it's telling me EPG Region is unknown - how can I change that ? and there are no Favourites options in the EPG Fav Group selection box - only 'None' - can someone help me resolve these issues please ?
upload_2014-10-29_16-1-42.png

Sorry just noticed my tag is out of date - that was my last humax - I'll change it
 

peterworks

Ye Olde Bowler
Sorry to bump this but I am still unable to see the changes I have made to Favourites on the Humax being reflected in RS or WebIf.
If it assists the rsvsync log shows
3186 Wed Nov 23 09:29:28 2016: Final schedule entries: 19
3185 Wed Nov 23 09:29:28 2016: Slots:
3184 Wed Nov 23 09:29:28 2016: Ignoring: no such table: fav (no such table: fav)
3183 Wed Nov 23 09:29:28 2016: Restoring any favourites.
3182 Wed Nov 23 09:29:28 2016: Opening /var/lib/humaxtv/rsvp.db
3181 Wed Nov 23 09:29:28 2016: rsvsync starting.

but the rsvp.db is empty. Could this be a reason ?
 
Top