Wifi Connection Encryption Issue


New Member
Hi All,
I've just bought myself a new HDR-2000T Freeview box, and so far love it. I have a problem connecting it to my Wifi network however. I'm using the official Wifi dongle that came with it, and it refuses to connect.

I can get it to connect perfectly when I disable security on my router, and it works great like that, however that's obviously not a permanent solution. I've tried the dongle on my PC as well and it works fine with and without encryption. I've also tried connecting to my phone as a Wifi hotspot with the same results. What all my testing tells me so far is:

- Reception or signal strength isn't an issue as speed is excellent when connected without encryption.
- The dongle is working perfectly with all types of encryption.
- The box cannot connect to the router, no matter what type of encryption I set.
- The router doesn't seem to be the problem as another network has the same issue.
- I shorteed the SSID and password in case these were an issue, no improvement.

So, has anyone come across this before, and if so how did you get around it? It works with standard ethernet, no problem, but I can't leave a cable connection like that permanently. I'd like to try and sort this out before I return the box, because I actually like everything else about the box, but if I can't get Wifi working then back to the shop it goes...

Thanks very much for your help!

There is a similar report HERE (click).

There is no need to throw the baby out with the bath water, there is more than one way to skin a cat. A cable network connection is by far the best, but if that is not a practical possibility I recommend HomePlug (power line) Ethernet adapters. If you must use WiFi and the dongle refuses to work, there are Wifi-Ethernet bridges such as TP-Link WR702n. One reason not to use a USB WiFi dongle is that it ties up a USB socket you could use for external storage.
Admittedly on a different type of Humax, I found that certain characters are not allowed in the key (password). In my case, it was spaces.

Just to ensure that's not the cause, have you tried a short pw with only regular chars in it?

Thought it worth a mention, at least. Otherwise, good luck...
II'm not sure if the WR702n would convert wifi to ethernet
What do you mean? I have several configured for various ad-hoc needs. It can be configured to connect to an existing Ethernet network (eg the room connection in a hotel) and provide a WiFi access point (I use one to provide a guest WiFi network at home rather than give out my main WiFi credentials, the guest network then vanishes when I turn it off), as a WiFi access point and Ethernet router (I use one in this way to service my outstationed HDR-FOX: plug it in to the Ethernet port with power from the USB port and I can then access the WebIF from my iPad), as an Ethernet link to an existing WiFi network, or even to link to an existing WiFi and rebroadcast another access point (although I have never managed to make it work like that).

I recommend it, although there are other and cheaper devices that will do something similar. Sometimes you can pick them up at a discounted price.

I admit I have not used one in the way needed here, but the control interface provides flexible options and I see no reason it wouldn't work. What you do is hook it up to something convenient (I use a Linux netbook) by Ethernet and use a web browser to access the WR702n's control panel, set up all the config for the WiFi and the Ethernet links, and reboot. If the config changes the Ethernet access details then the reboot will alter the address needed to access the control panel - if the control panel becomes unreachable there is a restore defaults button. The great thing is that the config is stored NV, so once set up that's it. The only wrinkle is that the default IP and netmask might not be compatible with your current network, which is why I use my netbook - it's easy to configure that to match the WR702n and get a direct point-to-point Ethernet link going.
Thanks for the replies guys! Yeah, I know there are other ways to do it, however since Wifi is a key feature that I was looking for when shopping for the box it's very annoying that I can't use it. I would have probably chosen a cheaper box which only had ethernet if I knew I'd have to be using extra devices to get it connected.

I'm not too concerned about losing a USB socket since there's a second socket on the front for temporary use and the internal hard drive is accessible over the network anyway.

As for the key and SSID, I've made both of them as short and simple as is allowed, still no joy. All letters, no spaces or other characters in either of them. Interestingly, with a couple of different encryption types the box incorrectly detects the encryption type which could be related to the issue.

I also tried searching for a software update via OTA but none were found, and can't find any sign of a download on the Humax website to do it via USB.

As it is, I have a wireless ethernet bridge which I'm using with the box at the moment, but it's taking up an extra mains socket. A powerline adaptor would be a similar issue - sockets are at a premium here - and I've had mixed results with powerline adaptors in the past. And if I'm to spend even more money on a newer wireless bridge which runs off USB power, I might as well return this box and exchange it for a cheaper one since one of the main features I bought it for doesn't work.
There are no firmware updates for HDR-2000T at present. My powerline adapters have pass-through mains sockets.

I agree the WiFi leaves something to be desired, and I don't use it as a matter of policy on my HDR-FOXes - although many do use it successfully. As noted another poster is reporting similar issues to you on HDR-2000T - are you sure it is not a signal problem? WiFi can be finicky about exact location, some people have reported better success when the dongle is on an extender cable and located clear of obstructions.
Yeah, I read about the other post, but I'm absolutely sure it's not a signal problem. With no encryption selected I get an excellent connection capable of streaming full HD with no buffering or glitching, and the network shows up as full strength in the network list.
Oh yes, you said that before, fair enough (though I'm not sure how you are managing to stream HiDef on a HDR-2000T).
Well, all I've been doing is running the iPlayer in HD mode, but it's been flawless at that, and FTP transfers using the dongle have also been very fast, approximately 10MBit/s, which reflects the connection quality.
Just thought I'd update you all on this. Got fed up trying to get Wifi working so I brought it back to the store where I bought it. We tried it in-store and the same problems occurred. But when we tried the display model, it seemed to work ok, so they swapped my box for a new one. Brought it home and tried it... And at first I had the same problems but shortening the SSID allowed this one to work where the first one didn't. So I'm a happy bunny :)

Bottom line: I ended up with a faulty box. The new box works well and once you don't use spaces in SSID or use WEP-128 encryption, it connects solidly and reliably.

Why would anyone use WEP? It's so weak it's as bad as having no encryption at all. WPA2-PSK is what you should be using.
Thanks for that, I'm quite well versed in network security. You'll note I never actually said I was using WEP other than for troubleshooting. Yes, it can be cracked in minutes but that's still better than no encryption at all, and will easily stop the casual nosy neighbour from stumbling onto your network. There are some niche uses for it, and the fact remains that the Humax software claims to support it but it doesn't. And yet 64-bit WEP works fine, which can be cracked even quicker than 128-bit. My original faulty box also incorrectly identified an AES-secured network for a TKIP-secured one, though I couldn't reproduce this problem with my new box however so it could've been related to the original fault. Nevertheless, the Wifi software in general seems a little "beta" to me, not helped by the fact it doesn't adhere fully to the 802.11 standard for SSIDs.

Anyway, I have a working box now so I'm happy with that. Hopefully they'll release a software update that fixes some niggles with the networking end of things and then it will be a truly excellent box.
I had issues with connecting to wifi network, Im with Virgin and have the Superhub2. I found the thing that worked for me was to open up the Reservation list on my hub and give the humax a static IP address, with unlimited reservation time. I then had to switch the hub off and on again, before the Humax and Hub were "talking". I know your saying you have it working Daedalus, but its just incase someone else looks at this for a solution, this might work for them. ;)
Hi, just got a 2000T and was reading your WIKI pages and saw that the Tenda W311U+ worked with the Humax so I got one and connected it, put in the name and code and have tried several of the security potions but all I ever get is no connection check settings. When I stand next to the machine with my tablet the tablet is getting a good signal, so what am I missing?
What you are missing is absolutely no guarantee that one non-Humax dongle will work when another one of the same "brand" works for somebody else. It's like UPDs (USB pen drives) - they are sourced from anywhere and branded up for selling on. Only by paying for a WiFi dongle sourced from Humax do you have a leg to stand on.
Hi, just got a 2000T and was reading your WIKI pages and saw that the Tenda W311U+ worked with the Humax so I got one and connected it, put in the name and code and have tried several of the security potions but all I ever get is no connection check settings. When I stand next to the machine with my tablet the tablet is getting a good signal, so what am I missing?

I had trouble getting the wifi/portal to work, even having bought the recommended Tenda USB adapter. In the end, what I had to do I think (what seems to have worked) was to set up the network, get it to say it was connected, then power down and plug out from the mains. I waited a minute (not sure that length matters) and then reconnected. I then had to redo the network hookup (select network, enter password) but now the TV portal worked!
According to Humax, dongle will only accept a wireless code of upto 8 characters. (My router was 10, so had to change my router and all other connected devices in the house.)

But I still had problems, and Humax told me not to use the rear usb for the dongle. Not helpful to me!! But then found that with a short - 20cm - usb extension cable the rear usb would work fine.
Last edited: