Wifi Connection Encryption Issue

I had problems with wifi connection using HDR2000.

They told me firstly that wireless code should be no more than 8 characters. (My router was 10, so I had to change my router and all other connected devices first.)

Still issues - but then found that dongle would work in the front USB but not in the rear. Humax response was that this sometimes occurs - just use the front!! Not convenient for me though.

Not helpful to me. But I found that with a short USB extension cable - mine was 20cm - at the rear, then the rear socket worked fine.
According to Humax, dongle will only accept a wireless code of upto 8 characters. (My router was 10, so had to change my router and all other connected devices in the house.)

But I still had problems, and Humax told me not to use the rear usb for the dongle. Not helpful to me!! But then found that with a short - 20cm - usb extension cable the rear usb would work fine.

I've used much longer wifi passwords than 8 characters with my Aunt's HDR Fox T2. Earlier software used to have a stupidly short timeout for entering the password and it would take several attempts getting faster before I could enter it in time. 1.03.12 either has no timeout or it's a lot longer.
Well, up to 10 works, because that's what I got working. I haven't tried longer. And agree with Derek Rogers, the rear USB works fine for wifi, though if your HDMI cable has a fat head, you'll need a slim extender cable to use it.
Are spaces in the pass phrase still forbidden? I never ever got my humax dongle to work. The pass phrase is 29 characters and contains 4 spaces.
Well I now have a problem connecting to my wireless network. I had a connection with my original router, and an Edimax dongle (can't recall the model, it's the one recommended in the HDR-T2 forum a couple of years ago - a aerial type thing on a short extender). Anyway, I was able to connect both the T2 and the replacement T2000 to my network using it, although the T2000 had a habit of losing the connection between uses of the portal, and I'd have to re-apply the wife settings (not enter the password again) to get it to re-connect. Anyway I replaced the PlusNet (Thompson) router with a Fritz!box to give a better wifi signal to the T2000 (amongst other things) - it's downstairs and the router is upstairs. The T2000 sees the new router just fine, 3 out of 5 bar strength, but every time I try and connect it fails, just seems to time out. The TV (sat directly above it, and with it's own dongle) on the other hand connects just fine. Password for the router security (WPA) is numeric only with 16 numbers.

EDIT: On checking, my router is set up with WPA2 (CCMP) security - I seem to recall (I'm not at home) that the T2000 is set for WPA+WPA2? So maybe that's the issue?
Last edited:
In the end I gave up trying to connect the Hummy to the Fritz!box wifi, and bought an AppleTV. I can now stream all the catchup services from my iPhone or (unless it's an ITV programme for some reason, where the iPad app doesn't work properly to mirror the display) iPad or MacBook.