1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wireless settings don't save

Discussion in 'HD-FOX T2 Freeview Receiver' started by Sam Widges, Dec 10, 2011.

  1. Sam Widges

    Sam Widges Active Member

    Does anyone else use a wireless card with their HD-T2?

    I bought an Edimax EW-7711USn recently and, when configured, the HD-T2 can see the outside world, but every time I power cycle the box (standby included) it loses the config. It wouldn't be so bad if it just forgot which wireless network it needed, but it forgets the password and once I've set that it tries DHCP, which I don't use in my network, so I have to wait a couple of minutes for the timeout and I then have to enter all the network information. This is plain infuriating for me, but SWMBO just isn't going to bother with all that faff at all.

    Is there some magic method to get the wireless settings to 'stick'?

    I have a horrible feeling that the only way to do this will be to roll my own firmware with hardcoded information :rolleyes:
     
  2. xyz321

    xyz321 Well-Known Member

    Check out the wireless-helper package.
     
  3. Black Hole

    Black Hole Ron Glum

    As above. The settings won't stick if you have your WiFi network set to hide the SSID, and the helper package (custom software) sorts that out.
     
  4. Sam Widges

    Sam Widges Active Member

    The SSID isn't hidden, but I'm giving it a go anyway.

    Is this meant to be configured through webif? It looks like the settings need to be set in the database for wifi-up to work, which I can do but I'd have thought that many other users would have a big problem with.
     
  5. Black Hole

    Black Hole Ron Glum

    Custom software / web interface, yes.
     
  6. Sam Widges

    Sam Widges Active Member

    It doesn't show in HD mode, maybe the hooks are there in HDR mode (or I'm just looking in the wrong place!)
     
  7. Black Hole

    Black Hole Ron Glum

    I shall go and turn my HD-FOX on and check (can't check the HDR... mongoose has died on me!).
     
  8. Black Hole

    Black Hole Ron Glum

    You have to enable advanced mode on the settings page, and then you get to see all the packages and not just the "safe" ones.
     
  9. Sam Widges

    Sam Widges Active Member

    That's one of the first things I turned on, even if I'm more of a CLI kind of guy :cool:

    I've already installed the package, I can't find a way of configuring the settings.
     
  10. Black Hole

    Black Hole Ron Glum

    dunno then, sorry.
     
  11. Sam Widges

    Sam Widges Active Member

    I've installed the wireless-helper package etc. on my HDR - the extra wlan entries are in the settings database but still no way of configuring them.
     
  12. af123

    af123 Administrator Staff Member

    It should pick up the settings you put in when configuring wifi in the Humax on-screen menus. You need to make sure your Ethernet cable's disconnected too.
     
  13. Sam Widges

    Sam Widges Active Member

    It looks like the settings are making it into the database, but several of the important rows are missing from the database on the HD - WLAN_AUTH_TYPE, WLAN_CONNECTED_AP and WLAN_KEY.

    Time to hard-code some values into wifi-up, I think.
     
  14. af123

    af123 Administrator Staff Member

    How are you checking whether they are empty? They are packed in the database so don't show up in the webif or via sqlite - if you run /mod/sbin/wifi-up then it should dump what's in the database though.

    I've only ever been able to test this on the HDR of course.

    I wouldn't bother with the supplicant, just edit wifi-up and hard code the values in there if necessary.
     
  15. Sam Widges

    Sam Widges Active Member

    I'm doing a database dump from webif and the rows for those values just aren't there.

    My edit and your message crossed in flight, but I did indeed hardcode entries into wifi-up and that seems to be working fine now.