1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

zyxel nsa310 will not wake from lan

Discussion in 'HD/HDR-FOX T2 Customised Firmware' started by Tron, Aug 26, 2012.

  1. Tron

    Tron New Member

    I have just got a zyxel nsa310 which works great on the network-shares-automount which I can see and play all my files. I just started to play with the wake on lan part and for the last few hours I cant seem to make it work. I have checked my mac code and made sure there is no separators or gaps. I have re booted the nas and the hummy and checked connections.
    I thought it must be the nas device so I download a wake on Lan program http://www.aquilatech.com/Software/wakeonlan which is free and wakes the nsa310 up fine and with ease.

    Has anyone else got the wake up from lan woring from the hummy to the nsa310?

    Anyone have any ideas please as I am so close to a fantastic setup. And I am thinking I must have missing something??
     
  2. Black Hole

    Black Hole Felonius Gru

    Got Wakeup=on?

    Another topic has reported a NAS which requires a specific utility to keep it awake rather than respond to the standard WoL poll. I wonder if this drive is actually compatible with the standard WoL function?
     
  3. Tron

    Tron New Member

    Thanks for your reply
    I tried in in lowercase and also caps which stays showing on for a while then resets to off (which it is meant to) . The NAS does not even it eyes.

    It seems to be not to try to keep it awake, but to get it to wake up.

    But with the windows programe (wake on lan, a normal box standard third party program) used it will then keep awake until I set a sleep time (i would guess it is just sending a normal wake up packet?? As there was no setting up first apart from ip address and mac code)

    Which makes me think I am missing something as a non branded programe work with ease with no special setup.
     
  4. xyz321

    xyz321 Well-Known Member

    Try 'ether-wake xx:xx:xx:xx:xx:xx' from a telnet prompt, where xx:xx:xx:xx:xx:xx is the MAC address of the NAS.
     
  5. Tron

    Tron New Member

    Sorry for the delay , just home from work. :(

    Well I tried the above and that worked fine and started the nas

    So whats my next steps please
     
  6. Ezra Pound

    Ezra Pound Well-Known Member

    It would be possible to add the 'ether-wake' line to a cron job on the Humax, but as you have installed network-shares-automount I guess the WOL option in there should already be doing a similar job, hence BH's question about is Wakeup=on
     
  7. Black Hole

    Black Hole Felonius Gru

    Having re-read the automount thread I am unclear about the current status of the WoL facility, we probably need comment from Drutt. Is it proven? It reads like it only works as a one-off, changing the Wakeup property to "off" after it has run. Perhaps that is the intention - only waking your NAS when you specifically ask it to do so.

    I think if you want the NAS to boot whenever the Humax boots an ether-wake line in the start-up script is the way to go.
     
  8. Ezra Pound

    Ezra Pound Well-Known Member

    It looks like the WOL command is not sent repeatedly details in #132, it is only sent once and then WakeUp is set back to off
     
  9. Tron

    Tron New Member

    Ezra
    Just to make sure I am getting it right with out any silly mistakes I will explain. The folder which is called "Wakeup=off" I rename this to "Wakeup=on" this will then stay called "Wakeup=on" for a few moments then go back to "Wakeup=off" . Is correct yes?

    Hope Drutt see's this thread and maybe he could comment as well:)

    Black hole I'm happy for it to boot only when I ask it too ( If we can get it working, fingers crossed ) at the moment.
    As I will not always want to use the Nas when I have the hummy turned on as the nas only powers down fully with either a manual button or a off timer which i will set for 12pm. So this will save it having to be switched on for most of the day when its not needed but the hummy has been turned on.

    But if I can't get it to work maybe I will have to look into this as another idea.
     
  10. Ezra Pound

    Ezra Pound Well-Known Member

    Yes, Drutt has written the code to send the command once and then reset it back to "Wakeup=off"
     
  11. xyz321

    xyz321 Well-Known Member

    The networks-shares-automount package does not use the ether-wake command, instead it contains a python script to perform the wake-up fuction.

    I did suggest adding ether-wake to crontab in a previous post but having thought about it more, the WOL packets will perform a wake up but may not keep an external device awake. Once awake it may be necessary to ping the device (or send some other packet) in order to prevent it from going to sleep. I think this may need more testing with various devices.
     
  12. Tron

    Tron New Member

    I guess adding the ether-wake to the auto mount package to work when set to "wakeup=on" is not as easy as it sounds?

    On my nas it will either stay full on if being used or go into a light sleep when a idle timer has been reached. But will start the harddrives when you access a file and wake up fully. So that should not be a problem.
    Its only the full sleep which needs a wake up ping.
     
  13. Drutt

    Drutt Active Member

    Sorry for delay replying - been away for a while. Yes this is indeed how it works. Only reason I used a python script to send the WOL packet rather than ether-wake, is that I didn't know about ether-wake ;) Could easily change the script to use it instead, but I suspect it would behave much the same.

    It is only tested with my mac-mini, and it has been working fine. However after the latest OsX update, it now goes back to sleep 30 seconds after a WOL, and network access over nft isn't deemed important enough to stay awake for (thanks Apple).
    I'm experimenting with it a little at the moment with a view keeping the mac awake while the Humax is playing a file from it. Unfortunately sending another WOL packet periodically doesn't reset the 30 second timer until it sleeps again, so you get the video freeze for a few seconds every 30.

    Only plan I've come up with so far is to write a "flag" file to the host, and have a script running on the mac forcing stay awake when the flag exists...
     
  14. Tron

    Tron New Member

    Thanks for getting back to me Drutt, I think on my set up the ether-wake would work just sending in once as the network access would keep my nas full awake and if there was a short gap or so and it went into light sleep mode,
    I think it would fully wake up again when needed.

    My NAS only fully shuts down to a wake from lan point when I set a off timer.

    If you where to change the script to ether-wake, Would I be able to try it out when you have some time please? (As I think you can add it via USB)

    As to your problem i guess the apple just loves saving power no matter if its being used or not :)
     
  15. Drutt

    Drutt Active Member

    Is the python wake up script that is currently used not working for you then? It should do the same thing as ether-wake (ie just send a WOL network packet to the specified mac address). I'll change it to use ether-wake for the next update though, just to remove the dependancy on python if nothing else...
     
  16. Tron

    Tron New Member

    No it does nouthing but if i use either-wake it will wake the NAS (I guess my NAS is being fussy)


    And thanks I look forward to the update.
     
  17. hairy_mutley

    hairy_mutley Member

    I also have a Zyxel NSA-310.
    I have been following the thread, but nothing much to offer, because I hadn't played with shutting down the NSA (was just relying on its automatic hard disk sleep).
    Anyway, though I could give it a try; for what it is worth, I am getting the same result.
    It will wake for ether-wake but not for wakeup=on.
    From the PC I use WakeOnLanEx2 (WoLEX) v2.12 from bootblock.co.uk; required no special configuration, just put in the MAC.

    @Tron Have you come across anything that will shutdown the NSA.
    I can do it from the Zyxel web interface or press the front panel button until first bleep.
    But it will not respond to any command from WoLEX other than wake.
    I would really like something that I could trigger shutdown from the PC command line.
     
  18. Tron

    Tron New Member

    Hairy_mutley I have not found anything as yet to turn it off remotely. I just set a off time in the zyxel settings for around 12pm when i know i will have no more use as it still uses a fair amount of power on soft standy (hard drive sleep mode = 16.3 watt). So its nice to shut it down as Wake-on-LAN mode as its only 0.24 watt
     
  19. hairy_mutley

    hairy_mutley Member

    I have one of those plug-in power consumption checkers, I really ought to use it! Hadn't realised the power consumption was quite that high. It really does make sense to turn on the timed power off, in fact I have now done exactly that.
     
  20. Drutt

    Drutt Active Member

    Just uploaded a new version (see here for details). Now using both ether-wake and the old script. As I can't get either-wake to wake my mac. Let me know if it works for you...