1.03.06 - Crash after booting


Well-Known Member
I've been running 1.03.06/ CF2.19 (since within a day of the update being posted) on 2HDRs: one is about 3 years old with loader 7.30, the other is approx. 1 year old with loader 7.33. Both are generally running well without significant EPG problems, but I have noticed that the older machine has been crashing once or twice a week just after booting. It is always the same, the picture breaks up, freezes and the box crashes and reboots. The newer machine does not crash but is configured in the same way with the essentially the same packages installed: the only differences I can think of is that the old box is linked to a HDFox (when it is on) by Foxlink and an SMB share (NSA) configured on the HD. Does anyone have any ideas? Has anyone else had the same problem?
I don't have any ideas but I do have an old box running with loader a7.30 and software 1.03.06 that's behaving fine.
Also, the crash.log file records the event, but does not mention that the flash packages have been disabled. Crashing definitely disables the fan and undelete packages. The fix flash packages diagnostic does not fix undelete in this case: the only way to fix it it to uninstall and reinstall through package management, and reboot.
I've just installed 1.-3.06/cf2.20 and am seeing the same behavior. Again its with an old unit. Approx 67 seconds into the boot cycle it crashes and then reboots and runs ok (mostly!)

Humax crashed at Fri Dec 13 17:05:33 UTC 2013 - Uptime: 36812
Humax crashed at Sun Dec 15 06:50:05 UTC 2013 - Uptime: 67
Humax crashed at Sun Dec 15 10:35:25 UTC 2013 - Uptime: 13497
Humax crashed at Mon Dec 16 01:32:14 UTC 2013 - Uptime: 67
Humax crashed at Mon Dec 16 06:49:48 UTC 2013 - Uptime: 66

Any suggestions as to how to diagnose what runs at power on gratefully received.
I ran fixdisk from maintenance mode and installed the 'swapper' virtual memory package and since then it has been fine. Unfortunately, I think the swapper package is no longer available. I do recommend fixdisk: it seems that numerous problems are caused by disk errors which are often corrected using this utility.
Tried fix disk. Unfortunately that did not help.
So then I tried removing the packages I had added one at a time (the ones I could remember at least) - No luck.
Next I tried the "Remove Custom Firmware ..." option from the diag menu - Still no luck

So now I have just a bare 1-03-06 system with the bare cf2.20. Not even the enhanced web-if package, and it still resets.

I'm about to roll back to 1-02-32 and try that (or 28).

Is there anyway I can find out what is causing the reboot?
Do you have anything connected to your USB ports?
Have you tried rebooting without your network connected?
Have you tried turning content share off?
Nothing connected to my usb ports.
Reboot without network connected: Not tried yet
Content Sharing off: was in the process of trying that (and ftp off) but my box is currently recording! will try in half an hour.

thanks for the suggestions - I'll try those before rolling back.
You could try doing a factory reset. You could also try going back to the last generally released version (1.02.32) without CF for a few days to see if the problem goes away though, as far as I am aware, the only significant new issue with 1.03.06 is a laggy EPG. If removing the CF does sort the problem out, you could do a bare bones CF install and try this out for a while, then gradually add any additional packages and see how it goes.
Well that fixed it!
Switched off content sharing and ftp - So it seems it was one of those 2.
Now to add back all the other packages and check its stable still.

Then I will find out which of the 2 features (content sharing or ftp) caused the problem. I'll also test without a network connection.
Do you have anything on your network using Twonky v7? this has been known to cause the Humax to reboot, v6 is apparently OK.
Perhaps you may need to reset your DLNA database from the webif diagnostics.
I suggest leaving the FTP server switched off and installing the CF package BetaFTP. This is an alternative FTP server and is widely regarded as a lot better than the Humax one.
Ah. I have twonky v7 running on my nas. Its hardly ever used so I could happily disable that or roll back a version.
I'll have a play around and isolate the problem.
Thanks again for all the helpful suggestions.